Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] VLC: Problem with playing DVDs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
solli
n00b
n00b


Joined: 31 Jul 2002
Posts: 16
Location: Graz, Austria

PostPosted: Sun Jan 11, 2009 12:38 pm    Post subject: [solved] VLC: Problem with playing DVDs Reply with quote

Hi!

My system upgraded from vlc 0.8.6 -> 0.9.8a. Before the update DVDs used to work without any problems. Since the update the first frames of a movie are played then the picture freezes and the VLC log is full of the following messages:

[00000414] main audio output warning: computed PTS is out of range (2766), clearing out
[00000414] main audio output warning: PTS is out of range (2844), dropping buffer
[00000414] main audio output warning: output PTS is out of range (13538), clearing out
[00000414] main audio output warning: PTS is out of range (-25236), dropping buffer
[00000385] main video output warning: late picture skipped (106863)
[00000414] main audio output warning: computed PTS is out of range (142790), clearing out
[00000414] main audio output warning: PTS is out of range (142860), dropping buffer
[00000414] main audio output warning: output PTS is out of range (153552), clearing out
[00000414] main audio output warning: PTS is out of range (114908), dropping buffer
[00000414] main audio output warning: PTS is out of range (86791), dropping buffer
[00000414] main audio output warning: PTS is out of range (298822), dropping buffer
[00000414] main audio output warning: PTS is out of range (270908), dropping buffer
[00000385] main video output warning: late picture skipped (322836)

The DVDs work perfectly with xine. VLC plays avi-files without any problems so only the DVDs don't work anymore.

Any ideas?

Stef


Last edited by solli on Wed Feb 04, 2009 4:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
BdON
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jan 2007
Posts: 127

PostPosted: Tue Jan 13, 2009 3:51 pm    Post subject: Reply with quote

I have the same problem. I was not able to fix it but I found a way around it. When you open the DVD, you need to increase the buffer length. The default is 300ms and I had to use values ranging from 3000-10000ms depending on the movie.

If anyone has a way to actually fix it, please post it because I would like to know it as well
Back to top
View user's profile Send private message
solli
n00b
n00b


Joined: 31 Jul 2002
Posts: 16
Location: Graz, Austria

PostPosted: Sun Jan 18, 2009 9:18 am    Post subject: Reply with quote

For me not even this works. I set the dvdread-buffer from 300ms to 10000ms. The only thing that changed was the time until the first picture showed up, then it freezed again.

It seems that not many people are having this problem :-( Since LIRC doesn't work either for vlc since the update (the affected computer is my media center with LIRC and no keyboard) I guess I'll switch to xine.

Unfortunately there's no downgrade possibility for vlc. Shouldn't there be at least two versions in the portage tree (one 0.8.x and one 0.9.x)?

Stefan
Back to top
View user's profile Send private message
jcvet
n00b
n00b


Joined: 24 Jan 2009
Posts: 2
Location: Dimondale,MI

PostPosted: Sat Jan 24, 2009 8:33 pm    Post subject: VLC: Problem with playing DVDs Reply with quote

Hello !!
I am a noob at posting so I hope this works OK.

This may work for you. I had the same problem. There are 2 places in the kernel that need to be checked. On my Gentoo install they were not by default.
I use genkernel to modify and compile the kernel.
#genkernel --menuconfig all (as root)
Pick "Processor type and features --->"
"[ ] High Resolution Timer Support" change to "[*] High Resolution Timer Support"
Then further down on the list:
"[ ] HPET Timer Support" change to "[* ] HPET Timer Support"
I also defaulted to a 486 processor type. This should not be necessary to change but under "Processor family" I picked my processor.
recompile and reboot.
I am using the onboard intel chips on a GX270. (so intel drivers) Compiled as a stable (x86) system No extra video card. I am not sure if Nvidia or Ati have these problems. I can list more specifics about my system and use flags if needed.

Let me know if this works.
jcvet
Back to top
View user's profile Send private message
solli
n00b
n00b


Joined: 31 Jul 2002
Posts: 16
Location: Graz, Austria

PostPosted: Mon Jan 26, 2009 3:55 pm    Post subject: Reply with quote

Hi jcvet!
You're my hero :-) Setting the first two options in the kernel config made my VLC work again!
thx!
Stefan
Back to top
View user's profile Send private message
szacks
n00b
n00b


Joined: 09 Mar 2005
Posts: 61

PostPosted: Mon Mar 23, 2009 6:52 am    Post subject: Reply with quote

I'm having the same problem.
My kernel is 2.6.21 from gentoo-sources and I don't have the options:
High Resolution Timer Support or
HPET Timer Support

in my Processor type and features menu.
Is this only in newer kernels?

Thanks
Sim
Back to top
View user's profile Send private message
cyberbat
n00b
n00b


Joined: 31 Jan 2011
Posts: 7

PostPosted: Mon Mar 28, 2011 6:45 pm    Post subject: Re: VLC: Problem with playing DVDs Reply with quote

jcvet wrote:

Pick "Processor type and features --->"
"[ ] High Resolution Timer Support" change to "[*] High Resolution Timer Support"
Then further down on the list:
"[ ] HPET Timer Support" change to "[* ] HPET Timer Support"


Big big big thanks to you, man! This thread is the only place where I've found a solution in whole internet. I have just one question: how (HOW???) have you guessed that DVD playing by VLC depends on this two options?

Thanks a lot again.
Back to top
View user's profile Send private message
equus
n00b
n00b


Joined: 16 Jan 2005
Posts: 7

PostPosted: Sat Jul 27, 2013 12:32 pm    Post subject: Re: VLC: Problem with playing DVDs Reply with quote

jcvet wrote:
Hello !!
I am a noob at posting so I hope this works OK.

This may work for you. I had the same problem. There are 2 places in the kernel that need to be checked. On my Gentoo install they were not by default.
I use genkernel to modify and compile the kernel.
#genkernel --menuconfig all (as root)
Pick "Processor type and features --->"
"[ ] High Resolution Timer Support" change to "[*] High Resolution Timer Support"
Then further down on the list:
"[ ] HPET Timer Support" change to "[* ] HPET Timer Support"
I also defaulted to a 486 processor type. This should not be necessary to change but under "Processor family" I picked my processor.
recompile and reboot.
I am using the onboard intel chips on a GX270. (so intel drivers) Compiled as a stable (x86) system No extra video card. I am not sure if Nvidia or Ati have these problems. I can list more specifics about my system and use flags if needed.

Let me know if this works.
jcvet


Thanks jcvet !

This worked for me too.

In my case (kernel 3.8.13), I just had to check :

[*] High Resolution Timer Support

in :
General setup --->
Timers subsystem --->

Rebuild the kernel, reboot, and... DVD playback works flawlessly again.

Kind Regards.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum