Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Which use flags should I use for Firefox?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Jonathan_R
n00b
n00b


Joined: 21 Mar 2011
Posts: 17

PostPosted: Mon Dec 16, 2013 8:50 pm    Post subject: Which use flags should I use for Firefox? Reply with quote

If I want all the plugins enabled for Firefox, which use flags should I use? I thought I saw a thread on this before, but I can't find it now. I want acroread, quicktime, flash, shumway (if I can do shumway I may not need flash), java, libreoffice, vlc, xine (and of course with vlc and xine I want all the codecs and plugins enabled on those as well). I may have forgotten a few, but hopefully you get the idea.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4737

PostPosted: Mon Dec 16, 2013 9:28 pm    Post subject: Reply with quote

use equery to get a human readable explain of use flag for a package.
equery is from app-portage/gentoolkit

Code:
equery u firefox
equery u vlc


Because many plugins for firefox won't be provide by firefox itself, but from others package with an option to have them or not.
Back to top
View user's profile Send private message
Jonathan_R
n00b
n00b


Joined: 21 Mar 2011
Posts: 17

PostPosted: Mon Dec 16, 2013 9:55 pm    Post subject: Reply with quote

krinn wrote:
use equery to get a human readable explain of use flag for a package.
equery is from app-portage/gentoolkit

Code:
equery u firefox
equery u vlc


Because many plugins for firefox won't be provide by firefox itself, but from others package with an option to have them or not.


I know which flags go with Firefox, but it's the ones that I listed that I'm not sure of. I listed below the flags that go with firefox from the use variable description site. http://www.gentoo.org/dyn/use-index.xml

firefox bindist Disable official Firefox branding (icons, name) which are not binary-redistributable according to upstream.
custom-optimization Fine-tune custom compiler optimizations (-Os, -O0, -O1, -O2, -O3)
ipc Use inter-process communication between tabs and plugins. Allows for greater stability in case of plugin crashes
minimal Prevent sdk and headers from being installed
pgo Add support for profile-guided optimization using gcc-4.5, for faster binaries. This option will double the compile time.
system-cairo Use the system-wide x11-libs/cairo Use system cairo instead of bundled.
system-icu Use the system-wide dev-libs/icu Use system icu instead of bundled.
system-jpeg Use the system-wide media-libs/libjpeg-turbo Use system jpeg instead of bundled.
system-sqlite Use the system-wide dev-db/sqlite installation with secure-delete enabled
webm Use system media-libs/libvpx for HTML5 WebM video support.
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 866
Location: Montréal

PostPosted: Mon Dec 16, 2013 10:21 pm    Post subject: Reply with quote

You can set the firefox, mozilla and nsplugin USE flags globally, so every package that have support for Firefox, Mozilla and Netscape will enable it.

For the codecs of Mplayer, Vlc and Xine (through the xine-lib package USE flags), again it is simpler to enable them globally so, all the codecs you which to have will be enabled in each player. A lot of codecs are common between them, some are not. The ffmpeg package USE flags enable a lot of codecs for all for them too.

There is no USE fLag to have Mplayer, Vlc and Xine plugin for Firefox. There is an mplayer USE flag, but not for Firefox. If you install the gecko-mediaplayer package, you will get Mplayer as a Firefox plugin through Gnome-mplayer.

You will not get shumway through Portage. Other than adobe-flash, I see you can try Gnash (nsplugin USE flasg), Lightspark and swfdec-mozilla. I know that Gnash Firefox plugin do not work with a lot of Flash applets but work on Youtube. Lightspark do not compile and swfdec-mozilla do not work.

On my side, I have to disable the material acceleration of the Adobe Flash plugin in Seamonky to advoid a complete Gentoo freeze.

You can use the application you want for a mime-type in the Firefox Preferences.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum