Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Need to autorun some xset commands in LXDE [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5365

PostPosted: Tue May 28, 2013 7:52 pm    Post subject: Need to autorun some xset commands in LXDE [SOLVED] Reply with quote

I need to put

Code:

xset -dpms
xset s noblank
xset s off


somewhere in my LXDE setup. I've tried using .xinitrc with no luck. Is there some other way to make this happen when LXDM starts or when the user logs in?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Linux 'Tude Tees: http://moodytudetees.com/index.php/linux-tude-tees


Last edited by audiodef on Fri May 31, 2013 3:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5100
Location: Saint Amant, Acadiana

PostPosted: Tue May 28, 2013 8:45 pm    Post subject: Reply with quote

~/.config/openbox/autostart.sh

If my memory serves me correctly and Openbox is default WM for LXDE.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1775

PostPosted: Tue May 28, 2013 9:39 pm    Post subject: Reply with quote

Good memory, just one slight error. The path should not include the ".sh" at the end. The file should exist and have comments already.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Wed May 29, 2013 4:55 am    Post subject: Reply with quote

The other file that you were looking for was ~/.Xresources.

From a quick search on google, that file is apparently depreciated now, but it was used by login managers, much like startx does with .xinitrc.

At one point, I had one of those files that I maintained, and the other was a link.

HTH
_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5365

PostPosted: Wed May 29, 2013 3:55 pm    Post subject: Reply with quote

~/.config/openbox/autostart didn't exist on my system, so I created the file and did chmod +x on it. The file contains:

Code:

xset -dmps
xset s noblank
xset s off


After logging out and back in, that didn't work.

That series of commands DOES work if I enter them manually in lxterminal, so I know it's not something else overriding it.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Linux 'Tude Tees: http://moodytudetees.com/index.php/linux-tude-tees
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5100
Location: Saint Amant, Acadiana

PostPosted: Wed May 29, 2013 8:36 pm    Post subject: Reply with quote

Well, the link for Openbox is here: http://openbox.org/wiki/Help:Autostart
It seems .sh has been dropped as Doctor mentioned ... another question is how LXDE is using Openbox ... maybe this helps http://wiki.lxde.org/en/LXSession#Automatically_start_some_applications_on_login
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 889
Location: Montréal

PostPosted: Thu May 30, 2013 2:23 am    Post subject: Reply with quote

It can be hard to know where your xset commands are changed in Lxde startup. It can come from the Xdg stuff that is started with a lot of X clients. It can come from your Session parameters/Autostart applications in the Preferences menu of Lxde. I have disabled most of the things that Lxde can start with itself there.

I setup a couple of xset commands in my .xinitrc like 'xset -dpms'. An 'xset q' after Lxde is started say that DPMS is disabled. Note that if you use Openbox to execute your commands, you cannot change the window manager of Lxde, for example Compiz like I do, and keep your commands executes.

You can create a script that you can use to execute your commands and finish it with the window manager you want to use with Lxde and put the script path in the Preferences/Session parameters/Advanced options/Window manager. Just hope that your script will be execute at the end of Lxde startup.

:D
_________________
Paul
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5365

PostPosted: Fri May 31, 2013 3:28 pm    Post subject: Reply with quote

Thanks for all the replies. :)

What ended up working was creating an autostart file in ~/.config/lxsession/LXDE.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Linux 'Tude Tees: http://moodytudetees.com/index.php/linux-tude-tees
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum