Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(older) googleearth ebuilds won't work any longer ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2617
Location: Hamburg/Germany

PostPosted: Thu May 30, 2013 8:42 am    Post subject: (older) googleearth ebuilds won't work any longer ? Reply with quote

Hello,

I'm wondering why older GE ebuilds won't work any longer, I always get something like
Code:
!!! Fetched file: GoogleEarthLnux-6.2.2.6613_i386.deb VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      45551694
!!! Expected: 25620810

Furthermore the ebuilds have to be tweaked b/c the package content seems to be changed :
Code:
$ diff -u /usr/portage/sci-geosciences/googleearth/googleearth-6.2.2.6613.ebuild /usr/local/portage/sci-geosciences/googleearth/googleearth-6.2.2.6613.ebuild
--- /usr/portage/sci-geosciences/googleearth/googleearth-6.2.2.6613.ebuild      2013-04-21 21:31:29.000000000 +0200
+++ /usr/local/portage/sci-geosciences/googleearth/googleearth-6.2.2.6613.ebuild        2013-05-29 18:26:05.539245673 +0200
@@ -102,14 +102,14 @@
                rm -v libQt{Core,Gui,Network,WebKit}.so.4 qt.conf || die
                rm -frv plugins/imageformats || die
        fi
-       rm -v libcurl.so.4 || die
+       rm -v libcurl.so.4
        if ! use mdns-bundled; then
-               rm -v libnss_mdns4_minimal.so.2 || die
+               rm -v libnss_mdns4_minimal.so.2
        fi

        if use x86; then
                # no 32 bit libs for gdal
-               rm -v libgdal.so.1 || die
+               rm -v libgdal.so.1
        fi
 }
For me it looks like the packages were changed but not their names - at least for the i386 systems.

Any hints about the culprit ?

FWIW already filed bug reports about this but no answer about the culprit so far : https://bugs.gentoo.org/show_bug.cgi?id=471722 and https://bugs.gentoo.org/show_bug.cgi?id=471674
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1363

PostPosted: Thu May 30, 2013 9:32 am    Post subject: Reply with quote

They work, there is no culprit, this is invalid.

Anyone experiencing this problem, wait at least a day and sync your Portage tree again...
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1533
Location: Just over the horizon

PostPosted: Thu May 30, 2013 10:28 am    Post subject: Reply with quote

This is what emerge outputs when I try to go back from 7.1.X to 7.0.X. I'm not sure if this is the same issue that's causing the problem for you.

Code:
!!! Couldn't download 'GoogleEarthLinux-7.0.3.8542_amd64.deb'. Aborting.
 * Fetch failed for 'sci-geosciences/googleearth-7.0.3.8542', Log file:
 *  '/var/tmp/portage/sci-geosciences/googleearth-7.0.3.8542/temp/build.log'
 * Wrong checksum or file size means that Google silently replaced the distfile with a newer version.
 * Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump.
 * Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for googleearth first!).
 * By redigesting the file yourself, you will install a different version than the ebuild says, untested!

>>> Failed to emerge sci-geosciences/googleearth-7.0.3.8542, Log file:

>>>  '/var/tmp/portage/sci-geosciences/googleearth-7.0.3.8542/temp/build.log'
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1363

PostPosted: Thu May 30, 2013 10:30 am    Post subject: Reply with quote

Quote:
* Wrong checksum or file size means that Google silently replaced the distfile with a newer version.
* Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump.
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2617
Location: Hamburg/Germany

PostPosted: Thu May 30, 2013 10:36 am    Post subject: Reply with quote

yep,
Quote:
Google silently replaced the distfile
such a behaviour of G make those ebuilds a moving target. I fear not easy to maintain (or much more worse, frustrating ?)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum