Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]xorg.conf for multiple video cards(onboard intel and
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
venustomars
n00b
n00b


Joined: 22 Sep 2008
Posts: 24

PostPosted: Wed May 29, 2013 5:37 am    Post subject: [solved]xorg.conf for multiple video cards(onboard intel and Reply with quote

I recently upgraded my mobo/CPU and since it includes onboard video I decided to hook up my TV (HDMI) to the onboard intel and let the nvidia GPU run my two DVI monitors (previously I had all 3 connected to nvidia but I have to toggle one of my monitors off when I wanted to use the television). I am having quite a bit of trouble configuring X to recognize both video cards.

I've added nvidia and intel in make.conf, emerged nvidia-drivers and xf86-input-video, and the i915 kernel module.

xorg.0.log:
Code:

[  1514.986]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[  1514.986] X Protocol Version 11, Revision 0
[  1514.986] Build Operating System: Linux 3.2.12-gentoo x86_64 Gentoo
[  1514.986] Current Operating System: Linux nexus 3.8.13-gentoo #14 SMP PREEMPT Wed May 29 01:00:59 EDT 2013 x86_64
[  1514.986] Kernel command line: noapi clock=pmtmr notsc no_timer_check root=/dev/sda4
[  1514.986] Build Date: 23 April 2013  09:44:54PM
[  1514.986] 
[  1514.986] Current version of pixman: 0.28.0
[  1514.986]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  1514.986] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1514.986] (==) Log file: "/var/log/Xorg.0.log", Time: Wed May 29 01:28:54 2013
[  1514.986] (==) Using config file: "/etc/X11/xorg.conf"
[  1514.986] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1514.986] (==) ServerLayout "X.org Configured"
[  1514.986] (**) |-->Screen "Screen0" (0)
[  1514.986] (**) |   |-->Monitor "Monitor0"
[  1514.986] (**) |   |-->Device "Device0"
[  1514.987] (**) |-->Input Device "Keyboard0"
[  1514.987] (**) |-->Input Device "Mouse0"
[  1514.987] (**) Option "DontVTSwitch" "off"
[  1514.987] (**) Option "BlankTime" "0"
[  1514.987] (**) Option "StandbyTime" "0"
[  1514.987] (**) Option "SuspendTime" "40"
[  1514.987] (**) Option "Xinerama" "0"
[  1514.987] (**) Option "AutoAddDevices" "on"
[  1514.987] (**) Option "AutoEnableDevices" "on"
[  1514.987] (**) Automatically adding devices
[  1514.987] (**) Automatically enabling devices
[  1514.987] (==) Automatically adding GPU devices
[  1514.987] (WW) The directory "/usr/share/fonts/freefont" does not exist.
[  1514.987]    Entry deleted from font path.
[  1514.987] (WW) The directory "/usr/share/fonts/artwiz-aleczapka-en" does not exist.
[  1514.987]    Entry deleted from font path.
[  1514.987] (WW) The directory "/usr/share/fonts/local" does not exist.
[  1514.987]    Entry deleted from font path.
[  1514.987] (**) FontPath set to:
   /usr/share/fonts/misc:unscaled,
   /usr/share/fonts/Type1,
   /usr/share/fonts/TTF,
   /usr/share/fonts/corefonts,
   /usr/share/fonts/sharefonts,
   /usr/share/fonts/ttf-bitstream-vera,
   /usr/share/fonts/75dpi:unscaled,
   /usr/share/fonts/100dpi:unscaled,
   /usr/share/fonts/unifont,
   /usr/share/fonts/texcm-ttf,
   /usr/share/fonts/cyrillic,
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[  1514.987] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  1514.987] (**) Extension "Composite" is disabled
[  1514.987] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  1514.987] (WW) Disabling Keyboard0
[  1514.987] (WW) Disabling Mouse0
[  1514.987] (II) Loader magic: 0x7f3be0
[  1514.987] (II) Module ABI versions:
[  1514.987]    X.Org ANSI C Emulation: 0.4
[  1514.987]    X.Org Video Driver: 13.1
[  1514.987]    X.Org XInput driver : 18.0
[  1514.987]    X.Org Server Extension : 7.0
[  1514.987] (II) config/udev: Adding drm device (/dev/dri/card0)
[  1514.989] (--) PCI: (0:0:2:0) 8086:0162:1458:d000 rev 9, Mem @ 0xf6400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[  1514.989] (--) PCI:*(0:1:0:0) 10de:1200:19da:1209 rev 161, Mem @ 0xf4000000/33554432, 0xe0000000/134217728, 0xe8000000/67108864, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[  1514.989] (II) Open ACPI successful (/var/run/acpid.socket)
[  1514.989] Initializing built-in extension Generic Event Extension
[  1514.989] Initializing built-in extension SHAPE
[  1514.989] Initializing built-in extension MIT-SHM
[  1514.989] Initializing built-in extension XInputExtension
[  1514.989] Initializing built-in extension XTEST
[  1514.989] Initializing built-in extension BIG-REQUESTS
[  1514.989] Initializing built-in extension SYNC
[  1514.989] Initializing built-in extension XKEYBOARD
[  1514.989] Initializing built-in extension XC-MISC
[  1514.989] Initializing built-in extension XINERAMA
[  1514.989] Initializing built-in extension XFIXES
[  1514.989] Initializing built-in extension RENDER
[  1514.989] Initializing built-in extension RANDR
[  1514.989] Initializing built-in extension COMPOSITE
[  1514.989] Initializing built-in extension DAMAGE
[  1514.989] Initializing built-in extension MIT-SCREEN-SAVER
[  1514.989] Initializing built-in extension DOUBLE-BUFFER
[  1514.989] Initializing built-in extension RECORD
[  1514.989] Initializing built-in extension DPMS
[  1514.989] Initializing built-in extension X-Resource
[  1514.989] Initializing built-in extension XVideo
[  1514.989] Initializing built-in extension XVideo-MotionCompensation
[  1514.989] Initializing built-in extension XFree86-VidModeExtension
[  1514.989] Initializing built-in extension XFree86-DGA
[  1514.989] Initializing built-in extension XFree86-DRI
[  1514.989] Initializing built-in extension DRI2
[  1514.989] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  1514.989] (II) LoadModule: "glx"
[  1514.989] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  1514.996] (II) Module glx: vendor="NVIDIA Corporation"
[  1514.996]    compiled for 4.0.2, module version = 1.0.0
[  1514.996]    Module class: X.Org Server Extension
[  1514.996] (II) NVIDIA GLX Module  319.23  Thu May 16 19:23:10 PDT 2013
[  1514.996] Loading extension GLX
[  1514.996] (II) LoadModule: "extmod"
[  1514.996] (II) Module "extmod" already built-in
[  1514.996] (II) LoadModule: "xtrap"
[  1514.996] (WW) Warning, couldn't open module xtrap
[  1514.996] (II) UnloadModule: "xtrap"
[  1514.996] (II) Unloading xtrap
[  1514.996] (EE) Failed to load module "xtrap" (module does not exist, 0)
[  1514.996] (II) LoadModule: "record"
[  1514.996] (II) Module "record" already built-in
[  1514.996] (II) LoadModule: "dbe"
[  1514.996] (II) Module "dbe" already built-in
[  1514.996] (II) LoadModule: "nvidia"
[  1514.996] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  1514.996] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1514.996]    compiled for 4.0.2, module version = 1.0.0
[  1514.996]    Module class: X.Org Video Driver
[  1514.996] (II) NVIDIA dlloader X Driver  319.23  Thu May 16 19:02:20 PDT 2013
[  1514.996] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1514.996] (++) using VT number 8

[  1514.997] (II) Loading sub module "fb"
[  1514.997] (II) LoadModule: "fb"
[  1514.997] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  1514.998] (II) Module fb: vendor="X.Org Foundation"
[  1514.998]    compiled for 1.13.4, module version = 1.0.0
[  1514.998]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1514.998] (WW) Unresolved symbol: fbGetGCPrivateKey
[  1514.998] (II) Loading sub module "wfb"
[  1514.998] (II) LoadModule: "wfb"
[  1514.998] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[  1514.998] (II) Module wfb: vendor="X.Org Foundation"
[  1514.998]    compiled for 1.13.4, module version = 1.0.0
[  1514.998]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1514.998] (II) Loading sub module "shadow"
[  1514.998] (II) LoadModule: "shadow"
[  1514.998] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[  1514.998] (II) Module shadow: vendor="X.Org Foundation"
[  1514.998]    compiled for 1.13.4, module version = 1.1.0
[  1514.998]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1514.998] (II) Loading sub module "ramdac"
[  1514.998] (II) LoadModule: "ramdac"
[  1514.998] (II) Module "ramdac" already built-in
[  1514.998] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[  1514.998] (==) NVIDIA(0): RGB weight 888
[  1514.998] (==) NVIDIA(0): Default visual is TrueColor
[  1514.998] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  1514.998] (**) NVIDIA(0): Enabling 2D acceleration
[  1515.281] (II) NVIDIA(GPU-0): Display (DELL U2312HM (DFP-0)) does not support NVIDIA 3D
[  1515.281] (II) NVIDIA(GPU-0):     Vision stereo.
[  1515.282] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 560 Ti (GF114) at PCI:1:0:0 (GPU-0)
[  1515.282] (--) NVIDIA(0): Memory: 1048576 kBytes
[  1515.282] (--) NVIDIA(0): VideoBIOS: 70.24.24.00.03
[  1515.282] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  1515.283] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 560 Ti at PCI:1:0:0
[  1515.284] (--) NVIDIA(0):     CRT-0
[  1515.284] (--) NVIDIA(0):     CRT-1
[  1515.284] (--) NVIDIA(0):     DELL U2312HM (DFP-0) (boot, connected)
[  1515.284] (--) NVIDIA(0):     DFP-1
[  1515.284] (--) NVIDIA(0):     DFP-2
[  1515.284] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[  1515.284] (--) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
[  1515.284] (--) NVIDIA(0): DELL U2312HM (DFP-0): 330.0 MHz maximum pixel clock
[  1515.284] (--) NVIDIA(0): DELL U2312HM (DFP-0): Internal Dual Link TMDS
[  1515.284] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[  1515.284] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[  1515.284] (--) NVIDIA(0): DFP-2: 330.0 MHz maximum pixel clock
[  1515.284] (--) NVIDIA(0): DFP-2: Internal Single Link TMDS
[  1515.284] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[  1515.284] (**) NVIDIA(0):     device DELL U2312HM (DFP-0) (Using EDID frequencies has
[  1515.284] (**) NVIDIA(0):     been enabled on all display devices.)
[  1515.284] (==) NVIDIA(0):
[  1515.284] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[  1515.284] (==) NVIDIA(0):     will be used as the requested mode.
[  1515.284] (==) NVIDIA(0):
[  1515.284] (II) NVIDIA(0): Validated MetaModes:
[  1515.284] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select{}"
[  1515.284] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[  1515.310] (--) NVIDIA(0): DPI set to (95, 94); computed from "UseEdidDpi" X config
[  1515.310] (--) NVIDIA(0):     option
[  1515.310] (--) Depth 24 pixmap format is 32 bpp
[  1515.310] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[  1515.310] (II) NVIDIA:     access.
[  1515.313] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select{}"
[  1515.340] Loading extension NV-GLX
[  1515.386] (==) NVIDIA(0): Disabling shared memory pixmaps
[  1515.386] (==) NVIDIA(0): Backing store disabled
[  1515.386] (==) NVIDIA(0): Silken mouse enabled
[  1515.386] (==) NVIDIA(0): DPMS enabled
[  1515.386] Loading extension NV-CONTROL
[  1515.386] Loading extension XINERAMA
[  1515.386] (II) Loading sub module "dri2"
[  1515.386] (II) LoadModule: "dri2"
[  1515.386] (II) Module "dri2" already built-in
[  1515.386] (II) NVIDIA(0): [DRI2] Setup complete
[  1515.386] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[  1515.386] (--) RandR disabled
[  1515.389] (II) Initializing extension GLX
[  1515.447] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[  1515.447] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  1515.447] (II) LoadModule: "evdev"
[  1515.448] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  1515.448] (II) Module evdev: vendor="X.Org Foundation"
[  1515.448]    compiled for 1.13.1, module version = 2.7.3
[  1515.448]    Module class: X.Org XInput Driver
[  1515.448]    ABI class: X.Org XInput driver, version 18.0
[  1515.448] (II) Using input driver 'evdev' for 'Power Button'
[  1515.448] (**) Power Button: always reports core events
[  1515.448] (**) evdev: Power Button: Device: "/dev/input/event1"
[  1515.448] (--) evdev: Power Button: Vendor 0 Product 0x1
[  1515.448] (--) evdev: Power Button: Found keys
[  1515.448] (II) evdev: Power Button: Configuring as keyboard
[  1515.448] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[  1515.448] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  1515.448] (**) Option "xkb_rules" "evdev"
[  1515.448] (**) Option "xkb_model" "evdev"
[  1515.448] (**) Option "xkb_layout" "us"
[  1515.467] (II) config/udev: Adding input device Video Bus (/dev/input/event2)
[  1515.467] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  1515.467] (II) Using input driver 'evdev' for 'Video Bus'
[  1515.467] (**) Video Bus: always reports core events
[  1515.467] (**) evdev: Video Bus: Device: "/dev/input/event2"
[  1515.467] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  1515.467] (--) evdev: Video Bus: Found keys
[  1515.467] (II) evdev: Video Bus: Configuring as keyboard
[  1515.468] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input2/event2"
[  1515.468] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[  1515.468] (**) Option "xkb_rules" "evdev"
[  1515.468] (**) Option "xkb_model" "evdev"
[  1515.468] (**) Option "xkb_layout" "us"
[  1515.468] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[  1515.468] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  1515.468] (II) Using input driver 'evdev' for 'Power Button'
[  1515.468] (**) Power Button: always reports core events
[  1515.468] (**) evdev: Power Button: Device: "/dev/input/event0"
[  1515.468] (--) evdev: Power Button: Vendor 0 Product 0x1
[  1515.468] (--) evdev: Power Button: Found keys
[  1515.468] (II) evdev: Power Button: Configuring as keyboard
[  1515.468] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[  1515.468] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[  1515.468] (**) Option "xkb_rules" "evdev"
[  1515.468] (**) Option "xkb_model" "evdev"
[  1515.468] (**) Option "xkb_layout" "us"
[  1515.468] (II) config/udev: Adding drm device (/dev/dri/card0)
[  1515.469] (II) config/udev: Adding input device Logitech G9x Laser Mouse (/dev/input/event3)
[  1515.469] (**) Logitech G9x Laser Mouse: Applying InputClass "evdev pointer catchall"
[  1515.469] (II) Using input driver 'evdev' for 'Logitech G9x Laser Mouse'
[  1515.469] (**) Logitech G9x Laser Mouse: always reports core events
[  1515.469] (**) evdev: Logitech G9x Laser Mouse: Device: "/dev/input/event3"
[  1515.469] (--) evdev: Logitech G9x Laser Mouse: Vendor 0x46d Product 0xc066
[  1515.469] (--) evdev: Logitech G9x Laser Mouse: Found 20 mouse buttons
[  1515.469] (--) evdev: Logitech G9x Laser Mouse: Found scroll wheel(s)
[  1515.469] (--) evdev: Logitech G9x Laser Mouse: Found relative axes
[  1515.469] (--) evdev: Logitech G9x Laser Mouse: Found x and y relative axes
[  1515.469] (II) evdev: Logitech G9x Laser Mouse: Configuring as mouse
[  1515.469] (II) evdev: Logitech G9x Laser Mouse: Adding scrollwheel support
[  1515.469] (**) evdev: Logitech G9x Laser Mouse: YAxisMapping: buttons 4 and 5
[  1515.469] (**) evdev: Logitech G9x Laser Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  1515.469] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.0/input/input3/event3"
[  1515.469] (II) XINPUT: Adding extended input device "Logitech G9x Laser Mouse" (type: MOUSE, id 9)
[  1515.469] (II) evdev: Logitech G9x Laser Mouse: initialized for relative axes.
[  1515.469] (**) Logitech G9x Laser Mouse: (accel) keeping acceleration scheme 1
[  1515.469] (**) Logitech G9x Laser Mouse: (accel) acceleration profile 0
[  1515.469] (**) Logitech G9x Laser Mouse: (accel) acceleration factor: 2.000
[  1515.469] (**) Logitech G9x Laser Mouse: (accel) acceleration threshold: 4
[  1515.470] (II) config/udev: Adding input device Logitech G9x Laser Mouse (/dev/input/mouse0)
[  1515.470] (II) No input driver specified, ignoring this device.
[  1515.470] (II) This device may have been added with another device file.
[  1515.470] (II) config/udev: Adding input device Logitech G9x Laser Mouse (/dev/input/event4)
[  1515.470] (**) Logitech G9x Laser Mouse: Applying InputClass "evdev keyboard catchall"
[  1515.470] (II) Using input driver 'evdev' for 'Logitech G9x Laser Mouse'
[  1515.470] (**) Logitech G9x Laser Mouse: always reports core events
[  1515.470] (**) evdev: Logitech G9x Laser Mouse: Device: "/dev/input/event4"
[  1515.470] (--) evdev: Logitech G9x Laser Mouse: Vendor 0x46d Product 0xc066
[  1515.470] (--) evdev: Logitech G9x Laser Mouse: Found 1 mouse buttons
[  1515.470] (--) evdev: Logitech G9x Laser Mouse: Found scroll wheel(s)
[  1515.470] (--) evdev: Logitech G9x Laser Mouse: Found relative axes
[  1515.470] (II) evdev: Logitech G9x Laser Mouse: Forcing relative x/y axes to exist.
[  1515.470] (--) evdev: Logitech G9x Laser Mouse: Found absolute axes
[  1516.470] (II) evdev: Logitech G9x Laser Mouse: Forcing absolute x/y axes to exist.
[  1515.470] (--) evdev: Logitech G9x Laser Mouse: Found keys
[  1515.470] (II) evdev: Logitech G9x Laser Mouse: Configuring as mouse
[  1515.470] (II) evdev: Logitech G9x Laser Mouse: Configuring as keyboard
[  1515.470] (II) evdev: Logitech G9x Laser Mouse: Adding scrollwheel support
[  1515.470] (**) evdev: Logitech G9x Laser Mouse: YAxisMapping: buttons 4 and 5
[  1515.470] (**) evdev: Logitech G9x Laser Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  1515.470] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.1/input/input4/event4"
[  1515.470] (II) XINPUT: Adding extended input device "Logitech G9x Laser Mouse" (type: KEYBOARD, id 10)
[  1515.470] (**) Option "xkb_rules" "evdev"
[  1515.470] (**) Option "xkb_model" "evdev"
[  1515.470] (**) Option "xkb_layout" "us"
[  1515.470] (II) evdev: Logitech G9x Laser Mouse: initialized for relative axes.
[  1515.470] (WW) evdev: Logitech G9x Laser Mouse: ignoring absolute axes.
[  1515.471] (**) Logitech G9x Laser Mouse: (accel) keeping acceleration scheme 1
[  1515.471] (**) Logitech G9x Laser Mouse: (accel) acceleration profile 0
[  1515.471] (**) Logitech G9x Laser Mouse: (accel) acceleration factor: 2.000
[  1515.471] (**) Logitech G9x Laser Mouse: (accel) acceleration threshold: 4
[  1515.471] (II) config/udev: Adding input device CYKB23 USB Keyboard (/dev/input/event5)
[  1515.471] (**) CYKB23 USB Keyboard: Applying InputClass "evdev keyboard catchall"
[  1515.471] (II) Using input driver 'evdev' for 'CYKB23 USB Keyboard'
[  1515.471] (**) CYKB23 USB Keyboard: always reports core events
[  1515.471] (**) evdev: CYKB23 USB Keyboard: Device: "/dev/input/event5"
[  1515.471] (--) evdev: CYKB23 USB Keyboard: Vendor 0x4d9 Product 0x2323
[  1515.471] (--) evdev: CYKB23 USB Keyboard: Found keys
[  1515.471] (II) evdev: CYKB23 USB Keyboard: Configuring as keyboard
[  1515.471] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.0/input/input5/event5"
[  1515.471] (II) XINPUT: Adding extended input device "CYKB23 USB Keyboard" (type: KEYBOARD, id 11)
[  1515.471] (**) Option "xkb_rules" "evdev"
[  1515.471] (**) Option "xkb_model" "evdev"
[  1515.471] (**) Option "xkb_layout" "us"
[  1515.472] (II) config/udev: Adding input device CYKB23 USB Keyboard (/dev/input/event6)
[  1515.472] (**) CYKB23 USB Keyboard: Applying InputClass "evdev keyboard catchall"
[  1515.472] (II) Using input driver 'evdev' for 'CYKB23 USB Keyboard'
[  1515.472] (**) CYKB23 USB Keyboard: always reports core events
[  1515.472] (**) evdev: CYKB23 USB Keyboard: Device: "/dev/input/event6"
[  1515.472] (--) evdev: CYKB23 USB Keyboard: Vendor 0x4d9 Product 0x2323
[  1515.472] (--) evdev: CYKB23 USB Keyboard: Found keys
[  1515.472] (II) evdev: CYKB23 USB Keyboard: Configuring as keyboard
[  1515.472] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.1/input/input6/event6"
[  1515.472] (II) XINPUT: Adding extended input device "CYKB23 USB Keyboard" (type: KEYBOARD, id 12)
[  1515.472] (**) Option "xkb_rules" "evdev"
[  1515.472] (**) Option "xkb_model" "evdev"
[  1515.472] (**) Option "xkb_layout" "us"


xorg.conf:
Code:

Section "ServerLayout"

    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "DontVTSwitch" "off"
    Option         "BlankTime" "0"
    Option         "StandbyTime" "0"
    Option         "SuspendTime" "40"
    Option         "Xinerama" "0"
EndSection

Section "Files"

   #FontPath     "/usr/share/fonts/misc/"
   #FontPath     "/usr/share/fonts/TTF/"
   #FontPath     "/usr/share/fonts/OTF"
   #FontPath     "/usr/share/fonts/Type1/"
   #FontPath     "/usr/share/fonts/100dpi/"
   #FontPath     "/usr/share/fonts/75dpi/"
#   FontPath   "/usr/share/fonts/mathematica-fonts"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/TTF"
    FontPath        "/usr/share/fonts/corefonts"
    FontPath        "/usr/share/fonts/freefont"
    FontPath        "/usr/share/fonts/sharefonts"
    FontPath        "/usr/share/fonts/ttf-bitstream-vera"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/artwiz-aleczapka-en"
    FontPath        "/usr/share/fonts/unifont"
    FontPath        "/usr/share/fonts/texcm-ttf"
    FontPath        "/usr/share/fonts/local"
    FontPath        "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
    Load           "glx"
    Load           "extmod"
    Load           "xtrap"
    Load           "record"
#   Load  "GLcore"
    Load           "dbe"
#   Load  "dri"
    Load           "freetype"
    Load           "type1"
EndSection

Section "ServerFlags"
    Option         "AutoAddDevices" "on"
    Option         "AutoEnableDevices" "on"
    Option         "AllowEmptyInput" "on"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "ExplorerPS/2"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "true"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Panasonic-TV"
    HorizSync       15.0 - 68.0
    VertRefresh     23.0 - 61.0
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2312HM"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
EndSection

Section "Monitor"
    Identifier     "Monitor2"
    VendorName     "Unknown"
    ModelName      "DELL U2312HM"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 560 Ti"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
   Identifier  "Card1"
   Driver      "i915"
   BusID       "PCI:0:2:0"
EndSection


Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
#    Option         "TwinView" "1"
#    Option         "TwinViewXineramaInfoOrder" "DFP-0"
#    Option         "Stereo" "0"
#    Option         "nvidiaXineramaInfoOrder" "DFP-1"
#    Option         "metamodes" "DFP-0: nvidia-auto-select +1920+0, DFP-2: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

#Section "Screen"
#    Identifier     "Screen1"
#    Device         "Card1"
#    Monitor        "Monitor1"
#    DefaultDepth    24
#    Option         "TwinView" "0"
#    Option         "TwinViewXineramaInfoOrder" "DFP-1"
#    Option         "nvidiaXineramaInfoOrder" "DFP-1"
#    Option         "Stereo" "0"
#    Option         "metamodes" "DFP-1: nvidia-auto-select +0+0"
#    SubSection     "Display"
#        Depth       24
#    EndSubSection
#EndSection

Section "Screen"
    Identifier     "Screen2"
    Device         "Card1"
    Monitor        "Monitor2"
    DefaultDepth    24
#    Option         "Stereo" "0"
#    Option         "metamodes" "DFP-2: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection


lspci:
Code:

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 Display controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.4 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 5 (rev c4)
00:1c.5 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c4)
00:1c.6 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 7 (rev c4)
00:1c.7 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 8 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Z77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GF114 [GeForce GTX 560 Ti] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF114 HDMI Audio Controller (rev a1)
03:00.0 USB controller: VIA Technologies, Inc. VL80x xHCI USB 3.0 Controller (rev 03)
04:00.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 41)
06:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10)
07:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9172 SATA 6Gb/s Controller (rev 11)


As you can see from the xorg log it sees the intel card but doesn't do anything with it, or attempt to communicate with the driver. In making this xorg.conf I wanted to test the basic set up of 1 DVI monitor on each card and ignore HDMI, so that's how they were plugged in. It's been a long time since I made an xorg.conf so apologies if I'm missing something obvious.


Last edited by venustomars on Thu May 30, 2013 3:17 am; edited 1 time in total
Back to top
View user's profile Send private message
pums974
n00b
n00b


Joined: 27 Feb 2010
Posts: 74

PostPosted: Wed May 29, 2013 11:38 am    Post subject: Reply with quote

I have tried similar things here yesterday.

I thing you have to add :
  • in the ServerLayout Section
    Code:
       Screen 1 "Screen2" RightOf "Screen0" 

  • in the Device0 Section
    Code:
        BusID "1:0:0"   

  • int the Card1 Section
    Code:
        BusID "0:2:0" 

But with all that, it seems for me, that gnome-shell segfault but not kde.
And I'm not sure how opengl is handled.
I'm interested for more information on this subject.
Back to top
View user's profile Send private message
venustomars
n00b
n00b


Joined: 22 Sep 2008
Posts: 24

PostPosted: Thu May 30, 2013 3:17 am    Post subject: Reply with quote

Adding the RightOf line and switching the driver from i915 to intel did the trick. Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum