Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo - after few years with debian, mint and debian again
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
vult
n00b
n00b


Joined: 13 May 2006
Posts: 34
Location: Poland -> Łódź

PostPosted: Thu Feb 09, 2017 12:37 pm    Post subject: gentoo - after few years with debian, mint and debian again Reply with quote

Hello again :)


I've repaired my old latop (HP 2540p) and decided to check out how Gentoo is doing nowadays.
I was able to build amd64 base install with custom kernel, cinnamon, AMP stack - basically all I need.
And guess what: I've fallen in love with gentoo again :)

But then it wasn't so smooth:
i was trying to update @world but keeps pulling out systemd and I had to deal with lots of blockages.

I've read a bit through the forum and googled it and I'm wondering: What is the reality now?
If you want cinnamon you have to use systemd and it works without problems?

Is the only way now Gentoo + KDE? Or maybe I should try systemd?

I've tried dantrell repo - gnome without systemd but I've given up after two days fighting wih blocked packages.
_________________
-v-
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16265
Location: here

PostPosted: Thu Feb 09, 2017 12:43 pm    Post subject: Reply with quote

Cinnamon not require systemd. You have masked systemd (and disabled use flag)?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
vult
n00b
n00b


Joined: 13 May 2006
Posts: 34
Location: Poland -> Łódź

PostPosted: Thu Feb 09, 2017 12:48 pm    Post subject: Reply with quote

Yes, I did like i've found on the wiki: https://wiki.gentoo.org/wiki/Gentoo_Without_systemd

I have -systemd USE fla in make.conf

/etc/portage/package.mask:
Code:
sys-apps/systemd
sys-fs/udev

_________________
-v-
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16265
Location: here

PostPosted: Thu Feb 09, 2017 1:01 pm    Post subject: Reply with quote

You can post, with wgetpaste, all output of emerge @world?

EDIT: Sorry, I forgot... welcome back :D
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
vult
n00b
n00b


Joined: 13 May 2006
Posts: 34
Location: Poland -> Łódź

PostPosted: Thu Feb 09, 2017 1:33 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You can post, with wgetpaste, all output of emerge @world?


Code:
emerge @world
Calculating dependencies... done!

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by gnome-base/gnome-shell-3.20.4::gentoo
# required by x11-terms/gnome-terminal-3.20.3::gentoo[gnome-shell]
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=sys-apps/systemd-226-r2

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! All ebuilds that could satisfy "sys-auth/pambase[systemd]" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-auth/pambase-20140313::gentoo (masked by: ~amd64 keyword)

(dependency required by "gnome-base/gdm-3.20.1::gentoo" [ebuild])
(dependency required by "gnome-base/gnome-shell-3.20.4::gentoo" [ebuild])
(dependency required by "x11-terms/gnome-terminal-3.20.3::gentoo[gnome-shell]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I don't use gdm, I have lxdm
gnome-terminal is the problem?

fedeliallalinea wrote:
EDIT: Sorry, I forgot... welcome back :D


Thanks :)
_________________
-v-
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16265
Location: here

PostPosted: Thu Feb 09, 2017 1:40 pm    Post subject: Reply with quote

vult wrote:
I don't use gdm, I have lxdm
gnome-terminal is the problem?

Probably the problem is only gnome-shell use flag of gnome-terminal, try to disable it.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
vult
n00b
n00b


Joined: 13 May 2006
Posts: 34
Location: Poland -> Łódź

PostPosted: Thu Feb 09, 2017 1:41 pm    Post subject: Reply with quote

I've removed gnome-terminal and installed mate-terminal.

Now emerge @world gives me that:
https://paste.pound-python.org/show/ceuET16PwrA33nfbFUFW/
_________________
-v-
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16265
Location: here

PostPosted: Thu Feb 09, 2017 2:00 pm    Post subject: Reply with quote

vult wrote:
I've removed gnome-terminal and installed mate-terminal.

Now emerge @world gives me that:
https://paste.pound-python.org/show/ceuET16PwrA33nfbFUFW/

You know you're not doing an update of the world, but only a rebuild of all packages contained in the world file.
If you want to do an update a correct command is emerge -uDNU @world.
Anyway for your problem you need to run this command
Code:
# emerge -1 =dev-libs/glib-2.50.2 =dev-util/gdbus-codegen-2.50.2

_________________
Questions are guaranteed in life; Answers aren't.


Last edited by fedeliallalinea on Fri Feb 10, 2017 7:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
vult
n00b
n00b


Joined: 13 May 2006
Posts: 34
Location: Poland -> Łódź

PostPosted: Thu Feb 09, 2017 2:19 pm    Post subject: Reply with quote

fedeliallalinea wrote:

You know you're not doing an update of the world, but only a rebuild of all packages contained in the world file.
If you want to do an update a correct command is emerge -uDNU @world.

Yes, I'm aware of that, however I thought that was what You asked.

Anyway, looks like:
Code:
# emerge -1 emerge =dev-libs/glib-2.50.2 =dev-util/gdbus-codegen-2.50.2

solved my problem.
What does --oneshot do?
When should I use it? What was the problem? - I'd like to understand for future issues.

Thank you very much fedeliallalinea!
_________________
-v-
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16265
Location: here

PostPosted: Thu Feb 09, 2017 2:44 pm    Post subject: Reply with quote

vult wrote:
What does --oneshot do?
When should I use it? What was the problem? - I'd like to understand for future issues.

oneshot option prevent to write package atom in world file (/var/lib/portage/world).
Usally is useful when you need to rebuild a package but you don't know if it's a dependency of another package or if it's a package present in world file.
This for a proper operation of emerge --depclean

Examples:
Code:
# emerge squashfs-tools
# emerge --depclean
>>> No packages selected for removal by depclean
Packages installed:   556
Packages in world:    79
Packages in system:   44
Required packages:    556
Number removed:  0

Code:
# emerge -1 squashfs-tools
# emerge --depclean
>>> These are the packages that would be unmerged:

 sys-fs/squashfs-tools
    selected: 4.3-r2
   protected: none
     omitted: none

All selected packages: =sys-fs/squashfs-tools-4.3-r2

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Would you like to unmerge these packages? [Yes/No]

Code:
# emerge -1 squashfs-tools
# emerge grs (has squashfs as direct dependency)
# emerge --depclean
>>> No packages selected for removal by depclean
Packages installed:   556
Packages in world:    79
Packages in system:   44
Required packages:    556
Number removed:  0

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cboldt
l33t
l33t


Joined: 24 Aug 2005
Posts: 761

PostPosted: Thu Feb 09, 2017 3:33 pm    Post subject: Reply with quote

Slightly off topic, but for updating the system, my impression is that the "--changed-use (-U)" is a subset of "--newuse (-N)", so that it one is using "-N", adding "-U" is harmless but redundant. I get my impression from the remarks in `man emerge`.
Back to top
View user's profile Send private message
vult
n00b
n00b


Joined: 13 May 2006
Posts: 34
Location: Poland -> Łódź

PostPosted: Fri Feb 10, 2017 9:53 am    Post subject: Reply with quote

fedeliallalinea wrote:

oneshot option prevent to write package atom in world file (/var/lib/portage/world).
Usally is useful when you need to rebuild a package but you don't know if it's a dependency of another package or if it's a package present in world file.
This for a proper operation of emerge --depclean

Thank you very much for explanation and the examples. Hope I'll know now when to use it ;)
_________________
-v-
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16265
Location: here

PostPosted: Fri Feb 10, 2017 10:12 am    Post subject: Reply with quote

cboldt wrote:
Slightly off topic, but for updating the system, my impression is that the "--changed-use (-U)" is a subset of "--newuse (-N)", so that it one is using "-N", adding "-U" is harmless but redundant. I get my impression from the remarks in `man emerge`.

It's true
man emerge wrote:
--newuse (-N)
Tells emerge to include installed packages where USE flags have changed since compilation. This option also implies the --selective option. USE flag changes include:

A USE flag was added to a package. A USE flag was removed from a package. A USE flag was turned on for a package. A USE flag was turned off for a package.

Thanks, I did not know this
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
abstr4kt
n00b
n00b


Joined: 22 Jul 2005
Posts: 19

PostPosted: Fri Feb 10, 2017 5:19 pm    Post subject: Reply with quote

Hi guys
Code:
# emerge -1 emerge =dev-libs/glib-2.50.2 =dev-util/gdbus-codegen-2.50.2

i'm just falled in the same dependency conflict and this command solved the queue.
I have got a silly question:
emerge -1 emerge ....
is a mispelled command or there is a special function of emerge ? (emerge of emerge)
i have not yet tested it whitout the second emerge,i don't know how to reproduce this scenario, but just for better underestand...does is it needed for resolve dependency conflict?

Thanks in advance.
Back to top
View user's profile Send private message
vult
n00b
n00b


Joined: 13 May 2006
Posts: 34
Location: Poland -> Łódź

PostPosted: Fri Feb 10, 2017 5:25 pm    Post subject: Reply with quote

abstr4kt, look at fedeliallalinea answer to my --oneshot question.
-1 it's the same as --oneshot
_________________
-v-
Back to top
View user's profile Send private message
Section_8
Guru
Guru


Joined: 22 May 2004
Posts: 543
Location: Arlington, TX, US

PostPosted: Fri Feb 10, 2017 6:31 pm    Post subject: Reply with quote

Quote:
emerge -1 emerge ....
I think that second "emerge" in that command was a typo.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16265
Location: here

PostPosted: Fri Feb 10, 2017 7:06 pm    Post subject: Reply with quote

@abstr4kt and @Section_8
Section_8 wrote:
I think that second "emerge" in that command was a typo.

Uh sorry (and thank you) my fault, I corrected in my post
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
abstr4kt
n00b
n00b


Joined: 22 Jul 2005
Posts: 19

PostPosted: Mon Feb 13, 2017 11:25 am    Post subject: Reply with quote

good to know it
I got new package blocking case:
i'm tryng to update my system . starting from what i need,just to print some pdf for example, but i runned into this

Code:

~ # emerge -avuDNtg cups

 * IMPORTANT: 18 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] media-video/camorama-0.19-r2::gentoo  USE="-debug"
[nomerge       ]  gnome-base/libgnomeui-2.24.5-r1::gentoo  USE="{-test}"
[ebuild     U  ]   x11-themes/adwaita-icon-theme-3.20::gentoo [3.18.0::gentoo] USE="branding" 18381 KiB
[nomerge       ] net-misc/networkmanager-openvpn-1.0.8::gentoo  USE="gtk {-test}"
[nomerge       ]  gnome-extra/nm-applet-1.0.10::gentoo  USE="bluetooth introspection -modemmanager"
[nomerge       ]   net-wireless/gnome-bluetooth-3.18.3:2/13::gentoo  USE="introspection -debug"
[nomerge       ]    x11-libs/gtk+-3.20.9:3::gentoo  USE="X introspection vim-syntax (-aqua) -broadway -cloudprint -colord -cups -examples {-test} -wayland -xinerama" ABI_X86="32 (64) (-x32)"
[ebuild     U  ]     app-accessibility/at-spi2-atk-2.20.1:2::gentoo [2.18.1:2::gentoo] USE="{-test}" ABI_X86="32 (64) (-x32)" 302 KiB
[nomerge       ] gnome-base/libgnomeui-2.24.5-r1::gentoo  USE="{-test}"
[nomerge       ]  gnome-base/gnome-vfs-2.24.4-r4:2::gentoo  USE="acl ipv6 ssl -gnutls -kerberos (-libressl) -samba {-test} -zeroconf" ABI_X86="32 (64) (-x32)"
[nomerge       ]   dev-libs/glib-2.50.2:2::gentoo  USE="dbus (mime) xattr -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7"
[ebuild     U  ]    gnome-base/dconf-0.26.0::gentoo [0.24.0::gentoo] USE="{-test}" 215 KiB
[ebuild     U  ] sys-apps/file-5.29::gentoo [5.25::gentoo] USE="zlib -python -static-libs" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-python3_5) (-python3_3%)" 766 KiB
[nomerge       ] app-portage/smart-live-rebuild-1.3.4.1::gentoo  PYTHON_TARGETS="python2_7 python3_4 -python3_3 (-python3_5)"
[nomerge       ]  app-portage/gentoopm-0.2.9::gentoo  USE="-doc" PYTHON_TARGETS="python2_7 python3_4 (-pypy) -python3_3 (-python3_5)"
[ebuild     U  ]   sys-apps/portage-2.3.3::gentoo [2.3.0::gentoo] USE="(ipc) xattr -build -doc -epydoc -native-extensions% (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-python3_5) (-python3_3%)" 900 KiB
[ebuild   R    ]    dev-python/pyxattr-0.5.5::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-python3_5) (-python3_3%)" 0 KiB
[ebuild     U  ] app-editors/vim-8.0.0106::gentoo [7.4.769::gentoo] USE="X acl gpm nls -cscope -debug -lua -luajit -minimal -perl -python -racket -ruby (-selinux) -tcl -vim-pager" PYTHON_TARGETS="python2_7 python3_4 (-python3_5) (-python3_3%)" 12645 KiB
[ebuild     U  ]  dev-util/ctags-20161028::gentoo [5.8::gentoo] USE="xml%* -json% -yaml% (-ada%)" 833 KiB
[ebuild  N     ]   dev-python/docutils-0.12::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5)" 1581 KiB
[ebuild  N     ]    dev-python/pygments-2.1.1::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5)" 2065 KiB
[nomerge       ] net-wireless/wpa_supplicant-2.5-r1::gentoo  USE="ap dbus eap-sim gnutls hs2-0 p2p qt4 readline ssl tdls uncommon-eap-types -fasteap (-libressl) (-ps3) -qt5 (-selinux) -smartcard (-wimax) -wps"
[nomerge       ]  net-wireless/crda-3.18-r1::gentoo  USE="-gcrypt (-libressl)"
[nomerge       ]   dev-python/m2crypto-0.22.3-r4::gentoo  PYTHON_TARGETS="python2_7"
[nomerge       ]    dev-python/setuptools-30.4.0::gentoo [20.6.7::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_3%)"
[ebuild     U  ]     dev-python/certifi-2016.9.26::gentoo [2015.11.20::gentoo] PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_3%)" 366 KiB
[ebuild     U  ]      dev-python/setuptools-30.4.0::gentoo [20.6.7::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_3%)" 641 KiB
[nomerge       ] net-analyzer/wireshark-2.0.4:0/2.0.4::gentoo  USE="adns androiddump caps crypt doc filecaps geoip gtk3 ipv6 lua netlink pcap smi ssl tfshark zlib -doc-pdf -kerberos -portaudio -qt4 -qt5 -sbc (-selinux)" CPU_FLAGS_X86="-sse4_2"
[nomerge       ]  app-doc/doxygen-1.8.10-r1::gentoo  USE="-clang -debug -doc -dot -doxysearch -latex -qt4 (-sqlite)" LINGUAS="it -af -ar -ca -cs -da -de -el -eo -es -fa -fi -fr -hr -hu -hy -id -ja -ko -lt -mk -nb -nl -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -tr -uk -vi -zh"
[ebuild   R    ]   app-text/ghostscript-gpl-9.15-r1::gentoo  USE="X cups dbus gtk tiff -djvu -idn -static-libs" L10N="-de% -ja% -ko% -zh-CN% -zh-TW%" LINGUAS="(-de%) (-ja%) (-ko%) (-zh_CN%) (-zh_TW%)" 0 KiB
[ebuild     U  ]    net-print/cups-2.1.4::gentoo [2.1.3-r1::gentoo] USE="X acl dbus pam ssl threads usb -debug -java -kerberos -lprng-compat -python (-selinux) -static-libs -systemd -xinetd -zeroconf" ABI_X86="32 (64) (-x32)" LINGUAS="it -ca -cs -de -es -fr -ja -ru" PYTHON_TARGETS="python2_7" 9349 KiB
[ebuild     U  ]     x11-misc/xdg-utils-1.1.1-r1::gentoo [1.1.1::gentoo] USE="perl -doc" 0 KiB
[nomerge       ] app-accessibility/at-spi2-atk-2.20.1:2::gentoo [2.18.1:2::gentoo] USE="{-test}" ABI_X86="32 (64) (-x32)"
[ebuild     U  ]  app-accessibility/at-spi2-core-2.20.2:2::gentoo [2.18.3:2::gentoo] USE="X introspection" ABI_X86="32 (64) (-x32)" 444 KiB
[nomerge       ] xfce-base/thunar-1.6.10::gentoo  USE="dbus exif libnotify pcre udisks -debug {-test}" XFCE_PLUGINS="trash"
[nomerge       ]  gnome-base/gvfs-1.26.3::gentoo  USE="cdda gtk http udev udisks -afp -archive -bluray -fuse -gnome-keyring -gnome-online-accounts -google -gphoto2 -ios -mtp -nfs -samba -systemd {-test} -zeroconf"
[nomerge       ]   net-misc/openssh-7.2_p2::gentoo  USE="X pam pie ssl -X509 -bindist -debug -hpn -kerberos -ldap -ldns -libedit (-libressl) -sctp (-selinux) -skey -ssh1 -static"
[nomerge       ]    sys-auth/pambase-20150213::gentoo  USE="consolekit cracklib nullok sha512 -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc -securetty (-selinux) -systemd"
[ebuild     U  ]     sys-auth/consolekit-1.1.0-r1::gentoo [1.1.0::gentoo] USE="acl pam policykit -cgroups -debug -doc -pm-utils (-selinux) {-test}" 0 KiB
[ebuild     U  ]      sys-apps/dbus-1.10.12::gentoo [1.10.8-r1::gentoo] USE="X -debug -doc (-selinux) -static-libs -systemd {-test} -user-session" ABI_X86="32 (64) (-x32)" 1939 KiB
[nomerge       ] net-analyzer/wireshark-2.0.4:0/2.0.4::gentoo  USE="adns androiddump caps crypt doc filecaps geoip gtk3 ipv6 lua netlink pcap smi ssl tfshark zlib -doc-pdf -kerberos -portaudio -qt4 -qt5 -sbc (-selinux)" CPU_FLAGS_X86="-sse4_2"
[ebuild     U  ]  www-client/lynx-2.8.9_pre11::gentoo [2.8.8_p2::gentoo] USE="bzip2 ipv6 nls ssl unicode -cjk -gnutls -idn (-libressl)" 2603 KiB
[ebuild     U  ]  net-libs/gnutls-3.3.26::gentoo [3.3.17.1::gentoo] USE="crywrap cxx nls openssl zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="32 (64) (-x32)" LINGUAS="it -cs -de -en -fi -fr -ms -nl -pl -sv -uk -vi -zh_CN" 6212 KiB
[nomerge       ] app-text/llpp-20_p20140818::gentoo  USE="ocamlopt -static"
[ebuild     U  ]  media-libs/openjpeg-2.1.1_p20160922:2/7::gentoo [2.1.0:2/7::gentoo] USE="-doc -static-libs {-test}" ABI_X86="32%* (64%*) (-x32)" 1958 KiB
[ebuild     U  ]   dev-util/cmake-3.7.2::gentoo [3.5.2-r1::gentoo] USE="ncurses -doc -emacs -qt5 -system-jsoncpp {-test} (-qt4%)" 7190 KiB
[ebuild     U  ]    app-arch/libarchive-3.2.2:0/13::gentoo [3.2.1-r3:0/13::gentoo] USE="acl bzip2 e2fsprogs iconv lzma threads%* xattr zlib -expat (-libressl) -lz4 -lzo -nettle -static-libs" ABI_X86="32 (64) (-x32)" 5331 KiB
[nomerge       ] net-misc/wicd-1.7.4-r1::gentoo  USE="X ambiance gtk libnotify ncurses nls pm-utils -doc -gnome-shell (-ioctl) -mac4lin" PYTHON_TARGETS="python2_7"
[nomerge       ]  dev-python/notify-python-0.1.1-r3::gentoo  USE="-examples" PYTHON_TARGETS="python2_7"
[nomerge       ]   dev-python/pygtk-2.24.0-r4:2::gentoo  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7"
[nomerge       ]    dev-python/pycairo-1.10.0-r4::gentoo  USE="svg xcb -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[nomerge       ]     x11-libs/xpyb-1.3.1-r3::gentoo  USE="(-selinux) -static-libs" PYTHON_TARGETS="python2_7"
[ebuild   R    ]      x11-proto/xcb-proto-1.12-r2::gentoo  ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5) (-python3_3%)" 0 KiB
[nomerge       ] net-p2p/transmission-2.84-r4::gentoo  USE="gtk qt4 (-ayatana) -lightweight -qt5 -systemd -xfs"
[ebuild     U  ]  net-misc/curl-7.52.1-r1::gentoo [7.50.3::gentoo] USE="ipv6 ssl -adns -http2 -idn -kerberos -ldap -metalink -rtmp -samba -ssh -static-libs {-test} -threads" ABI_X86="32 (64) (-x32)" CURL_SSL="openssl -axtls -gnutls (-libressl) -mbedtls -nss -polarssl (-winssl)" 2540 KiB
[nomerge       ] net-analyzer/wireshark-2.0.4:0/2.0.4::gentoo  USE="adns androiddump caps crypt doc filecaps geoip gtk3 ipv6 lua netlink pcap smi ssl tfshark zlib -doc-pdf -kerberos -portaudio -qt4 -qt5 -sbc (-selinux)" CPU_FLAGS_X86="-sse4_2"
[nomerge       ]  app-text/asciidoc-8.6.9-r2::gentoo  USE="-examples -graphviz -highlight {-test}" PYTHON_SINGLE_TARGET="python2_7 (-pypy)" PYTHON_TARGETS="python2_7 (-pypy)"
[ebuild     U  ]   app-text/docbook-xsl-stylesheets-1.79.1-r1::gentoo [1.79.0::gentoo] USE="-ruby" 21454 KiB
[nomerge       ] x11-wm/compiz-fusion-0.8.8::gentoo  USE="emerald -gnome -kde -unsupported"
[nomerge       ]  x11-plugins/compiz-plugins-extra-0.8.8::gentoo  USE="gconf libnotify"
[nomerge       ]   x11-plugins/compiz-plugins-main-0.8.8::gentoo  USE="gconf"
[ebuild     U  ]    gnome-base/librsvg-2.40.16:2::gentoo [2.40.15:2::gentoo] USE="introspection -tools -vala" ABI_X86="32 (64) (-x32)" 548 KiB
[ebuild     U  ]     x11-libs/pango-1.40.3::gentoo [1.38.1::gentoo] USE="X introspection {-test} (-debug%)" ABI_X86="32 (64) (-x32)" 1037 KiB
[ebuild     U  ]      media-libs/harfbuzz-1.3.1:0/0.9.18::gentoo [1.2.7:0/0.9.18::gentoo] USE="cairo glib graphite icu introspection truetype -fontconfig -static-libs {-test}" ABI_X86="32 (64) (-x32)" 1327 KiB
[ebuild     U ~] dev-util/gtk-update-icon-cache-3.22.2::gentoo [3.20.9::gentoo] 358 KiB
[nomerge       ] lxde-base/lxappearance-0.5.5::gentoo  USE="dbus"
[nomerge       ]  x11-libs/gtk+-2.24.31:2::gentoo  USE="introspection vim-syntax (-aqua) -cups -debug -examples {-test} -xinerama" ABI_X86="32 (64) (-x32)"
[ebuild     U  ]   dev-libs/atk-2.20.0::gentoo [2.18.0::gentoo] USE="introspection nls {-test}" ABI_X86="32 (64) (-x32)" 708 KiB
[nomerge       ] dev-python/m2crypto-0.22.3-r4::gentoo  PYTHON_TARGETS="python2_7"
[nomerge       ]  dev-libs/openssl-1.0.2k::gentoo [1.0.2j::gentoo] USE="asm sslv3 tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs {-test} -vanilla" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="(sse2)"
[ebuild     U  ]   app-misc/ca-certificates-20161102.3.27.2-r2::gentoo [20151214.3.21::gentoo] USE="-cacert* -insecure_certs%" 7516 KiB
[nomerge       ] x11-themes/greybird-1.5.3::gentoo  USE="(-ayatana) -gnome"
[nomerge       ]  x11-themes/gtk-engines-murrine-0.98.2-r1::gentoo  USE="themes -animation-rtl" ABI_X86="32 (64) (-x32)"
[ebuild     U  ]   x11-libs/gdk-pixbuf-2.34.0:2::gentoo [2.32.3:2::gentoo] USE="X introspection jpeg tiff -debug -jpeg2k {-test}" ABI_X86="32 (64) (-x32)" 2646 KiB
[nomerge       ] net-wireless/gnome-bluetooth-3.18.3:2/13::gentoo  USE="introspection -debug"
[ebuild     U  ]  dev-libs/libxml2-2.9.4-r1:2::gentoo [2.9.4:2::gentoo] USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test}" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5) (-python3_3%)" 0 KiB
[nomerge       ] net-misc/networkmanager-openswan-1.0.8::gentoo  USE="gtk"
[nomerge       ]  gnome-extra/nm-applet-1.0.10::gentoo  USE="bluetooth introspection -modemmanager"
[nomerge       ]   virtual/notification-daemon-0::gentoo  USE="-gnome"
[nomerge       ]    xfce-extra/xfce4-notifyd-0.2.4::gentoo  USE="-debug"
[nomerge       ]     xfce-base/libxfce4ui-4.12.1-r2::gentoo  USE="gtk3 startup-notification -debug"
[nomerge       ]      x11-libs/gtk+-2.24.31:2::gentoo  USE="introspection vim-syntax (-aqua) -cups -debug -examples {-test} -xinerama" ABI_X86="32 (64) (-x32)"
[nomerge       ]       dev-libs/gobject-introspection-common-1.48.0::gentoo [1.46.0::gentoo]
[blocks b      ]        <dev-libs/gobject-introspection-1.48.0 ("<dev-libs/gobject-introspection-1.48.0" is blocking dev-libs/gobject-introspection-common-1.48.0)
[ebuild     U  ]         dev-libs/gobject-introspection-1.48.0::gentoo [1.46.0::gentoo] USE="cairo -doctool {-test}" PYTHON_TARGETS="python2_7" 1340 KiB
[nomerge       ] dev-python/m2crypto-0.22.3-r4::gentoo  PYTHON_TARGETS="python2_7"
[nomerge       ]  dev-lang/python-exec-2.4.4:2::gentoo [2.0.2:2::gentoo] PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_4) (python3_5) (python3_6%*) (-python3_3%)"
[blocks b      ]   <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking dev-lang/python-exec-2.4.4)
[ebuild     U  ]    dev-lang/python-2.7.12:2.7::gentoo [2.7.10-r1:2.7::gentoo] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened (-libressl) -tk -wininst" 12114 KiB
[blocks b      ]   <dev-lang/python-3.4.3-r4:3.4 ("<dev-lang/python-3.4.3-r4:3.4" is blocking dev-lang/python-exec-2.4.4)
[ebuild     U  ]    dev-lang/python-3.4.5:3.4/3.4m::gentoo [3.4.3-r1:3.4/3.4::gentoo] USE="gdbm ipv6 ncurses readline ssl (threads) xml -build -examples -hardened (-libressl) -sqlite -tk -wininst" 14189 KiB
[ebuild     U  ]     dev-libs/openssl-1.0.2k::gentoo [1.0.2j::gentoo] USE="asm sslv3 tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs {-test} -vanilla" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="(sse2)" 5185 KiB
[nomerge       ] net-print/cups-2.1.4::gentoo [2.1.3-r1::gentoo] USE="X acl dbus pam ssl threads usb -debug -java -kerberos -lprng-compat -python (-selinux) -static-libs -systemd -xinetd -zeroconf" ABI_X86="32 (64) (-x32)" LINGUAS="it -ca -cs -de -es -fr -ja -ru" PYTHON_TARGETS="python2_7"
[nomerge       ]  net-libs/gnutls-3.3.26::gentoo [3.3.17.1::gentoo] USE="crywrap cxx nls openssl zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="32 (64) (-x32)" LINGUAS="it -cs -de -en -fi -fr -ms -nl -pl -sv -uk -vi -zh_CN"
[nomerge       ]   sys-devel/autogen-5.18.4::gentoo  USE="-libopts -static-libs"
[ebuild  N     ]    dev-scheme/guile-1.8.8-r3:12/8::gentoo  USE="deprecated nls readline regex threads -debug -debug-freelist -debug-malloc -discouraged -emacs -networking" 3864 KiB
[ebuild     U  ]   dev-libs/libtasn1-4.9-r1:0/6::gentoo [4.5:0/6::gentoo] USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 1822 KiB
[ebuild     U  ] sys-fs/e2fsprogs-1.43.3-r1::gentoo [1.42.13::gentoo] USE="nls -fuse% -static-libs" 7234 KiB
[nomerge       ] net-wireless/gnome-bluetooth-3.18.3:2/13::gentoo  USE="introspection -debug"
[ebuild     U  ]  dev-util/gtk-doc-am-1.25-r1::gentoo [1.25::gentoo] 0 KiB
[nomerge       ] x11-base/xorg-drivers-1.17::gentoo  INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -elographics -fpit -hyperpen -joystick -libinput -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="radeon -amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev (-fglrx) (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -neomagic -nouveau -nv -nvidia (-omap) (-omapfb) -qxl -r128 -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx (-tegra) -tga -trident -tseng -vesa -via -virtualbox -vmware (-voodoo)"
[nomerge       ]  x11-drivers/xf86-input-evdev-2.9.2::gentoo
[ebuild     U  ]   sys-kernel/linux-headers-4.4::gentoo [4.3::gentoo] 3827 KiB
[nomerge       ] net-misc/networkmanager-1.0.12-r1::gentoo  USE="bluetooth consolekit dhclient introspection modemmanager ncurses nss ppp wext wifi -connection-sharing -dhcpcd -gnutls -resolvconf (-selinux) -systemd -teamd {-test} -vala -zeroconf" ABI_X86="32 (64) (-x32)"
[nomerge       ]  net-libs/libsoup-2.52.2:2.4::gentoo  USE="introspection ssl -debug -samba {-test} -vala" ABI_X86="32 (64) (-x32)"
[nomerge       ]   net-libs/glib-networking-2.46.1::gentoo  USE="libproxy ssl -gnome -smartcard {-test}" ABI_X86="32 (64) (-x32)"
[nomerge       ]    net-libs/gnutls-3.3.26::gentoo [3.3.17.1::gentoo] USE="crywrap cxx nls openssl zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="32 (64) (-x32)" LINGUAS="it -cs -de -en -fi -fr -ms -nl -pl -sv -uk -vi -zh_CN"
[ebuild     U  ]     dev-libs/nettle-3.2-r1:0/6::gentoo [3.2:0/6::gentoo] USE="gmp -doc (-neon) -static-libs {-test}" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="-aes" 0 KiB
[nomerge       ] media-video/ffmpeg-2.8.6:0/54.56.56::gentoo  USE="X aac aacplus alsa amr bs2b bzip2 cdio cpudetection encode faac fdk flite fontconfig frei0r fribidi gme gpl gsm hardcoded-tables iconv iec61883 ieee1394 jack jpeg2k ladspa libass libcaca librtmp libsoxr libv4l lzma mp3 network opengl openssl pic postproc quvi schroedinger sdl speex ssh theora threads truetype twolame v4l vaapi vdpau vorbis wavpack webp x264 x265 xcb xvid zlib zvbi (-altivec) -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -celt -debug -doc -examples -gnutls (-libressl) (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -opus -oss -pulseaudio -samba -snappy -static-libs {-test} -vpx" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -sse4_2 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"
[nomerge       ]  media-libs/openjpeg-1.5.2:0/5::gentoo  USE="-doc -static-libs {-test}" ABI_X86="32 (64) (-x32)"
[nomerge       ]   dev-util/cmake-3.7.2::gentoo [3.5.2-r1::gentoo] USE="ncurses -doc -emacs -qt5 -system-jsoncpp {-test} (-qt4%)"
[ebuild  N     ]    dev-libs/libuv-1.10.2:0/1::gentoo  USE="-static-libs" ABI_X86="32 (64) (-x32)" 1050 KiB
[nomerge       ] net-print/cups-2.1.4::gentoo [2.1.3-r1::gentoo] USE="X acl dbus pam ssl threads usb -debug -java -kerberos -lprng-compat -python (-selinux) -static-libs -systemd -xinetd -zeroconf" ABI_X86="32 (64) (-x32)" LINGUAS="it -ca -cs -de -es -fr -ja -ru" PYTHON_TARGETS="python2_7"
[nomerge       ]  net-print/cups-filters-1.5.0::gentoo  USE="dbus foomatic jpeg png tiff -ldap -perl -static-libs -zeroconf"
[ebuild     U  ]   app-text/qpdf-5.1.1-r1:0/13::gentoo [5.1.1:0/13::gentoo] USE="-doc -examples -perl% -static-libs {-test}" 7484 KiB
[nomerge       ] x11-wm/compiz-fusion-0.8.8::gentoo  USE="emerald -gnome -kde -unsupported"
[nomerge       ]  x11-wm/emerald-0.8.8::gentoo
[nomerge       ]   x11-wm/compiz-0.8.8-r3::gentoo  USE="cairo dbus gconf gtk svg -fuse -gnome -kde"
[nomerge       ]    x11-apps/xdpyinfo-1.3.2::gentoo  USE="-dga -dmx -xinerama"
[ebuild     U  ]     x11-libs/libXtst-1.2.3::gentoo [1.2.2::gentoo] USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 315 KiB
[ebuild     U  ]    x11-libs/libXrandr-1.5.1::gentoo [1.5.0::gentoo] USE="-static-libs" ABI_X86="32 (64) (-x32)" 309 KiB
[nomerge       ] xfce-base/xfce4-meta-4.12::gentoo  USE="svg -minimal"
[nomerge       ]  xfce-base/xfce4-session-4.12.1::gentoo  USE="nls policykit upower xscreensaver -debug -systemd"
[nomerge       ]   x11-misc/xscreensaver-5.34::gentoo  USE="jpeg opengl pam perl -gdm -new-login (-selinux) -suid -xinerama"
[ebuild     U  ]    x11-libs/libXi-1.7.8::gentoo [1.7.6::gentoo] USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 475 KiB
[ebuild     U  ]     x11-libs/libXfixes-5.0.3::gentoo [5.0.2::gentoo] USE="-static-libs" ABI_X86="32 (64) (-x32)" 288 KiB
[nomerge       ] x11-apps/xdpyinfo-1.3.2::gentoo  USE="-dga -dmx -xinerama"
[ebuild     U  ]  x11-libs/libXrender-0.9.10::gentoo [0.9.9::gentoo] USE="-static-libs" ABI_X86="32 (64) (-x32)" 302 KiB
[ebuild     U  ]   x11-libs/libX11-1.6.4::gentoo [1.6.3::gentoo] USE="ipv6 -doc -static-libs {-test}" ABI_X86="32 (64) (-x32)" 2286 KiB
[ebuild     U  ]    x11-misc/util-macros-1.19.1::gentoo [1.19.0::gentoo] 82 KiB
[nomerge       ] sys-apps/pciutils-3.4.1::gentoo  USE="kmod udev zlib -dns -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ]  sys-apps/kmod-23::gentoo [22::gentoo] USE="tools zlib -debug -doc -lzma -python -static-libs" PYTHON_TARGETS="python2_7 python3_4 (-python3_5) (-python3_3%)" 440 KiB
[nomerge       ] net-misc/networkmanager-openswan-1.0.8::gentoo  USE="gtk"
[nomerge       ]  net-misc/libreswan-3.17::gentoo  USE="pam -caps -curl -dnssec -ldap"
[ebuild     U  ]   dev-libs/nspr-4.13.1::gentoo [4.12::gentoo] USE="-debug" ABI_X86="32 (64) (-x32)" 1111 KiB
[nomerge       ] xfce-base/thunar-1.6.10::gentoo  USE="dbus exif libnotify pcre udisks -debug {-test}" XFCE_PLUGINS="trash"
[ebuild     U  ]  dev-libs/libpcre-8.39:3::gentoo [8.38-r1:3::gentoo] USE="bzip2 cxx jit pcre16 readline recursion-limit (unicode) zlib -libedit -pcre32 -static-libs" ABI_X86="32 (64) (-x32)" 1525 KiB
[nomerge       ] media-video/ffmpeg-2.8.6:0/54.56.56::gentoo  USE="X aac aacplus alsa amr bs2b bzip2 cdio cpudetection encode faac fdk flite fontconfig frei0r fribidi gme gpl gsm hardcoded-tables iconv iec61883 ieee1394 jack jpeg2k ladspa libass libcaca librtmp libsoxr libv4l lzma mp3 network opengl openssl pic postproc quvi schroedinger sdl speex ssh theora threads truetype twolame v4l vaapi vdpau vorbis wavpack webp x264 x265 xcb xvid zlib zvbi (-altivec) -amrenc (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bluray -celt -debug -doc -examples -gnutls (-libressl) (-mipsdspr1) (-mipsdspr2) (-mipsfpu) -modplug (-neon) -openal -opus -oss -pulseaudio -samba -snappy -static-libs {-test} -vpx" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -sse4_2 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"
[nomerge       ]  media-libs/libass-0.12.3:0/5::gentoo  USE="enca fontconfig harfbuzz -static-libs" ABI_X86="32 (64) (-x32)"
[nomerge       ]   media-libs/harfbuzz-1.3.1:0/0.9.18::gentoo [1.2.7:0/0.9.18::gentoo] USE="cairo glib graphite icu introspection truetype -fontconfig -static-libs {-test}" ABI_X86="32 (64) (-x32)"
[ebuild     U  ]    dev-libs/icu-58.1-r1:0/58.1::gentoo [57.1:0/57::gentoo] USE="-debug -doc -examples -static-libs" ABI_X86="32 (64) (-x32)" 22819 KiB
[ebuild     U  ] sys-apps/util-linux-2.28.2::gentoo [2.26.2::gentoo] USE="cramfs ncurses nls pam readline%* suid udev unicode -build -caps -fdformat -kill% -python (-selinux) -slang -static-libs -systemd {-test} -tty-helpers" ABI_X86="32 (64) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_4 (-python3_5) (-python3_3%)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5) (-python3_3%)" 4053 KiB
[nomerge       ] media-video/vlc-2.2.1-r1:0/5-8::gentoo  USE="X a52 alsa atmo avcodec avformat cdda dbus dc1394 directfb dts dvbpsi dvd encode faad fdk ffmpeg flac fluidsynth fontconfig gcrypt gme growl httpd ieee1394 jpeg libnotify libsamplerate linsys lirc live lua matroska modplug mp3 mpeg mtp musepack ncurses ogg omxil opencv opengl optimisememory png postproc projectm pulseaudio qt4 rdp rtsp samba schroedinger sdl sdl-image shout sid speex svg swscale taglib theora tremor truetype udev upnp v4l vaapi vcdx vdpau vlm vorbis wma-fixed x264 x265 xcb xml xv zeroconf zvbi -aalib (-altivec) (-audioqueue) -bidi -bluray -cddb -chromaprint -debug (-directx) -dvb (-dxva2) -gnome -gnutls -jack -kate -kde -libass -libav -libcaca -libtar -libtiger (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) -media-library (-neon) -opus -qt5 -run-as-root -sftp -skins {-test} -twolame -vnc -vpx" CPU_FLAGS_X86="mmx sse"
[nomerge       ]  media-libs/opencv-2.4.12-r1:0/2.4::gentoo  USE="eigen gtk jpeg opengl openmp png python tiff -cuda -examples -ffmpeg -gstreamer -ieee1394 (-ipp) -java -jpeg2k -libav -opencl -openexr -pch -qt4 -qt5 -testprograms -threads -v4l (-vtk) -xine" PYTHON_TARGETS="python2_7"
[ebuild     U  ]   media-libs/tiff-4.0.7::gentoo [4.0.6::gentoo] USE="cxx jpeg zlib -jbig -lzma -static-libs {-test}" ABI_X86="32 (64) (-x32)" 2028 KiB
[ebuild     U  ]   media-libs/libpng-1.6.27:0/16::gentoo [1.6.21:0/16::gentoo] USE="apng (-neon) -static-libs" ABI_X86="32 (64) (-x32)" 972 KiB
[ebuild     U  ]    sys-libs/zlib-1.2.11::gentoo [1.2.8-r1::gentoo] USE="minizip -static-libs" ABI_X86="32 (64) (-x32)" 594 KiB
[ebuild     U  ]     sys-devel/libtool-2.4.6-r2:2::gentoo [2.4.6:2::gentoo] USE="-vanilla" 0 KiB
[nomerge       ] app-editors/vim-8.0.0106::gentoo [7.4.769::gentoo] USE="X acl gpm nls -cscope -debug -lua -luajit -minimal -perl -python -racket -ruby (-selinux) -tcl -vim-pager" PYTHON_TARGETS="python2_7 python3_4 (-python3_5) (-python3_3%)"
[ebuild     U  ]  app-editors/vim-core-8.0.0106::gentoo [7.4.769::gentoo] USE="acl nls -minimal" 0 KiB
[nomerge       ] x11-misc/xscreensaver-5.34::gentoo  USE="jpeg opengl pam perl -gdm -new-login (-selinux) -suid -xinerama"
[nomerge       ]  virtual/opengl-7.0-r1::gentoo  ABI_X86="32 (64) (-x32)"
[nomerge       ]   media-libs/mesa-12.0.1::gentoo  USE="classic dri3 egl gallium gbm llvm nptl udev -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -vaapi -valgrind -vdpau -wayland -xa -xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="radeon (-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeonsi (-vc4) -vmware"
[ebuild     U  ]    app-eselect/eselect-mesa-0.0.10-r1::gentoo [0.0.10::gentoo] 0 KiB
[nomerge       ] net-wireless/aircrack-ng-1.2_rc1-r1::gentoo  USE="airdrop-ng airgraph-ng netlink pcre sqlite unstable" PYTHON_TARGETS="python2_7"
[nomerge       ]  net-wireless/lorcon-0.0_p20150109::gentoo  USE="python -ruby" PYTHON_TARGETS="python2_7" RUBY_TARGETS="(ruby20) (-ruby19)"
[nomerge       ]   dev-lang/python-exec-2.4.4:2::gentoo [2.0.2:2::gentoo] PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_4) (python3_5) (python3_6%*) (-python3_3%)"
[blocks b      ]    <app-eselect/eselect-python-20160206 ("<app-eselect/eselect-python-20160206" is blocking dev-lang/python-exec-2.4.4)
[ebuild     U  ]     app-eselect/eselect-python-20160516::gentoo [20140125-r1::gentoo] 46 KiB
[nomerge       ] app-emulation/wine-1.8.3::gentoo  USE="X alsa fontconfig gecko jpeg lcms mono mp3 ncurses nls opengl perl png realtime run-exes ssl threads truetype udisks xcomposite xml -capi -cups -custom-cflags -dos -gphoto2 -gsm -gstreamer -ldap -netapi -odbc -openal -opencl -osmesa -oss -pcap -pipelight -prelink -pulseaudio -s3tc -samba -scanner (-selinux) -staging {-test} -v4l -vaapi -xinerama" ABI_X86="32 64 (-x32)" LINGUAS="it -ar -bg -ca -cs -da -de -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW"
[nomerge       ]  net-libs/gnutls-3.3.26::gentoo [3.3.17.1::gentoo] USE="crywrap cxx nls openssl zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="32 (64) (-x32)" LINGUAS="it -cs -de -en -fi -fr -ms -nl -pl -sv -uk -vi -zh_CN"
[ebuild     U  ]   net-dns/libidn-1.33::gentoo [1.30::gentoo] USE="nls -doc -emacs -java -mono -static-libs" ABI_X86="32 (64) (-x32)" 3419 KiB
[ebuild     U  ]  sys-devel/flex-2.6.1::gentoo [2.5.39-r1::gentoo] USE="nls -static {-test}" ABI_X86="32 (64) (-x32)" 816 KiB
[ebuild     U  ] app-arch/tar-1.29-r1::gentoo [1.28-r1::gentoo] USE="acl nls xattr -minimal (-selinux) -static" 2653 KiB
[nomerge       ] sys-fs/e2fsprogs-1.43.3-r1::gentoo [1.42.13::gentoo] USE="nls -fuse% -static-libs"
[ebuild     U  ]  sys-libs/e2fsprogs-libs-1.43.3::gentoo [1.42.13::gentoo] USE="nls -static-libs" ABI_X86="32 (64) (-x32)" 586 KiB
[ebuild     U  ] sys-devel/make-4.2.1::gentoo [4.1-r1::gentoo] USE="nls -guile -static" 1375 KiB
[ebuild     U  ] sys-apps/sed-4.2.2::gentoo [4.2.1-r1::gentoo] USE="acl nls (-selinux) -static" 1035 KiB
[nomerge       ] virtual/package-manager-0::gentoo
[nomerge       ]  sys-apps/portage-2.3.3::gentoo [2.3.0::gentoo] USE="(ipc) xattr -build -doc -epydoc -native-extensions% (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-python3_5) (-python3_3%)"
[ebuild     U  ]   sys-apps/sandbox-2.10-r3::gentoo [2.10-r1::gentoo] USE="(-multilib%*)" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U  ]    app-misc/pax-utils-1.1.7::gentoo [1.1.6::gentoo] USE="seccomp -caps -debug -python" 634 KiB
[ebuild     U  ]   app-shells/bash-4.3_p48-r1::gentoo [4.3_p46-r1::gentoo] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins (-vanilla%)" 6 KiB
[ebuild     U  ]    sys-libs/readline-6.3_p8-r3::gentoo [6.3_p8-r2::gentoo] USE="-static-libs -utils" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ]   dev-lang/python-exec-2.4.4:2::gentoo [2.0.2:2::gentoo] PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_4) (python3_5) (python3_6%*) (-python3_3%)" 85 KiB
[nomerge       ] xfce-extra/tumbler-0.1.31::gentoo  USE="curl ffmpeg gstreamer jpeg odf pdf raw -debug"
[nomerge       ]  gnome-extra/libgsf-1.14.36:0/114::gentoo  USE="bzip2 gtk introspection"
[ebuild     U  ]   dev-libs/gobject-introspection-common-1.48.0::gentoo [1.46.0::gentoo] 0 KiB
[nomerge       ] x11-misc/slim-1.3.6-r5::gentoo  USE="branding consolekit pam"
[nomerge       ]  x11-libs/libXft-2.3.2::gentoo  USE="-static-libs" ABI_X86="32 (64) (-x32)"
[ebuild     U  ]   virtual/ttf-fonts-1-r1::gentoo [1::gentoo] 0 KiB
[ebuild     U  ] sys-apps/coreutils-8.25::gentoo [8.23::gentoo] USE="acl nls xattr -caps -gmp -hostname% -kill% -multicall (-selinux) -static -vanilla" 5641 KiB
[nomerge       ] media-video/cheese-3.18.1-r1:0/8::gentoo  USE="introspection {-test}"
[nomerge       ]  dev-lang/vala-0.30.1:0.30::gentoo  USE="{-test}"
[ebuild     U  ]   dev-libs/vala-common-0.32.1::gentoo [0.30.1::gentoo] 2695 KiB
[ebuild     U  ] sys-devel/gnuconfig-20161104::gentoo [20151214::gentoo] 49 KiB
[nomerge       ] media-video/cheese-3.18.1-r1:0/8::gentoo  USE="introspection {-test}"
[nomerge       ]  media-libs/clutter-gst-3.0.18:3.0::gentoo  USE="X introspection udev -debug -examples"
[nomerge       ]   media-libs/cogl-1.22.0-r2:1.0/20::gentoo  USE="introspection kms opengl pango -debug -examples -gles2 (-gstreamer) {-test} -wayland" VIDEO_CARDS="(-fglrx)"
[nomerge       ]    media-libs/mesa-12.0.1::gentoo  USE="classic dri3 egl gallium gbm llvm nptl udev -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -vaapi -valgrind -vdpau -wayland -xa -xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="radeon (-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeonsi (-vc4) -vmware"
[ebuild     U  ]     dev-libs/expat-2.2.0-r1::gentoo [2.1.1-r2::gentoo] USE="unicode -examples -static-libs" ABI_X86="32 (64) (-x32)" 405 KiB
[ebuild     U  ]    app-arch/xz-utils-5.2.3::gentoo [5.2.2::gentoo] USE="nls threads -static-libs" ABI_X86="32 (64) (-x32)" 1456 KiB
[blocks B      ] <x11-libs/gtk+-3.22.2:3 ("<x11-libs/gtk+-3.22.2:3" is blocking dev-util/gtk-update-icon-cache-3.22.2)

Total: 83 packages (76 upgrades, 4 new, 3 reinstalls), Size of downloads: 228431 KiB
Conflict: 5 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-58.1-r1:0/58.1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-57.1:0/57::gentoo, installed) pulled in by
    dev-libs/icu:0/57=[abi_x86_32(-),abi_x86_64(-)] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed)
                ^^^^^^                                                                                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/gtk+-3.20.9:3/3::gentoo, installed) pulled in by
    x11-libs/gtk+:3 required by (app-text/ghostscript-gpl-9.15-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (net-analyzer/wireshark-2.0.4:0/2.0.4::gentoo, installed)
    >=x11-libs/gtk+-3.4:3 required by (net-misc/networkmanager-openswan-1.0.8:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3/3= required by (xfce-extra/xfdashboard-0.4.0:0/0::gentoo, installed)
    x11-libs/gtk+:3[introspection] required by (x11-misc/alacarte-3.11.91:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.5.2:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-3.5.2:3[abi_x86_32(-),abi_x86_64(-)]) required by (x11-themes/gtk-engines-unico-1.0.3_pre20140109:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.13.2:3 required by (sys-apps/baobab-3.18.1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.12:3[introspection?] (>=x11-libs/gtk+-3.12:3[introspection]) required by (net-wireless/gnome-bluetooth-3.18.3:2/13::gentoo, installed)
    x11-libs/gtk+:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (x11-libs/gtk+:3[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/libcanberra-0.30-r5:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.12:3[abi_x86_32(-),abi_x86_64(-)] required by (x11-themes/gnome-themes-standard-3.18.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.0:3 required by (gnome-base/gvfs-1.26.3:0/0::gentoo, installed)
    x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.4:3 required by (net-misc/networkmanager-openvpn-1.0.8:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3= required by (xfce-extra/xfdashboard-0.4.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.4:3[introspection?] (>=x11-libs/gtk+-3.4:3[introspection]) required by (gnome-extra/nm-applet-1.0.10:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.10:3[introspection] required by (x11-libs/libwnck-3.14.1:3/3::gentoo, installed)
    x11-libs/gtk+:3 required by (media-sound/pulseaudio-8.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.15:3[X,abi_x86_32(-),abi_x86_64(-)] required by (media-libs/gst-plugins-bad-1.6.3:1.0/1.0::gentoo, installed)
    >=x11-libs/gtk+-3.14:3/3= required by (xfce-base/garcon-0.5.0-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.8.0:3[X=,introspection?,wayland=] (>=x11-libs/gtk+-3.8.0:3[X,introspection,-wayland]) required by (media-libs/clutter-gtk-1.6.6-r1:1.0/1.0::gentoo, installed)
    x11-libs/gtk+:3 required by (app-text/apvlv-0.1.5-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.14:3/3= required by (xfce-extra/xfce4-power-manager-1.5.2:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.18.0:3[X,abi_x86_32(-),abi_x86_64(-)] required by (dev-cpp/gtkmm-3.18.1:3.0/3.0::gentoo, installed)
    x11-libs/gtk+:3 required by (net-misc/remmina-1.2.0_rc3-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.3.6:3[X,introspection] required by (gnome-base/gnome-desktop-3.18.2:3/12::gentoo, installed)
    >=x11-libs/gtk+-3.2:3 required by (xfce-base/xfce4-panel-4.12.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3= required by (xfce-base/libxfce4ui-4.12.1-r2:0/0::gentoo, installed)
    x11-libs/gtk+:3[introspection] required by (dev-util/catfish-1.2.2:0/0::gentoo, installed)
    x11-libs/gtk+:3 required by (media-sound/gmtp-1.3.10:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.8:3[introspection] required by (x11-libs/vte-0.42.5:2.91/2.91::gentoo, installed)
    x11-libs/gtk+:3 required by (sci-calculators/galculator-2.1.4:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3= required by (xfce-base/xfce4-appfinder-4.12.0-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.4:3 required by (net-misc/networkmanager-pptp-1.0.8:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.14:3= required by (xfce-extra/xfce4-power-manager-1.5.2:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.5.1:3 required by (x11-misc/xdg-user-dirs-gtk-0.10:0/0::gentoo, installed)
    x11-libs/gtk+:3 required by (dev-libs/appstream-glib-0.5.15:0/8::gentoo, installed)
    >=x11-libs/gtk+-3.6:3 required by (x11-themes/clearlooks-phenix-3.0.15:3.6/3.6::gentoo, installed)
    >=x11-libs/gtk+-3.14:3= required by (xfce-base/garcon-0.5.0-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.4:3/3= required by (net-p2p/transmission-2.84-r4:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.12:3[X,introspection] required by (app-crypt/gcr-3.18.0:0/1::gentoo, installed)
    >=x11-libs/gtk+-3.2:3/3= required by (xfce-base/libxfce4ui-4.12.1-r2:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3/3= required by (xfce-base/xfce4-appfinder-4.12.0-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.13.4:3[introspection] required by (media-video/cheese-3.18.1-r1:0/8::gentoo, installed)
    >=x11-libs/gtk+-3.3.18:3[aqua?] (>=x11-libs/gtk+-3.3.18:3) required by (media-libs/clutter-1.24.2:1.0/1.0::gentoo, installed)

  (dev-util/gtk-update-icon-cache-3.22.2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-util/gtk-update-icon-cache required by @selected
    >=dev-util/gtk-update-icon-cache-2 required by (x11-libs/gtk+-2.24.31:2/2::gentoo, installed)
    >=dev-util/gtk-update-icon-cache-3 required by (x11-libs/gtk+-3.20.9:3/3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages




so i tryed again whit the --oneshoot switch to try to get rid of this... but:

Code:

~ # emerge -1avg x11-libs/gtk+ dev-util/gtk-update-icon-cache

 * IMPORTANT: 18 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-util/gtk-update-icon-cache-3.22.2::gentoo [3.20.9::gentoo] 358 KiB
[binary   R    ] x11-libs/gtk+-3.20.9:3::gentoo  USE="X introspection vim-syntax (-aqua) -broadway -cloudprint -colord -cups -examples {-test} -wayland -xinerama" ABI_X86="32 (64) (-x32)" 0 KiB
[blocks B      ] <x11-libs/gtk+-3.22.2:3 ("<x11-libs/gtk+-3.22.2:3" is blocking dev-util/gtk-update-icon-cache-3.22.2)

Total: 2 packages (1 upgrade, 1 reinstall, 1 binary), Size of downloads: 358 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-util/gtk-update-icon-cache-3.22.2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-util/gtk-update-icon-cache required by @selected
    dev-util/gtk-update-icon-cache
    >=dev-util/gtk-update-icon-cache-2 required by (x11-libs/gtk+-2.24.31:2/2::gentoo, installed)
    >=dev-util/gtk-update-icon-cache-3 required by (x11-libs/gtk+-3.20.9:3/3::gentoo, binary scheduled for merge)

  (x11-libs/gtk+-3.20.9:3/3::gentoo, binary scheduled for merge) pulled in by
    x11-libs/gtk+:3 required by (net-analyzer/wireshark-2.0.4:0/2.0.4::gentoo, installed)
    >=x11-libs/gtk+-3.4:3 required by (net-misc/networkmanager-openswan-1.0.8:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3/3= required by (xfce-extra/xfdashboard-0.4.0:0/0::gentoo, installed)
    x11-libs/gtk+:3[introspection] required by (x11-misc/alacarte-3.11.91:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.5.2:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-3.5.2:3[abi_x86_32(-),abi_x86_64(-)]) required by (x11-themes/gtk-engines-unico-1.0.3_pre20140109:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.13.2:3 required by (sys-apps/baobab-3.18.1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.12:3[introspection?] (>=x11-libs/gtk+-3.12:3[introspection]) required by (net-wireless/gnome-bluetooth-3.18.3:2/13::gentoo, installed)
    x11-libs/gtk+:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (x11-libs/gtk+:3[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/libcanberra-0.30-r5:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.12:3[abi_x86_32(-),abi_x86_64(-)] required by (x11-themes/gnome-themes-standard-3.18.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.0:3 required by (gnome-base/gvfs-1.26.3:0/0::gentoo, installed)
    x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.4:3 required by (net-misc/networkmanager-openvpn-1.0.8:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3= required by (xfce-extra/xfdashboard-0.4.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.4:3[introspection?] (>=x11-libs/gtk+-3.4:3[introspection]) required by (gnome-extra/nm-applet-1.0.10:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3/3= required by (xfce-base/libxfce4ui-4.12.1-r2:0/0::gentoo, installed)
    x11-libs/gtk+
    >=x11-libs/gtk+-3.10:3[introspection] required by (x11-libs/libwnck-3.14.1:3/3::gentoo, installed)
    x11-libs/gtk+:3 required by (media-sound/pulseaudio-8.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.15:3[X,abi_x86_32(-),abi_x86_64(-)] required by (media-libs/gst-plugins-bad-1.6.3:1.0/1.0::gentoo, installed)
    >=x11-libs/gtk+-3.14:3/3= required by (xfce-base/garcon-0.5.0-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.8.0:3[X=,introspection?,wayland=] (>=x11-libs/gtk+-3.8.0:3[X,introspection,-wayland]) required by (media-libs/clutter-gtk-1.6.6-r1:1.0/1.0::gentoo, installed)
    x11-libs/gtk+:3 required by (app-text/apvlv-0.1.5-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.14:3/3= required by (xfce-extra/xfce4-power-manager-1.5.2:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.18.0:3[X,abi_x86_32(-),abi_x86_64(-)] required by (dev-cpp/gtkmm-3.18.1:3.0/3.0::gentoo, installed)
    x11-libs/gtk+:3 required by (net-misc/remmina-1.2.0_rc3-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.3.6:3[X,introspection] required by (gnome-base/gnome-desktop-3.18.2:3/12::gentoo, installed)
    >=x11-libs/gtk+-3.2:3 required by (xfce-base/xfce4-panel-4.12.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3= required by (xfce-base/libxfce4ui-4.12.1-r2:0/0::gentoo, installed)
    x11-libs/gtk+:3[introspection] required by (dev-util/catfish-1.2.2:0/0::gentoo, installed)
    x11-libs/gtk+:3 required by (media-sound/gmtp-1.3.10:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.8:3[introspection] required by (x11-libs/vte-0.42.5:2.91/2.91::gentoo, installed)
    x11-libs/gtk+:3 required by (sci-calculators/galculator-2.1.4:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3= required by (xfce-base/xfce4-appfinder-4.12.0-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.4:3 required by (net-misc/networkmanager-pptp-1.0.8:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.14:3= required by (xfce-extra/xfce4-power-manager-1.5.2:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.5.1:3 required by (x11-misc/xdg-user-dirs-gtk-0.10:0/0::gentoo, installed)
    x11-libs/gtk+:3 required by (dev-libs/appstream-glib-0.5.15:0/8::gentoo, installed)
    >=x11-libs/gtk+-3.6:3 required by (x11-themes/clearlooks-phenix-3.0.15:3.6/3.6::gentoo, installed)
    >=x11-libs/gtk+-3.14:3= required by (xfce-base/garcon-0.5.0-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.4:3/3= required by (net-p2p/transmission-2.84-r4:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.12:3[X,introspection] required by (app-crypt/gcr-3.18.0:0/1::gentoo, installed)
    x11-libs/gtk+:3 required by (app-text/ghostscript-gpl-9.15-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.2:3/3= required by (xfce-base/xfce4-appfinder-4.12.0-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.13.4:3[introspection] required by (media-video/cheese-3.18.1-r1:0/8::gentoo, installed)
    >=x11-libs/gtk+-3.3.18:3[aqua?] (>=x11-libs/gtk+-3.3.18:3) required by (media-libs/clutter-1.24.2:1.0/1.0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages



am i using it in the wrong manner or this is simply a nasty case?
i've tryed also to pull them once at time but this is what i get :

this for gtk+

Code:

~ # emerge -1avg x11-libs/gtk+

 * IMPORTANT: 18 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[binary   R    ] x11-libs/gtk+-3.20.9:3::gentoo  USE="X introspection vim-syntax (-aqua) -broadway -cloudprint -colord -cups -examples {-test} -wayland -xinerama" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 1 package (1 reinstall, 1 binary), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] n

Quitting.


and this for gtk-update-icon-cache


Code:
https://paste.pound-python.org/show/93xhJYnyl5WBTXsg5FyD/


any help will be appreciated
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16265
Location: here

PostPosted: Mon Feb 13, 2017 12:01 pm    Post subject: Reply with quote

If you want =dev-util/gtk-update-icon-cache-3.22.2 you need to unmask version 3.22.5 of gtk+:3
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
abstr4kt
n00b
n00b


Joined: 22 Jul 2005
Posts: 19

PostPosted: Mon Feb 13, 2017 1:21 pm    Post subject: Reply with quote

@fedeliallalinea thanks for the quick reply..
i'm looking for upgrade the entire system, i don't really have a special need to emerge gtk-update-icon-cache-3.22.2
but if i have understand what you said i can try to add ACCEPT_KEYWORDS="~amd64" to install gtk+ and finally reach to install gtk-update-icon-cache-3.22.2

Code:

~ # ACCEPT_KEYWORDS="~amd64" emerge -avg gtk+

 * IMPORTANT: 18 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/glew-2.0.0:0/2.0::gentoo [1.10.0-r2:0/1.10::gentoo] USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 652 KiB
[ebuild  N     ] dev-libs/libuv-1.10.2:0/1::gentoo  USE="-static-libs" ABI_X86="32 (64) (-x32)" 1050 KiB
[ebuild     U  ] dev-util/cmake-3.7.2::gentoo [3.5.2-r1::gentoo] USE="ncurses -doc -emacs -qt5 -system-jsoncpp {-test} (-qt4%)" 7190 KiB
[ebuild  r  U  ] media-libs/libprojectm-2.1.0-r2::gentoo [2.1.0-r1::gentoo] USE="openmp -debug" VIDEO_CARDS="-nvidia" 0 KiB
[ebuild     U  ] x11-libs/gtk+-3.22.5:3::gentoo [3.20.9:3::gentoo] USE="X introspection vim-syntax (-aqua) -broadway -cloudprint -colord -cups -examples {-test} -wayland -xinerama" ABI_X86="32 (64) (-x32)" 17824 KiB

Total: 5 packages (4 upgrades, 1 new), Size of downloads: 26713 KiB

The following packages are causing rebuilds:

  (media-libs/glew-2.0.0:0/2.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-libs/libprojectm-2.1.0-r2:0/0::gentoo, ebuild scheduled for merge)

Would you like to merge these packages? [Yes/No] n



i cant manage out if is the good way to go head..


Last edited by abstr4kt on Mon Feb 13, 2017 1:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16265
Location: here

PostPosted: Mon Feb 13, 2017 1:30 pm    Post subject: Reply with quote

abstr4kt wrote:
but if i have understand what you said i can try to add ACCEPT_KEYWORDS="~amd64" to install gtk+ and then all reach to instgtk-update-icon-cache-3.22.2

It's not a good idea to add ACCEPT_KEYWORDS="~amd64" before emerge, because this try to install all unstable packages that depending on gtk+.
You can add gtk+ to unstable with /etc/portage/package.accept_keywords
Code:
# echo "=x11-libs/gtk+-3.22.5 ~amd64" >> /etc/portage/package.accept_keywords

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
nativemad
Developer
Developer


Joined: 30 Aug 2004
Posts: 892
Location: Switzerland

PostPosted: Mon Feb 13, 2017 4:27 pm    Post subject: Reply with quote

Hi,

I guess the problem is that you just requested to update cups with all it's deps which are shared with other things in the system (gtk) which are not really requested to update in the same run!
Either do -uDN with @world instead of a package or leave away the -D!
Leaving "-D" away only works if the package in question doesn't require the newer versions of the deps explicitly. Another way would be to not only update cups but also the other bits which would cause breakage... (qtwebkit for the icu dep and probably gtk+. With them also queried to update it might need even more packages depending on those deps....... so it would be easier to just take everything with @world :wink: )

HTH, cheers
_________________
Power to the people!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum