Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
equery usage problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
petko3000
n00b
n00b


Joined: 24 May 2013
Posts: 5

PostPosted: Mon May 27, 2013 11:54 am    Post subject: equery usage problem Reply with quote

Hello guys. I found another problem with my gentoo box:

Code:

dev ~ # equery '*'
Traceback (most recent call last):
  File "/usr/bin/equery", line 35, in <module>
    from gentoolkit import equery, errors
ImportError: No module named 'gentoolkit'


I already tried to re-emerge portage and gentoolkit. Nothing help :(

Code:

dev ~ # emerge --info
Portage 2.1.12.2 (default/linux/x86/13.0, gcc-4.5.4, glibc-2.15-r3, 3.6.6-gentoo i686)
=================================================================
System uname: Linux-3.6.6-gentoo-i686-Intel-R-_Celeron-R-_CPU_847_@_1.10GHz-with-gentoo-2.2
KiB Mem:     3525876 total,    174844 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Mon, 27 May 2013 01:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.4, 3.3.2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13::<unknown repository>, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/alias /var/qmail/control /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl acpi alsa apache2 arts avi berkdb crypt cxx dvd gdbm gpm java jikes kde kdeenablefinal maildir mmx nptl pam qt3support readline rtc scanner sse sse2 ssl unicode usb x86" ABI_X86="32" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CURL_SSL="openssl" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" PHP_TARGETS="php5.4" PYTHON_TARGETS="python2_7 python3_3" USERLAND="GNU" VIDEO_CARDS="fbdev nvidia v4l vesa" VOICEMAIL_STORAGE="file"
USE_PYTHON="2.7"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Thank you for you help.
Back to top
View user's profile Send private message
petko3000
n00b
n00b


Joined: 24 May 2013
Posts: 5

PostPosted: Mon May 27, 2013 12:40 pm    Post subject: fixed with choosing right active python interpreter Reply with quote

Code:

dev ~ # eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3 *
dev ~ # eselect python set 1
dev ~ # eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.3
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7403
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon May 27, 2013 12:41 pm    Post subject: Reply with quote

Well, first of all, that's invalid syntax. Try
Code:
equery list -i portage
just as a test. What were you trying to do?

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1545

PostPosted: Mon May 27, 2013 7:55 pm    Post subject: Re: fixed with choosing right active python interpreter Reply with quote

petko3000 wrote:
Code:
dev ~ # eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3 *
dev ~ # eselect python set 1
dev ~ # eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.3

petko3000 ... if you do this then you will have issues with python. In order to change the default python you need to run 'python-updater' and possibly 'revdep-rebuild', for example:

Code:
# eselect python set python3.2
# python-updater
# emerge --ask --depclean
# revdep-rebuild

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum