Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
b43 dropping connection
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sat May 25, 2013 11:05 pm    Post subject: b43 dropping connection Reply with quote

my b43 likes to drop the connection to wpa2 access point after a minute of inactivity. it has been noted elsewhere.

http://ubuntuforums.org/showthread.php?t=1390174

its hardware is b4311 & software is b43 + nm-applet....

im experiencing strange behavior where i have to run wicd's refresh to load the network list also.

dmesg is flooded with these messages....

Code:

[  112.525837] wlan0: authenticate with xx:xx:xx:xx:xx:xx
[  112.555080] wlan0: send auth to xx:xx:xx:xx:xx:xx (try 1/3)
[  112.756045] wlan0: send auth to xx:xx:xx:xx:xx:xx (try 2/3)
[  112.957048] wlan0: send auth to xx:xx:xx:xx:xx:xx (try 3/3)
[  113.158031] wlan0: authentication with xx:xx:xx:xx:xx:xx timed out
&&
[  125.949399] wlan0: RX AssocResp from xx:xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
[  125.949829] wlan0: associated
[  125.949874] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  127.058164] wlan0: deauthenticating from xx:xx:xx:xx:xx:xx by local choice (reason=3)



another instance....
still connected, pages stop responding, cant ping google cant ping gateway....

dmesg says

"wlan0: authenticated"
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1361
Location: Montréal

PostPosted: Sun May 26, 2013 2:02 am    Post subject: Reply with quote

Did you disable the power management on the wireless card?
Code:
iwconfig wlan0 power off

I ever had a Broadcom wireless card. For long I was force to use the broadcom-sta wl module. The b43 module was not working. At the end, b43 was working. The firmware version in use can make a difference.

I set my country option in cfg80211 module and use specials options for module mac80211 in /etc/modprobe.d/modprobe.conf
Code:
options cfg80211 ieee80211_regdom=CA
options mac80211 max_nullfunc_tries=60 max_probe_tries=60 probe_wait_ms=3600000

With the mac80211 options, I try to give all the time needed to prevent disconncection. That may not make a difference at all. I just come to check dmesg on my two laptops. I have no wireless lan message since the connexion have been established. But they do not use b43, they use ath9k and rt2800pci modules.
_________________
Paul
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sun May 26, 2013 2:48 am    Post subject: Reply with quote

i used fwcutter and broadcom firmware to get b43 working.... im using it because of aircrack... i think im going to have to get another module for daily use going, possibly broadcom-sta though i dislike that idea, i like the idea of having the power to be a wireless access point.

Code:

mkultra@mkultra [ ~ ]$ sudo iwconfig wlan0 power off
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.


it could have something to do with the kernel, as i updated to 3.9.3, and did not follow the wireless wiki on kernel configuration, and didnt have this problem in 3.7.x series of kernels. its bad, like every 2 minutes dropping regardless of load or no load.

powersaving by default was compiled into my kernel... ill try chopping that 1 option out.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum