Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
upgrade asking to merge, but is masked...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
papapenguin
l33t
l33t


Joined: 20 Sep 2005
Posts: 694
Location: Bellevue

PostPosted: Wed May 29, 2013 6:29 pm    Post subject: upgrade asking to merge, but is masked... Reply with quote

hello, just did a downgrade to some stable packages and got this...
Code:
papapenguin ~ # emerge -avuDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-apps/less-459 [458] USE="pcre unicode" 305 kB
[ebuild     U  ] media-sound/alsa-utils-1.0.27.1-r1:0.9 [1.0.27-r1:0.9] USE="libsamplerate ncurses nls -doc (-selinux)" 1,117 kB
[ebuild     U  ] sys-apps/kmod-13-r1 [13] USE="tools zlib -debug -doc -lzma -static-libs" 0 kB
[ebuild     U  ] media-video/transcode-1.1.7-r2 [1.1.7-r1] USE="X a52 aac alsa dv dvd iconv jpeg mmx mp3 mpeg ogg quicktime sdl sse sse2 theora truetype v4l vorbis x264 xml xvid -3dnow (-altivec) -imagemagick -lzo -mjpeg (-nuv) -oss (-pic) -postproc" 0 kB
[ebuild     U  ] media-libs/libjpeg-turbo-1.3.0 [1.2.90] USE="java -static-libs" 1,330 kB
[ebuild  N     ] kde-base/kopete-4.10.2:4  USE="addbookmarks autoreplace contactnotes handbook highlight history jingle msn nowlistening oscar pipes privacy ssl statistics texteffect translator urlpicpreview v4l xmpp yahoo (-aqua) -debug -gadu -groupwise -latex -meanwhile -otr -skype -sms -testbed -webpresence -winpopup -zeroconf" 0 kB
[ebuild  N     ] kde-base/kdenetwork-meta-4.10.2:4  USE="(-aqua) -ppp" 0 kB
[ebuild     UD ] kde-base/kde-meta-4.10.2:4 [4.10.3:4] USE="accessibility nls semantic-desktop (-aqua) -sdk" 0 kB
[ebuild     U  ] dev-java/icedtea-7.2.3.9:7 [7.2.3.8:7] USE="X alsa cups javascript jbootstrap nsplugin nss source webstart -cjk -debug -doc -examples -pax_kernel -pulseaudio -systemtap {-test}" 72,756 kB

Total: 9 packages (6 upgrades, 1 downgrade, 2 new), Size of downloads: 75,506 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

virtual/mysql:0

  (virtual/mysql-5.5::gentoo, ebuild scheduled for merge) conflicts with
    =virtual/mysql-5.1 required by (dev-db/mysql-5.1.67::gentoo, installed)

app-admin/apache-tools:0

  (app-admin/apache-tools-2.4.4-r1::gentoo, ebuild scheduled for merge) conflicts with
    ~app-admin/apache-tools-2.2.24 required by (www-servers/apache-2.2.24::gentoo, installed)


Would you like to merge these packages? [Yes/No]

is this a problem, or should I just let it pass?
_________________
--------------
Compaq Presario V6120US
AMD Turion 64X2
------------------------
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 8045
Location: Saint Amant, Acadiana

PostPosted: Thu May 30, 2013 1:47 am    Post subject: Reply with quote

This is not a problem, you can upgrade. Some packages will not be upgraded at this time because of dependencies.
_________________
My Gentoo installation notes.
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
papapenguin
l33t
l33t


Joined: 20 Sep 2005
Posts: 694
Location: Bellevue

PostPosted: Thu May 30, 2013 4:22 am    Post subject: Reply with quote

thanks...I think I may have gotten these messages because I added these packages to
Code:
papapenguin ~ # cat /etc/portage/package.accept_keywords
sys-kernel/gentoo-sources       -~amd64
kde-base/*                      -~amd64
app-office/akonadi-server       -~amd64
media-libs/mediastreamer        -~amd64
dev-libs/soprano                -~amd64
www-servers/apache              -~amd64
#dev-lang/python                        -~amd64

it also may have happened because I can't run eclean...
_________________
--------------
Compaq Presario V6120US
AMD Turion 64X2
------------------------
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum