Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Turning my laptop into an access point
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 30 Jan 2004
Posts: 980

PostPosted: Fri May 24, 2013 1:11 pm    Post subject: Turning my laptop into an access point Reply with quote

Hi All:

Ok, kids' school holidays and the WHOLE gang is at a resort for a few days...hotel has only a single wired connection in our room to support mummy with her Korean dramas on the internet (laptop with windows) and the kids' ipads and daddy's late night Samsung galaxy. "Daddy, why no Internet?".

Hey, I run Gentoo Linux on my laptop, lets put this thing to work.

Ok, I'm on a Dell Precision 4600 with this wireless card:
03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)

Which uses this module:

Problem is, when you try:
iwconfig wlp3s mode master...
it fails like this:
jserinki7 linux # iwconfig wlp3s mode master
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlp3s ; No such device.

And as this shows:
iw list:

Supported interface modes:
* managed
* monitor

it doesn't support being an AP...just my luck. but wait, in my computer bag I have an old Edimax USB 2.4G wireless thinggy...
Plug it in, cool.
Followed advice here on how to set things up:

jserinki7 ap # cat /home/jserink/linux/ap/hostapd-test.conf
jserinki7 ap #

Fired up hostapd like this:
hostapd hostapd-test.conf

and got this error in /var/log/everything/current
May 24 12:28:04 [kernel] [ 1333.206006] phy1 -> rt2x00lib_request_firmware: Info - Loading firmware file 'rt73.bin'.
May 24 12:28:04 [kernel] [ 1333.208338] phy1 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
May 24 12:33:28 [kernel] [ 1656.878991] usb 1-1: USB disconnect, device number 2

ok, it needs FW. Tried to emerge this:
net-wireless/ralink-firmware which was masked but it died from plenty of errors....ralink has been bought out so their FW site is different but then once finding the required files and dumping them in /usr/portage/distfiles the ebuild burps and farts on the unzipping of stuff.....

Google and get plenty of hits, downloaded it, expanded it and copied over rt73.bin to /lib/firmware, plug the unit in a away we go!

Great, DNS masq setup:
jserinki7 linux # cat /etc/dnsmasq.conf

And that's it, it all works.
So, just to review, did the following:
1. plug the Edimax USB thinggy in,
2. Assign the IP to the new interface wlp0s29u1u2,
3. Start up, as root, hostapd from the command line with the above config file,
4. Start dnsmasq like this: /etc/init.d/dnsmasq start
5. Push in the Ip tables rules to make it go:
echo "1" > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o enp0s25 -j MASQUERADE
iptables -A FORWARD -j ACCEPT
iptables -A INPUT -i wlp0s29u1u2 -j ACCEPT

and kids and mummy are happy.

its all good!


Last edited by jserink on Thu May 30, 2013 11:54 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Fri May 24, 2013 3:43 pm    Post subject: Reply with quote

can you clean this up and post it as a wiki please?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum