Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Fullscreen VirtualBox guest, MaxGuestResolution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
neoancient
n00b
n00b


Joined: 02 Jul 2003
Posts: 9

PostPosted: Thu May 23, 2013 4:03 pm    Post subject: [solved] Fullscreen VirtualBox guest, MaxGuestResolution Reply with quote

Hello,
I have a 64 bit Windows 7 guest running on a gentoo host with two physical screens, which is working great except for full screen mode.

Full screen guest takes over one of my screens (which I expect) but resets the guest's resolution to double screen width, which is slightly annoying. I've tried variations on
Code:
VBoxManage setextradata global GUI/MaxGuestResolution 1280,1024
to no avail.

Hope someone can help. Please see https://forums.virtualbox.org/viewtopic.php?f=7&t=55669 for more details.

Jez.


Last edited by neoancient on Thu May 23, 2013 4:59 pm; edited 3 times in total
Back to top
View user's profile Send private message
imaginasys
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2009
Posts: 83
Location: Québec

PostPosted: Thu May 23, 2013 4:19 pm    Post subject: Reply with quote

I have 2 monitor and use virtualbox on kubuntu with E17 for a windows guest.

I set myself the resolution with the followings commands:

Code:
xrandr --output VGA1 --mode 1920x1080
xrandr  --output HDMI2 --mode 1920x1080
xrandr  --output HDMI2 --right-of VGA1


In virtual box I have installed the vbox GuestAdditions and I have set the screen to full screen with "Host+F" and automatic size "Host+G".
I have given only one screen to the vm.

I have absolutly no problem with may screen resolution it stays at "1920x1080".

But with enlightenment I get 4 desktop on each screen, it can get confusing.

I hope it helps,

BT :mrgreen:

PS: Check if you have activated screen resize mode "Host+C" , you should not. (I'm not sure of the term, my machine speaks french but check for the shortcut it should be the same).
Back to top
View user's profile Send private message
neoancient
n00b
n00b


Joined: 02 Jul 2003
Posts: 9

PostPosted: Thu May 23, 2013 4:56 pm    Post subject: Reply with quote

Thanks imaginasys,

I've got this working now. I tried your additional xrandr lines, but I think what makes the difference is the "auto resize Guest Display [Host+G]" setting. I see now that it's a toggle: it was on, and I needed it to be off.

Cheers,
Jez.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum