Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
warning: don't compile vim with gcc-4.8 + graphite on amd64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 3782

PostPosted: Sun May 19, 2013 6:47 am    Post subject: warning: don't compile vim with gcc-4.8 + graphite on amd64 Reply with quote

The title says all: vim with gcc+4.8 and graphite (-floop-*) useflags compiles fine on amd64, but better do not use it: If you edit any file and save it, the saved file may be almost completely destroyed.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5610
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon May 20, 2013 4:31 pm    Post subject: Reply with quote

thanks for the heads up !

I edited a few kernel-files with it and it seemed to have gone fine

will put it into the package.env
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4076
Location: Removed by Neddy

PostPosted: Wed May 22, 2013 7:23 am    Post subject: Reply with quote

Very interesting bug. Is it known upstream
_________________
A free press is the unsleeping guardian of every other right that free men prize; it is the most dangerous foe of tyranny. Where men have the habit of liberty, the Press will continue to be the vigilant guardian of the rights of the ordinary citizen.
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 3782

PostPosted: Wed May 22, 2013 7:34 am    Post subject: Reply with quote

Naib wrote:
Very interesting bug. Is it known upstream

Since it is a gcc bug, one would have to produce a simple test case to report it - I have no time to do that. However, gentoo toolchain knows about the problem: texlive-core fails to compile, too, I guess for the same reason. And libreoffices newly crashes on my am64 system, too, but not on x86: I bet it is again related to some library being compiled with graphite (I do not use graphite for libreoffice itself).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum