Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
startx normal user
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
titusIII
n00b
n00b


Joined: 03 Jan 2016
Posts: 15

PostPosted: Thu Jan 07, 2016 5:54 pm    Post subject: startx normal user Reply with quote

Bonjour,

Je ne peux lancer X et gnome qu'en root.

Code:
drwxr-xr-x 14 myuser root  4096  5 janv. 14:52 .
drwxr-xr-x  3 root  root  4096  4 janv. 22:52 ..
-rw-------  1 myuser myuser  222  5 janv. 14:53 .bash_history
drwxr-xr-x  3 myuser myuser 4096  5 janv. 14:51 .cache
drwx------  7 myuser myuser 4096  5 janv. 14:51 .config
drwx------  3 myuser myuser 4096  5 janv. 14:20 .dbus
drwxr-xr-x  2 myuser myuser 4096  5 janv. 14:28 Desktop
drwxr-xr-x  2 myuser myuser 4096  5 janv. 14:28 Documents
drwxr-xr-x  2 myuser myuser 4096  5 janv. 14:28 Downloads
-rw-------  1 myuser myuser  676  5 janv. 14:51 .ICEauthority
drwx------  3 myuser myuser 4096  5 janv. 14:21 .local
drwxr-xr-x  2 myuser myuser 4096  5 janv. 14:28 Music
drwxr-xr-x  2 myuser myuser 4096  5 janv. 14:28 Pictures
drwxr-xr-x  2 myuser myuser 4096  5 janv. 14:28 Public
drwxr-xr-x  2 myuser myuser 4096  5 janv. 14:28 Templates
drwxr-xr-x  2 myuser myuser 4096  5 janv. 14:28 Videos
-rw-------  1 myuser myuser    0  5 janv. 14:52 .Xauthority
-rw-r--r--  1 myuser myuser   49  5 janv. 13:05 .xinitrc


Code:
cat .xinitrc
export XDG_MENU_PREFIX=gnome-
exec gnome-session


J'ai déjà essayé de supprimer le fichier .Xauthority

Le log de Xorg ne retourne rien de particulier à part :
Code:
[    63.920] (II) UnloadModule: "synaptics"
[    63.920] (II) systemd-logind: releasing fd for 13:71
[    63.927] (II) evdev: AT Translated Set 2 keyboard: Close
[    63.927] (II) UnloadModule: "evdev"
[    63.927] (II) systemd-logind: releasing fd for 13:67
[    63.935] (II) evdev: Asus WMI hotkeys: Close
[    63.935] (II) UnloadModule: "evdev"
[    63.935] (II) systemd-logind: releasing fd for 13:68
[    63.948] (II) evdev: Logitech USB Receiver: Close
[    63.948] (II) UnloadModule: "evdev"
[    63.948] (II) systemd-logind: releasing fd for 13:70
[    63.955] (II) evdev: Logitech USB Receiver: Close
[    63.955] (II) UnloadModule: "evdev"
[    63.955] (II) systemd-logind: releasing fd for 13:69
[    63.960] (II) evdev: Sleep Button: Close
[    63.960] (II) UnloadModule: "evdev"
[    63.960] (II) systemd-logind: releasing fd for 13:65
[    63.967] (II) evdev: Power Button: Close
[    63.967] (II) UnloadModule: "evdev"
[    63.967] (II) systemd-logind: releasing fd for 13:66
[    64.771] (II) NVIDIA: Freed GPU:0 (GPU-168f1577-8240-bad8-2083-bd70c5adfc08) @
[    64.771] (II) NVIDIA:     PCI:0000:01:00.0
[    64.771] (II) NVIDIA(GPU-0): Deleting GPU-0
[    64.775] (II) Server terminated successfully (0). Closing log file.


Merci de votre aide. Rester en root c'est pas l'idéal...
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 6493
Location: ~Brussels - Belgique

PostPosted: Thu Jan 07, 2016 7:58 pm    Post subject: Reply with quote

Hello,

Es-tu avec systemd ? OpenRC ?

Est-ce que consolekit est bien configuré ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
titusIII
n00b
n00b


Joined: 03 Jan 2016
Posts: 15

PostPosted: Thu Jan 07, 2016 8:26 pm    Post subject: Reply with quote

Je suis avec systemd

Consolekit est installé oui.
Je n'ai pas trop touché à ses parametres encore. Je vais m'y pencher

Avec dans .xinitrc :
Code:
exec ck-launch-session dbus-launch gnome-session


En root ça marche et j'ai : pour list-session
Code:
Session2:
   unix-user = '0'
   realname = 'root'
   seat = 'Seat1'
   session-type = ''
   active = TRUE
   x11-display = ':0'
   x11-display-device = '/dev/tty1'
   display-device = '/dev/tty1'
   remote-host-name = ''
   is-local = TRUE
   on-since = '2016-01-07T20:39:26.856566Z'
   login-session-id = '2'


En user normal ça ne marche pas. Toujours le
Code:
Oh no! Something has gone wrong.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 6493
Location: ~Brussels - Belgique

PostPosted: Thu Jan 07, 2016 8:43 pm    Post subject: Reply with quote

hmm... regarde dans les groups de ton utilisateur s'il a tout ce qu'il faut (du genre video), il y a aussi cette piste.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
titusIII
n00b
n00b


Joined: 03 Jan 2016
Posts: 15

PostPosted: Thu Jan 07, 2016 8:52 pm    Post subject: Reply with quote

Avec le groupe "video" c'est mieux effectivement...
J'ai retourné tout mon OS pour une erreur comme celle là, je ne mérite même pas gentoo :(

Merci encore!

Résolu.


(j'ouvre un nouveau post qui parle du backlight de mon ordi)
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 6493
Location: ~Brussels - Belgique

PostPosted: Thu Jan 07, 2016 10:00 pm    Post subject: Reply with quote

Au contraire !

Je vois que tu maîtrises bien ton sujet et que tu creuses avant de nous poser des questions bien circonstanciées. J'ai juste énuméré des pistes (consolekit et groups) c'est toi qui as tout fait ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum