Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SEMI-SOLVED][ath9k] How to AR9280 & hostapd & 802.11n?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Bialy
Guru
Guru


Joined: 20 Mar 2006
Posts: 479

PostPosted: Tue May 14, 2013 11:08 am    Post subject: [SEMI-SOLVED][ath9k] How to AR9280 & hostapd & 802.1 Reply with quote

I fight with this trio a few months. Before I had only 802.11g (54Mbps), but yesterday I changed kernel and hostapd.
Nowadays I have 802.11n (130Mbps) and this message when hostapd starting:
Code:
rfkill: Cannot open RFKILL control device


I have Atheros AR9280 card:
Code:
ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xffffc90010ea0000, irq=16
Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

I crating AP with hostapd:
Code:
net-wireless/hostapd-2.0  USE="crda ipv6 ssl wps -logwatch -madwifi"

interface=wlp2s0
driver=nl80211
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2
dump_file=/tmp/hostapd.dump
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=Gentoo
country_code=PL
ieee80211d=1
hw_mode=g
channel=7
beacon_int=100
dtim_period=2
max_num_sta=255
rts_threshold=2347
fragm_threshold=2346
macaddr_acl=0
accept_mac_file=/etc/hostapd/hostapd.accept
deny_mac_file=/etc/hostapd/hostapd.deny
auth_algs=3
ignore_broadcast_ssid=0
wmm_enabled=1
wmm_ac_bk_cwmin=4
wmm_ac_bk_cwmax=10
wmm_ac_bk_aifs=7
wmm_ac_bk_txop_limit=0
wmm_ac_bk_acm=0
wmm_ac_be_aifs=3
wmm_ac_be_cwmin=4
wmm_ac_be_cwmax=10
wmm_ac_be_txop_limit=0
wmm_ac_be_acm=0
wmm_ac_vi_aifs=2
wmm_ac_vi_cwmin=3
wmm_ac_vi_cwmax=4
wmm_ac_vi_txop_limit=94
wmm_ac_vi_acm=0
wmm_ac_vo_aifs=2
wmm_ac_vo_cwmin=2
wmm_ac_vo_cwmax=3
wmm_ac_vo_txop_limit=47
wmm_ac_vo_acm=0
ieee80211n=1
ht_capab=[HT40+][SHORT-GI-40][DSSS_CCK-40]
eap_server=0
own_ip_addr=127.0.0.1
wpa=3
wpa_passphrase=You_want_to_know
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
and ath9k driver:
Code:
linux-3.8.6-hardened

CONFIG_WLAN=y
CONFIG_ATH9K_HW=y
CONFIG_ATH9K_COMMON=y
# CONFIG_ATH9K_BTCOEX_SUPPORT is not set
CONFIG_ATH9K=y
CONFIG_ATH9K_PCI=y
CONFIG_ATH9K_AHB=y
# CONFIG_ATH9K_DEBUGFS is not set
CONFIG_ATH9K_RATE_CONTROL=y
# CONFIG_ATH9K_HTC is not set

CONFIG_FIB_RULES=y
CONFIG_WIRELESS=y
CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
CONFIG_CFG80211=y
# CONFIG_NL80211_TESTMODE is not set
# CONFIG_CFG80211_DEVELOPER_WARNINGS is not set
# CONFIG_CFG80211_REG_DEBUG is not set
CONFIG_CFG80211_DEFAULT_PS=y
# CONFIG_CFG80211_DEBUGFS is not set
# CONFIG_CFG80211_INTERNAL_REGDB is not set
CONFIG_CFG80211_WEXT=y
# CONFIG_LIB80211 is not set
CONFIG_MAC80211=y
CONFIG_MAC80211_HAS_RC=y
CONFIG_MAC80211_RC_MINSTREL=y
CONFIG_MAC80211_RC_MINSTREL_HT=y
CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
CONFIG_MAC80211_RC_DEFAULT="minstrel_ht"
# CONFIG_MAC80211_MESH is not set
CONFIG_MAC80211_LEDS=y


What I want?

First of all, how to remove 'rfkill' message?
Second, how to enable full 802.11n support (300Mbps, MIMO 2x2)?


Last edited by Bialy on Thu May 16, 2013 3:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1547

PostPosted: Tue May 14, 2013 12:31 pm    Post subject: Re: [ath9k] How to AR9280 & hostapd & 802.11n? Reply with quote

Bialy wrote:
Code:
rfkill: Cannot open RFKILL control device

Baily ... you need to enable CONFIG_RFKILL ... its under: Networking support => RF switch subsystem support.

Bialy wrote:
I crating AP with hostapd:
Code:
net-wireless/hostapd-2.0  USE="crda ipv6 ssl wps -logwatch -madwifi"

CONFIG_IEEE80211N is enabled by default in the hostapd ebuild. Unrelated, but unless you must use WPS then I'd suggest you disable that useflag, also you may not want/need ipv6.

Bialy wrote:
Code:
driver=nl80211
hw_mode=g
ieee80211n=1
wmm_enabled=1
country_code=PL
ieee80211d=1

The hostapd.conf seems fine, all the 80211N options are enabled.

Bialy wrote:
Second, how to enable full 802.11n support (300Mbps, MIMO 2x2)?

The card is a AR928X and so should support the following (untested):

Code:
ht_capab=[HT40-][HT40+][SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40]

HTH & best ... khay
Back to top
View user's profile Send private message
Bialy
Guru
Guru


Joined: 20 Mar 2006
Posts: 479

PostPosted: Tue May 14, 2013 1:23 pm    Post subject: Re: [ath9k] How to AR9280 & hostapd & 802.11n? Reply with quote

khayyam wrote:
Bialy wrote:
Code:
rfkill: Cannot open RFKILL control device

Baily ... you need to enable CONFIG_RFKILL ... its under: Networking support => RF switch subsystem support.

I found it in the meantime ;)
khayyam wrote:

Bialy wrote:
Second, how to enable full 802.11n support (300Mbps, MIMO 2x2)?

The card is a AR928X and so should support the following (untested):

Code:
ht_capab=[HT40-][HT40+][SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40]

HTH & best ... khay

Still don't work, but I found this:
Code:
Neighboring BSS: 64:70:02:ae:b2:b8 freq=2437 pri=6 sec=2
40 MHz pri/sec mismatch with BSS 64:70:02:ae:b2:b8 <2437,2417> (chan=6-) vs. <2442,2462>
20/40 MHz operation not permitted on channel pri=7 sec=11 based on overlapping BSSes
Completing interface initialization

And Hostapd-0.7.3 description:
Quote:
> > Anyway, you wrote that hostapd check for overlapping BSSes only at startup. Let's assume that at the moment of start there was one
> > conflicting BSSes on our channels, so as result hostapd started in 20 mhz mode. Then, after some time this conflicting AP has
> > gone away (this is an example from real life). In this case, I guess, hostapd will still work in 20 mhz mode and will not switch
> > into 40 mhz mode because check for neighboring BSSes performed only at startup. Am I correct?
>
> Yes, that's the current implementation. This will hopefully get more
> dynamic in the future to allow 20/40 MHz mode to be enabled (and also
> disabled) automatically based on periodic scans by the AP and/or
> associated stations indicating that conflicting device leave/enter the
> radio range.
Back to top
View user's profile Send private message
Bialy
Guru
Guru


Joined: 20 Mar 2006
Posts: 479

PostPosted: Thu May 16, 2013 3:26 pm    Post subject: Reply with quote

I did it (almost). When my neighbor shut down his network, I restarted my hostapd and inSSIDer says that I using two channels.
Also inSSIDer says that "Max Rate" is 300Mbps, but my clients and AP shows only 130Mbps:
Code:
tx bitrate:     130.0 MBit/s MCS 15


Why Leo, why?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum