Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-base/gnome-panel fail to emerge[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
haleh
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 127

PostPosted: Tue May 14, 2013 10:34 am    Post subject: gnome-base/gnome-panel fail to emerge[solved] Reply with quote

Hi all
I upgrade my gnome to 3.6 and then I face new problems so I emerge systemd now one weird problem is still remain !I run revdep-rebuild it fail to emerge gnome-base/gnome-panel!

revdep-rebuild
http://www.bpaste.net/show/98695/

/var/tmp/portage/gnome-base/gnome-panel-3.6.2-r1/temp/build.log
http://www.bpaste.net/show/98696/

emerge --info
http://www.bpaste.net/show/98697/

I re emerge dev-libs/libgweather because of this error but nothing has changed!
Quote:
clock.c:57:38: fatal error: libgweather/gweather-xml.h: No such file or directory


when I want to login to gnome. error will be reported "Unable to load session gnome" it is because of gnome-panel .Isn't it ?

:? 8O :( :cry:
it seems that it is a gnome bug !
https://mail.gnome.org/archives/commits-list/2013-January/msg00398.html
what do you suggest me to do ?
now I don't have gnome-panel so don't have gnome ! what do you suggest me ?any idea ?


Last edited by haleh on Wed May 15, 2013 4:56 pm; edited 3 times in total
Back to top
View user's profile Send private message
haleh
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 127

PostPosted: Tue May 14, 2013 11:58 am    Post subject: Reply with quote

This is gnome-panel-3.6.2-r1 ebuild :
http://www.bpaste.net/show/98771/

unfortunately I somehow don't know Bash! This summer I will learn it :D so I don't know what this means but It says this should fix this problem but for me it doesn't !!!!In building gweather-include.patch is applied patch successfully !
Quote:

# Fix build error due to missing gweather-xml.h
epatch "${FILESDIR}/${P}-gweather-include.patch"



but why it has error ! Should I report this as bug ?
Edit :These two are for aclocal:
http://www.bpaste.net/show/98791/
http://www.bpaste.net/show/98790/
Back to top
View user's profile Send private message
HayarobiPark
n00b
n00b


Joined: 17 Apr 2013
Posts: 5

PostPosted: Wed May 15, 2013 6:30 am    Post subject: Reply with quote

The gnome-panel-3.6.2-r1 is currently masked by system. Make sure you had added gnome-panel version 3.6.2-r1 to package.mask and package.accept_keywords.

If you don't want to install masked pacakge, try this walkaround.
Code:
 
# cd /usr/include
# ln -s libgweather-3.0 libgweather-3.0/libgweather


I'm not sure that this is working since I didn't have this problem when building gnome-3.6 , but it take not so much time to try.
[/code]
Back to top
View user's profile Send private message
haleh
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jul 2012
Posts: 127

PostPosted: Wed May 15, 2013 4:55 pm    Post subject: Reply with quote

Thanks Hayarobipark for your reply ! I fix it ! I emerged libgweather-3.8 which it has bugs ! I unmerge it and emerge libgweather-3.6 ! I understand this when I read gnome-panel ebuild !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum