Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No internet connection.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ryuh90
n00b
n00b


Joined: 09 May 2013
Posts: 1

PostPosted: Thu May 09, 2013 8:51 pm    Post subject: No internet connection. Reply with quote

I'm pretty new to the Gentoo environment, but pretty experienced within Linux as a whole, but once I installed Gentoo(3.7.10-gentoo-r1), I have big problems with my internet connection(even though the LiveCD immediately caught it). I am using a Realtek RTL 8111E ethernet card but for some reason during the boot up screen, it's telling me it's loading an E1000 driver(for Intel? :?: ) and an R8169 driver. "ifconfig -a" only shows up with "enp5s0" and "lo" and I am clueless as to what went wrong.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Thu May 09, 2013 9:18 pm    Post subject: Reply with quote

ryuh90,

Welcome to Gentoo.

enp5s0 is your ethernet interface. The right kernel modules must be loaded.
This is the new shiny naming convention.

If you have dhcpcd installed and enp5s0 is a wired interface, it should just work.
Does
Code:
dhcpcd enp5s0
return any error messages?

If you had planned to use a static setup, swap eth0 for enp5s0 everywhere.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum