Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
help installing pantheon-shell (elementary-os shell)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
samuaz
n00b
n00b


Joined: 06 May 2013
Posts: 27

PostPosted: Thu May 09, 2013 5:32 am    Post subject: help installing pantheon-shell (elementary-os shell) Reply with quote

hi people im new in gentoo i moving from archlinux

i know here is a overlay/ebuild for install the pantheon shell in gentoo, but because im so new on gentoo im very confused and the wiki are out of date and its for people with experience with gentoo

wiki link http://wiki.gentoo.org/wiki/Pantheon
github of elementary for gentoo https://github.com/pimvullers/elementary

at this moment i have gentoo installed but without desktop environment, i want to install the pantheon-shell

so anyone have pantheon shell installed and can make a quick guide for noobs :twisted:

the process its like this:

emerge layman

layman -s

layman -a elementary

but after that im confused about the keywords, mask, unmask, the ~amd64 and also i want to know if need to have installed gnome 3/shell befor install the pantheon shell?

thanks


Last edited by samuaz on Thu May 09, 2013 10:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
jeracho
n00b
n00b


Joined: 09 May 2013
Posts: 16
Location: Virginia

PostPosted: Thu May 09, 2013 1:31 pm    Post subject: Reply with quote

I know it seems intimidating, but all these files are really quite simple to understand. Also, you must be running amd64 to use Pantheon.

First, run the layman command layman -a elementary as the guide says. I am assuming you understand how to use layman.

/etc/portage/profile/package.accept_keywords is a file used to unmask what are considered unstable packages by the devs. After you run layman -a elementary, you must put all the listed packages in the Pantheon guide in package.accept_keywords with ~amd64 after each atom.

For example, I am running the 3.9.0 kernel so in my package.accept_keywords I have "=sys-kernel/gentoo-sources-3.9.0 ~amd64" without the quotes.

/etc/portage/package.use is a file where you can specify individual USE flags you want (or don't want) a package to have. If you understand USE flags and atoms, this should make sense.

For example, if you wanted wine to be emerged without CUPS support you would add to your package.use file "=app-emulation/wine-1.4.1 -cups" without the quotes.

Knowing this, the rest of the guide should speak for itself.


Last edited by jeracho on Thu May 09, 2013 10:00 pm; edited 2 times in total
Back to top
View user's profile Send private message
samuaz
n00b
n00b


Joined: 06 May 2013
Posts: 27

PostPosted: Thu May 09, 2013 9:47 pm    Post subject: Re: help installing pantheon-shell (elementary-os shell) Reply with quote

thanks im trying right now i hope it works
Back to top
View user's profile Send private message
jeracho
n00b
n00b


Joined: 09 May 2013
Posts: 16
Location: Virginia

PostPosted: Thu May 09, 2013 9:59 pm    Post subject: Reply with quote

Me too. :) Good luck.
Back to top
View user's profile Send private message
samuaz
n00b
n00b


Joined: 06 May 2013
Posts: 27

PostPosted: Thu May 09, 2013 10:30 pm    Post subject: Reply with quote

hi i have a problem xD

conflicts in some libs

terminal out:

http://pastebin.com/YmvXJZLu

and this its my package keywords:

http://pastebin.com/KZv1rghm

my package mask:

http://pastebin.com/acmhAiMT

my package unmask:

http://pastebin.com/u55v4ZFY

my package use
http://pastebin.com/zqZd2KQJ

my make.conf
http://pastebin.com/cUL8fNeP
Back to top
View user's profile Send private message
jeracho
n00b
n00b


Joined: 09 May 2013
Posts: 16
Location: Virginia

PostPosted: Fri May 10, 2013 2:39 pm    Post subject: Reply with quote

Based on the conflicting packages and how unstable Pantheon Shell and the packages you need to pull in are, I would give up for now. I don't think it is such a good idea to try any further than you have. It isn't worth compromising your whole system for something that probably isn't even going to work halfway right anyway.
Back to top
View user's profile Send private message
samuaz
n00b
n00b


Joined: 06 May 2013
Posts: 27

PostPosted: Sat May 11, 2013 3:28 am    Post subject: Reply with quote

hi i manage to resolve the conflicts now im building the pantheon-shell i have a compilation error with the footnote im trying to fix it.

yes i know pantheon shell its under develop and are "unstable" but i try it with the luna beta 2 and its stable for my never crash but i dont like ubuntu, so im trying to get it with gentoo, this its linux :P.

my default distro its arch so im using gentoo for try things like this and learn things before to make it my default distro
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum