Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] How to activate mouse?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
melon1234
n00b
n00b


Joined: 07 May 2013
Posts: 6

PostPosted: Tue May 07, 2013 11:55 am    Post subject: [SOLVED] How to activate mouse? Reply with quote

Hi, all,

I installed gentoo as guest system in virtualbox, it works fine except mouse. "mice" & "mouse0" are in /dev/input, but when I "cat" them while move my mouse, no data output. If I start from install-*-minimal.iso, the mouse will be detected and the driver will be loaded correctly. I think there might be a command to activate mouse. The mouse setting in my kernel option seems correct: CONFIG_INPUT_MOUSEDEV=y, CONFIG_MOUSE_PS2*=y. What should I do now?

p.s. FYI, Xorg.0.log says:
(II) evdev: ImExPS/2 Generic Explorer Mouse: initialized for relative axes.
(**) ImExPS/2 ...
(II) config/udev: Adding input device ImExPS/2... (/dev/input/mouse0)
(II) No input driver specified, ignoring this device. // How to specify mouse driver?
(II) This device may have been added with another device file.
(II) evdev: ImExPS/2 ... : Close

Thank you in advance.

--
ShenLei


Last edited by melon1234 on Wed May 08, 2013 11:43 am; edited 1 time in total
Back to top
View user's profile Send private message
PabloEsc
n00b
n00b


Joined: 24 Dec 2009
Posts: 39

PostPosted: Tue May 07, 2013 12:06 pm    Post subject: Reply with quote

You need to emerge xorg-drivers with evdev flag enabled.
Back to top
View user's profile Send private message
melon1234
n00b
n00b


Joined: 07 May 2013
Posts: 6

PostPosted: Tue May 07, 2013 12:55 pm    Post subject: Reply with quote

PabloEsc wrote:
You need to emerge xorg-drivers with evdev flag enabled.


Would you please tell me the exact form of these commands? I have done:

Code:
echo "x11-base/xorg-server udev" >> /etc/portage/package.use
and
Code:
echo 'INPUT_DEVICE="evdev"' >> /etc/make.conf
--
ShenLei
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7395
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue May 07, 2013 1:12 pm    Post subject: Reply with quote

Typo. Should be INPUT_DEVICES, not INPUT_DEVICE. :wink:

Then, just
Code:
emerge -1v xorg-drivers

- John

P.S.: Code tags appreciated for readability.
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
melon1234
n00b
n00b


Joined: 07 May 2013
Posts: 6

PostPosted: Wed May 08, 2013 5:21 am    Post subject: Reply with quote

John R. Graham wrote:
Typo. Should be INPUT_DEVICES, not INPUT_DEVICE. :wink:

Then, just
Code:
emerge -1v xorg-drivers

- John

P.S.: Code tags appreciated for readability.


Thank you very much! It works. Now I have a fully functional Xorg.

--
ShenLei
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum