Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] use flags don't work - removal of policykit
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fidel
Guru
Guru


Joined: 16 Jul 2004
Posts: 391
Location: CH

PostPosted: Tue May 07, 2013 7:38 am    Post subject: [SOLVED] use flags don't work - removal of policykit Reply with quote

I was running a xfce Desktop without polkit, consolekit, upower, udisks and was happy. Now I wanted to update the machine and all of a sudden my use flags get ignored. I cannot understand, how I could fix this. Fact is, I don't need nor want any of those *kit packages.

When I run emerge -uDN world I get the following error:
Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-auth/pambase:0

  (sys-auth/pambase-20101024-r2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-auth/pambase-20101024-r2::gentoo, ebuild scheduled for merge) pulled in by
    sys-auth/pambase[consolekit] required by (sys-auth/polkit-0.110::gentoo, ebuild scheduled for merge)


It seems that gconf and xfce4-session depend on policykit:
Code:

$ equery d sys-auth/polkit
 * These packages depend on sys-auth/polkit:
gnome-base/gconf-2.32.4 (policykit ? sys-auth/polkit)
xfce-base/xfce4-session-4.10.0 (policykit ? >=sys-auth/polkit-0.104-r1)


But I disabled the policykit use flag:
Code:

$ euse -i policykit
global use flags (searching: policykit)
************************************************************
[- cD   ] policykit - Enable PolicyKit authentication support

local use flags (searching: policykit)
************************************************************
[- cD   ] policykit
    app-emulation/virt-manager: Enables sys-auth/polkit authentication
    support, required when using app-emulation/libvirt with PolicyKit
    authentication
        [-  ] 0.9.4 [gentoo]
        [-  ] 9999 [gentoo]

[- cD   ] policykit
    net-misc/spice-gtk: Enable sys-auth/polkit support for the usbredir
    acl helper
        [-  ] 0.14 [gentoo]
        [-  ] 0.14-r2 [gentoo]
        [-  ] 0.15.3 [gentoo]
        [-  ] 0.16 [gentoo]
        [-  ] 0.18 [gentoo]

[- cD   ] policykit
    sys-auth/consolekit: Use the PolicyKit framework (sys-auth/polkit) to
    get authorization for suspend/shutdown.
        [-  ] 0.4.5_p20120320-r1 [gentoo]
        [-  ] 0.4.5_p20120320-r2 [gentoo]


Why is this not working as expected? What am I doing wrong?


Last edited by fidel on Wed May 08, 2013 8:48 am; edited 1 time in total
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1580
Location: U.S.A.

PostPosted: Wed May 08, 2013 12:57 am    Post subject: Reply with quote

I can't replicate this. When I pretend to emerge those packages, policykit is not being forced upon me.

What is the output of
Code:
emerge -p gconf xfce4-session


What happens after you run another emerge --sync and try it?
_________________
"When you're told what to think you want to hear, it's easier to pretend it couldn't happen." -- pjp
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2971
Location: UK

PostPosted: Wed May 08, 2013 1:58 am    Post subject: Reply with quote

This is probably caused by using the wrong profile.
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1580
Location: U.S.A.

PostPosted: Wed May 08, 2013 2:09 am    Post subject: Reply with quote

Hmmm... I wonder if he's using this profile:

profiles/targets/desktop/kde/

which seems to contain

use.force:policykit
_________________
"When you're told what to think you want to hear, it's easier to pretend it couldn't happen." -- pjp
Back to top
View user's profile Send private message
fidel
Guru
Guru


Joined: 16 Jul 2004
Posts: 391
Location: CH

PostPosted: Wed May 08, 2013 8:48 am    Post subject: Reply with quote

I am using the default desktop profile. But now I found it - the problem probably was that I got other error messages concerning other packages that caused errors (chromium-binary-plugins). I then removed those other packages emerge was complaining about, now it is clear, why polkit gets pulled in:

Code:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
#required by sys-auth/polkit-0.110, required by sys-power/upower-0.9.20-r2, required by xfce-extra/xfce4-weather-plugin-0.8.3[udev], required by @selected, required by @world (argument)
=sys-auth/consolekit-0.4.5_p20120320-r1 policykit
#required by sys-auth/polkit-0.110[pam], required by sys-power/upower-0.9.20-r2, required by xfce-extra/xfce4-weather-plugin-0.8.3[udev], required by @selected, required by @world (argument)
=sys-auth/pambase-20101024-r2 consolekit
#required by dev-libs/icu-51.1[doc], required by media-libs/harfbuzz-0.9.12, required by www-client/chromium-26.0.1410.43, required by @selected, required by @world (argument)
=app-doc/doxygen-1.7.6.1 dot


Its the udev use flag of the weather-plugin.

Thank you!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum