Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] nm-applet wireless signal icon is now no-entry icon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sirlark
Guru
Guru


Joined: 25 Oct 2004
Posts: 304
Location: Cape Town, South Africa

PostPosted: Sat May 04, 2013 3:31 pm    Post subject: [SOLVED] nm-applet wireless signal icon is now no-entry icon Reply with quote

I just updated with emerge -uNDav @world, compiled a new kernel, and after the reboot, my network-manager wireless icon in my system tray (nm-applet) changes from the stack of signal bars to a no entry icon. Everything else is still functioning. Any idea how I can change the icon back?

I use XFCE (but i've checked in Enlightenment too, and the problem exists there too)...

Thanks
_________________
Adopt an unanswered post today


Last edited by sirlark on Sun May 05, 2013 8:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
kurly
Apprentice
Apprentice


Joined: 02 Apr 2012
Posts: 204

PostPosted: Sat May 04, 2013 9:27 pm    Post subject: Reply with quote

The problem is that there are literally thousands of "bad" PNG files in Gentoo, including the one you found inside Network Manager. You can either downgrade to a less stringent libpng, or you can wait for those PNGs to get fixed. Personally, I temporarily masked libpng-1.6.2 on my machines. This may or may not be appropriate for your situation.

You didn't specify, so I had to assume that you are running ~arch. If you are not, I rescind my offer of advice in this circumstance. :wink:
Back to top
View user's profile Send private message
sirlark
Guru
Guru


Joined: 25 Oct 2004
Posts: 304
Location: Cape Town, South Africa

PostPosted: Sun May 05, 2013 10:52 am    Post subject: Reply with quote

Yup, running ~arch... and libpng makes perfect sense... Recompiling after masking libpng myself. Just curious though, what makes a .png file 'bad'
_________________
Adopt an unanswered post today
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Sun May 05, 2013 12:23 pm    Post subject: Reply with quote

I've uploaded the fixed signal icons for nm-applet-0.9.6.4 and nm-applet-0.9.8.0. And because the fix is also in upstream git, it'll be in next release too.
Back to top
View user's profile Send private message
kurly
Apprentice
Apprentice


Joined: 02 Apr 2012
Posts: 204

PostPosted: Sun May 05, 2013 5:47 pm    Post subject: Reply with quote

ssuominen wrote:
I've uploaded the fixed signal icons for nm-applet-0.9.6.4 and nm-applet-0.9.8.0. And because the fix is also in upstream git, it'll be in next release too.
Oh good, thank you. So is now a good time to remove the temp mask on my system or should I wait for a new version to hit the tree?
Back to top
View user's profile Send private message
sirlark
Guru
Guru


Joined: 25 Oct 2004
Posts: 304
Location: Cape Town, South Africa

PostPosted: Sun May 05, 2013 8:49 pm    Post subject: Reply with quote

Okay, it was definitely libpng that was causing the problem. Thanks @ssuominen, I'll clear the mask out and update in a few days.
_________________
Adopt an unanswered post today
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum