Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge not setting build arch -Interix-
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
AKF_SDS
n00b
n00b


Joined: 03 Apr 2013
Posts: 22

PostPosted: Wed May 01, 2013 4:22 pm    Post subject: emerge not setting build arch -Interix- Reply with quote

when attempting to run emerge --color n sys-devel/gcc I get the following error:

* ARCH is not set... Are you missing the '/opt/gentoo/etc/make.profile'
* symlink? Is the symlink correct? Is your portage tree complete?


At the link location make.defaults:5 reads as follows
Code:
ARCH="x86-interix"


I rsync'd over a hard copy of the symlink location to test if it was indeed not accessing the link properly. Unfortunately this did not resolve the issue and I received the same error.

running emerge with ARCH="x86-interix" listed in the command produces the following error:

!!! 'ARCH=x86-interix' is not a valid package atom.
!!! Please check ebuild(5) for full details.

The man suggests that a definative list of acceptable arch's can be found at /usr/portage/profiles/arch.list
wherein x86-interix is listed.

Has anyone seen this bug before? How do I get make.profile to properly link? Why is the ARCH not being properly identified?
Back to top
View user's profile Send private message
slis
n00b
n00b


Joined: 11 Oct 2010
Posts: 57
Location: Limanowa

PostPosted: Tue May 07, 2013 6:09 am    Post subject: Reply with quote

How are you setting this variable?
Please attach your full command line.
It should look like this:
Code:

ARCH="x86-interix" emerge package...


The `ARCH' part have to be *before* the emerge, not after.
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 2160
Location: The Peanut Gallery

PostPosted: Tue May 07, 2013 7:48 am    Post subject: Reply with quote

What slis said, wrt the command. You need to sort your profile out, evidently, but I don't know enough about Prefix. My advice would be to use IRC: chat.freenode.net and /join #gentoo-prefix to get support from others using it and the developers, in real-time.

edit: missed 'said'


Last edited by steveL on Wed May 08, 2013 5:44 am; edited 1 time in total
Back to top
View user's profile Send private message
AKF_SDS
n00b
n00b


Joined: 03 Apr 2013
Posts: 22

PostPosted: Tue May 07, 2013 9:47 pm    Post subject: Reply with quote

@slis leading with ARCH="x86-interix" worked. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum