Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] New no gui problem
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Tue Apr 30, 2013 3:01 pm    Post subject: [SOLVED] New no gui problem Reply with quote

I have recently been out of touch due to health issues, but that is now in the past.

A few months ago, my hard drive died. It is not recoverable. My new HD is a WD 250 gb and I did manage to install Gentoo with kernel 3.7.10. But I don't understand why I am unable to find things in the same place as they were on my older system. For example: /etc/make.conf does not exist. There is a make.conf in /etc/portage, however. I have attempted to reinstall Gentoo by deleting the partitions and going through the entire process, but no luck. Do I need to format the drive and then try again? Currently the system boots up with the splash screen where I can choose the version to load (side note: I cannot use the rescue version), but all I get is a command line allowing me to login as root. Just cannot get a gui to load. Obviously I've done something wrong, but I don't have a clue how to fix it. I am posting from my Macbook since I can't use links on my pc unless I boot with the livecd, so it is difficult to post the output of any code messages. I have to re-key everything.

I am lost and confused after looking for problems similar to mine. Any suggestions? :(
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams


Last edited by mark2 on Fri May 03, 2013 11:40 am; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7398
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Apr 30, 2013 5:38 pm    Post subject: Re: New no gui problem Reply with quote

mark2 wrote:
But I don't understand why I am unable to find things in the same place as they were on my older system. For example: /etc/make.conf does not exist. There is a make.conf in /etc/portage, however.
Gentoo evolves. The decision's been made to keep all Portage-related files in /etc/portage, whereas historically some were in /etc. The Gentoo Handbook has been updated so that people following it expect the files in their new locations. The old location still works, though. Just don't have the file both places as unexpected things occur.

Regarding the lack of GUI, recall that that's what you get with a pure Handbook install. You have to follow other guides to get a GUI and desktop environment. Have you worked throughBefore we know where you're stuck, we can't really help.

mark2 wrote:
I am posting from my Macbook since I can't use links on my pc unless I boot with the livecd, so it is difficult to post the output of any code messages. I have to re-key everything.
Just emerge wgetpaste and use it to post error message to a URL. For example, if someone asked you for your "emerge --info", all you would need to do is
Code:
emerge --info | wgetpaste
This will return a short, easy to transcribe by hand URL to you that contains the output of emerge. :wink:

- John

P.S.: Regarding the Douglas Adams quote, are you a pilot?
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Tue Apr 30, 2013 8:32 pm    Post subject: Reply with quote

Hi John, good to see you. I remember that you have helped me before.

I was unaware of the changes to the handbook, so I will print out another copy to work from. I do have the Xserver Howto Configuration and the Gentoo Linux Nvidia Guide and I think I have the KDE guide as well. I have not worked through the Xserver guide, but I will just to see if I can find where I went wrong. I will post back when I have something. Sorry for the delay in replying; I had a physical therapy session that I had to go to.

Added: I have tried to emerge wgetpaste and some other things, but I am getting this

Code:
 "/etc/portage/make.conf", line 18: Invalid token 'SYNC' (not '=')


I think I may have to go back to the beginning and start over. :)

Regarding my quote in the signature: no, I am not a pilot, but I am a fan of Douglas Adams' writings.

Thanks,
Mark
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams


Last edited by mark2 on Tue Apr 30, 2013 8:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Tue Apr 30, 2013 8:39 pm    Post subject: Reply with quote

mark2,

Welcome back.

One thing that s not changed is that Gentoo still gives you two things :-
The packages you ask for
The packages you need to support the packages you asked for.

The converse is still true, if you haven't asked for it yet, you don't have it
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7398
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Apr 30, 2013 8:49 pm    Post subject: Reply with quote

mark2 wrote:
...but I am a fan of Douglas Adams' writings.
Me, too, but I also routinely, "...throw myself at the ground and miss." :D

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Tue Apr 30, 2013 8:58 pm    Post subject: Reply with quote

Edited: see above.
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7398
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Apr 30, 2013 9:02 pm    Post subject: Reply with quote

mark2 wrote:
Added: I have tried to emerge wgetpaste and some other things, but I am getting this

Code:
 "/etc/portage/make.conf", line 18: Invalid token 'SYNC' (not '=')


I think I may have to go back to the beginning and start over. :)
Don't do that yet. Laboriously hand transcribe line 18 of /etc/portage/make.conf and post it here, please.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Tue Apr 30, 2013 9:23 pm    Post subject: Reply with quote

Line 18 was put in by Portage. It goes like this:
Code:
 SYNC="rsync://rsync3.us.gentoo.org/gentoo-portage"


If I comment it out and try to emerge, I get a similar message about Line 19 which is blank - there is nothing after Line 18. Weird...
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7398
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed May 01, 2013 12:28 pm    Post subject: Reply with quote

Alas that doesn't tell us enough; we're going to need to see the whole make.conf file to find out what's going on. Here's what you can do:
  • If you haven't already done so, download and burn one of the comprehensive LiveCDs that contain a graphical environment. SystemRescueCD recommended.
  • Boot that and get into the GUI.
  • Open a terminal window and mount your root partition onto /mnt/gentoo, just like you did during the install.
  • Edit the /mnt/gentoo/etc/portage/make.conf with one of the supplied editors and copy / paste it into a forum message using one of the supplied web browsers. (SystemRescueCD also includes wgetpaste, if you want to take that route.)
  • Bask in the warm glow of additional forum support. ;)
- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Wed May 01, 2013 4:22 pm    Post subject: Reply with quote

Well, I had anticipated that it would not be enough so I hand copied the remainder of the make.conf. I did mean to post it early this morning, but I ran out of time and had to leave before I had a chance. So here is the whole make.conf leaving out the default comments before modification:
Code:

# Comments...
CFLAGS="-march=athlon64 -02 -pipe"
CXXFLAGS=${CFLAGS}"
# Comments...
CHOST="X86_64-pc-linux-gnu"
# Comments... the following USE are all on one line
USE="bindist mmx sse sse2 qt4 kde dvd alsa cdr cairo exif ffmpeg ftp gimp gtk java javascript lame mad minizip mozilla mp3 mp4 mplayer ogg opengl plasma jpeg scanner truetype tiff x264 xine xinerama x11-libs/libdrm-2.4.40 libkms media-libs/mesa/9.0.1 xa -cups consolekit dbus policykit udev"
MAKEOPTS="-j2"
VIDEO_CARDS="nvidia"
INPUT_DEVICES="evdev"
VIDEO=uvesafb :mtrr:3,ywrap,1680x1050-32@59
blank line...
SYNC="rsync://rsync3.us.gentoo.org/gentoo-portage
blank line...


The blank lines are 17 and 19 before and after the SYNC line. Hope this provides additional insight. :)

~Mark
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Wed May 01, 2013 5:43 pm    Post subject: Reply with quote

mark2,

Code:
CXXFLAGS=${CFLAGS}"
is incorrectly quoted. It needs either no quotes or a pair - I'm not sure which.
Comment out
Code:
VIDEO=uvesafb :mtrr:3,ywrap,1680x1050-32@59
That looks like it belongs in grub.conf, not make.conf.

Code:
SYNC="rsync://rsync3.us.gentoo.org/gentoo-portage
as you have written it, is missing a closing quote. That may just be your post
Code:
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
is the North American sync rotation. IF you comment out the SYNC= line, its the default provided by your profile.

That you get errors at the end of the file points towards missing or extra ",
They will cause portage to parse the file incorrectly.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sno35
Guru
Guru


Joined: 15 May 2004
Posts: 332
Location: Paris, France

PostPosted: Wed May 01, 2013 5:50 pm    Post subject: Reply with quote

Hi
Why can not we see the double quote at the end of the SYNC line ?

[EDIT] Oops, sorry too late.
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Wed May 01, 2013 6:39 pm    Post subject: Reply with quote

Ah, embarassment time. :oops: The missing quotes are due to my incorrectly typing the hand transcription. The actual make.conf does contain the quotes in the correct place. I even copied it correctly on paper, but messed up in typing it in my reply. Sorry.

I did comment out the VIDEO line and the SYNC line and that restored the ability to emerge without any errors. I also went back and uncommented the SYNC line and tested emerge once more. Success, again! So it was the VIDEO line, apparently because it contained no quotes. I did reboot but still no gui. There is more work to be done, I'm sure, with configuring the Xserver. In reading the HOWTO document, I saw where it said to take out all the legacy framebuffer drivers in order to use Kernel modesetting, but I don't remember going through that on my previous system. So I'm now wondering where to go next. More reading is necessary.

Thanks, Neddy.

[Edit] Have gone into the Gentoo Nvidia guide and the Xserver HOWTO guide and checked the kernel configuration. When I run modprobe nvidia, I get an error: FATAL - module nvidia not found. Stuck again.

~Mark
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Wed May 01, 2013 8:53 pm    Post subject: Reply with quote

mark2,

I was expecting a few transcription errors in your make.conf. Its inevitable.

That means that the nvidia kernel module is not installed, or its installed for a kernel other than the one you are running.

When the nvidia kernel module is built, it finds the kernel to build against by following the /usr/src/linux symbolic link.
This link need not point to the kernel you are actually running. Its useful during a kernel update for example to build for the new kernel.
emerge -1 nvidia-drivers
Run the command
Code:
uname -r
this tells the running kernel.
Run the command
Code:
readlink /usr/src/linux
this tells where the symlink points.

If the versions are not the same, use the
Code:
eselect kernel
command to rewrite the symlink to point to your running kernel then run
Code:
emerge -1 nvidia-drivers
This will build nvida-drivers against your running kernel but not add it to your world file.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Wed May 01, 2013 9:27 pm    Post subject: Reply with quote

Neddy,

Code:

uname -r
3.7.10-gentoo

And
Code:

readlink /usr/src/linux
linux-3.7.10-gentoo

Code:

eselect kernel list
linux-3.7.10-gentoo *

It was the only one selected. Then running
Code:

emerge -l nvidia-drivers

produced a lot of screens that went by too fast to pick up on any warnings. I rebooted and tried startx after logging as root, but it could not connect to xserver. Also modprobe nvidia produced the same error: FATAL: module nvidia not found.

~Mark
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Wed May 01, 2013 9:35 pm    Post subject: Reply with quote

mark2,

Use wgetpaste to post your Xorg log file
Code:
emerge wgetpaste
if its not installed already.
Code:
wgetpaste /var/log/Xorg.0.log
wgetpaste will return a URL to your log on the web.
Just post the URL.

You should not run Xorg as root.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7398
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed May 01, 2013 9:49 pm    Post subject: Reply with quote

Just a couple of low priority additions to what Neddy said:
  • mark2 wrote:
    I rebooted...
    You shouldn't have to unless you've made a necessary change to your kernel. Rebooting is one of those bad habits you got into with that other operating system that starts with W.
  • mark2 wrote:
    ...produced a lot of screens that went by too fast to pick up on any warnings.
    Go ahead & enable portage logging by adding this line to your /etc/portage/make.conf:
    Code:
    PORT_LOGDIR="/var/log/portage"
    Then all those fast-scrolling messages will be preserved and you can wgetpaste them easily if necessarily.
Hope this helps. :wink:

- John
_________________
This space intentionally left blank.


Last edited by John R. Graham on Wed May 01, 2013 9:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Wed May 01, 2013 9:49 pm    Post subject: Reply with quote

Neddy,

It came back:
Code:

/usr/bin/wgetpaste: /var/log/Xorg.0.log No such file found


~Mark
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Wed May 01, 2013 10:24 pm    Post subject: Reply with quote

mark2,

I half expected that. It means that the X server has never been run.

Did you install the X server test packages?
Code:
emerge -1 twm xterm xclock
if not do that now.

Log in as your normal user, not root. Make a normal user if you haven't already.
Run
Code:
startx

If it works, you will get three xterms and an analogue clock.
If not, tell us what happens and post your /var/log/Xorg.0.log so we can see what Xorg actually did.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Wed May 01, 2013 10:26 pm    Post subject: Reply with quote

John,

I set the PORT_DIR as you directed, but it doesn't look as if running the emerge for nvidia-drivers put the log in that directory. Instead, I looked around and did an ls on the root directory and found 3 log files in /root/var/log/portage, 2 of which I did get a return from wgetpaste that seem pertinent:
Code:

http://bpaste.net/show/95747
and
Code:
http://bpaste.net/show/95748


~Mark
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Wed May 01, 2013 10:32 pm    Post subject: Reply with quote

mark2,

Read the log you posted at http://bpaste.net/show/95747/ and follow the advice it provides.

Your video card is not supported by the nvidia driver you have installed, so it won't work.
Do what it says in the log then run
Code:
emerge -1 nvidia-drivers
again.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Wed May 01, 2013 11:07 pm    Post subject: Reply with quote

Neddy,

Followed the instructions in the log file and verified that package.mask did contain that line. I did the emerge -l nvidia-drivers. Then I went back and installed the X server test packages again and ran startx. I still do not get a /var/log/Xorg.0.log file. It does not exist.

Startx returned:
Code:

xauth: file /home/.serverauth.18728 does not exist
/etc/X11/xinit/xserverrc: line2: /usr/bin/X: No such file or directory


~Mark
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7398
Location: Somewhere over Atlanta, Georgia

PostPosted: Thu May 02, 2013 1:13 pm    Post subject: Reply with quote

mark2 wrote:
I set the PORT_DIR as you directed, but it doesn't look as if running the emerge for nvidia-drivers put the log in that directory. ...
Is that a typo? My note said "PORT_LOGDIR". Could you wgetpaste your make.conf, now you've got it working?

For the current problem, looks like xorg-server may not have emerged completely successfully. Let's get logging working before you proceed, though, so you can wgetpaste logs.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
mark2
Apprentice
Apprentice


Joined: 22 May 2012
Posts: 188
Location: South Carolina

PostPosted: Thu May 02, 2013 1:41 pm    Post subject: Reply with quote

John,

Yes, you're right, it was a typo on my part; the make.conf has the entry that you mentioned. Wgetpaste has a copy of my make.conf at http://bpaste.net/show/95853 .

Also, I have created a normal user and am logged in as that instead of root (just thought I'd mention that).

Regards,
~Mark
_________________
"Flying is learning how to throw yourself at the ground and miss." - Douglas Adams


Last edited by mark2 on Thu May 02, 2013 1:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7398
Location: Somewhere over Atlanta, Georgia

PostPosted: Thu May 02, 2013 1:51 pm    Post subject: Reply with quote

Okay, there's a typo in your make.conf. The line
Code:
PORT_LOGDIR="var/log/portage"
should instead read
Code:
PORT_LOGDIR="/var/log/portage"
See the missing forward slash at the beginning of the string? This also explains why your logs ended up in a strange place. There are also some strange non-USE-flag values in your USE variable but we can safely deal with that later.

Could you (a) fix the make.conf typo and then (b) run
Code:
emerge --oneshot --verbose xorg-server
Please tell us if it runs to completion without any errors. If not, locate the log of the failed package in /var/log/portage and wgetpaste that.

Making progress. :)

- John

Edit: Substituted long form options to reduce confusion over letter-number similarity.
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum