Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] KDE 4.10: User-Mounten klappt nicht mehr
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
sprittwicht
Guru
Guru


Joined: 04 Dec 2003
Posts: 594

PostPosted: Sun Apr 28, 2013 2:49 pm    Post subject: [gelöst] KDE 4.10: User-Mounten klappt nicht mehr Reply with quote

Habe gerade festgestellt dass auf einem meiner KDE-Rechner (x86) das Mounten von USB-Sticks über das "Geräteüberwachung" (??) - Symbol nicht mehr klappt. Beim Versuch kommt die Meldung "Folgendes Gerät kann nicht eingebunden werden: ...".
Mounte ich manuell per udisks --mount /dev/sdb1 wird das Gerät eingehängt, fordert aber zum Umounten über das KDE-Icon root-Rechte. Was ist diesmal kaputt?

Was mir noch aufgefallen ist: Der Stick wird ganz normal unter /media/ eingehängt, auf meinem anderen Rechner (x86_64, auf dem das Mounten auch unter KDE noch funktioniert) landen die Geräte aber plötzlich unter /run/media/. Wurde da irgendwas umgestellt und auf meinem x86-Rechner hab ich mir irgendein Update zerschossen?


Last edited by sprittwicht on Sat May 04, 2013 6:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3839
Location: Irgendwo im Nirgendwo

PostPosted: Sun Apr 28, 2013 2:56 pm    Post subject: Reply with quote

/media war udisks1, /run/media ist udisks2 - was eigentlich von kde-4.10 verwendet werden sollte. Vielleicht läufst du in irgend einen Konflikt mit udisks1?
Vielleicht reicht es ja, udidks:0 zu entfernen (vllt. kdelibs danach neu bauen).
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2186
Location: Germany

PostPosted: Sun Apr 28, 2013 5:02 pm    Post subject: Reply with quote

Jo, beachte auch das /usr/bin/udisks aus sys-fs/udisks-1 stammt
Im kde wird aber ab 4.10 sys-fs/udisks-2 verwendet, das dann /usr/bin/udisksctl bereit stellt.

Normal funktioniert das ganze aber auch problemlos wenn beide sloted udisks Versionen gleichzeitig installiert sind (hier tut es das auf einem x86 System)
Teste das ganze doch noch mal mit einem jugfräulichen Testuser, und auch mal mit einem anderen USB-Stick
Back to top
View user's profile Send private message
sprittwicht
Guru
Guru


Joined: 04 Dec 2003
Posts: 594

PostPosted: Sun Apr 28, 2013 6:29 pm    Post subject: Reply with quote

Ah, danke für die Erklärungen!
Kann das leider erst nächstes Wochenende testen, aber jetzt steh ich schonmal nicht mehr ganz so doof wie der Ochs vorm Berg.
Mit nem anderen Stick war genau das gleiche...

Was mir noch einfällt: Nach irgendeinem emerge gab es eine Warnung über einen User ohne Login-Shell (ivman). Der stammt glaub ich noch von irgendeinem HAL-Geraffel von anno dazumal, kann es sein dass da noch irgendwas rumhängt was da nicht mehr hingehört?
Back to top
View user's profile Send private message
sprittwicht
Guru
Guru


Joined: 04 Dec 2003
Posts: 594

PostPosted: Sat May 04, 2013 6:40 pm    Post subject: Reply with quote

Gentoo-Bibelstunde, erstes Gebot:
"Du sollst emerge-Ausgaben, die auf eine Fehlkonfiguration hinweisen, nicht nur auf deine TODO-Liste kopieren, sondern selbige irgendwann auch mal abarbeiten."

Habe versucht manuell per udisksctl aus udisks-2 zu mounten und bekam auf der Konsole eine Fehlermeldung (die ich mir eigentlich auch in KDE wünschen würde!), irgendwas mit ACL-Blabla-Operation-not-permitted.
Gucke auf meinen Desktop, steht da im Notizzettel: "CONFIG_TMPFS_POSIX_ACL: is not set when it should be."
Das hatte mir sys-fs/udisks-2 wohl damals vor den Latz geknallt, ich formschöner Prachtmensch hab mich aber nicht dran gehalten.
Option eingebaut -> Läuft.

Danke nochmal, ohne euren Hinweis auf udisks-1 vs. udisks-2 würde ich heute noch ratlos und gleichgültig auf meine TODO-Liste starren und alles manuell mounten... :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum