Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wont Fix - Don't want framebuffer during boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
FastTurtle
Guru
Guru


Joined: 03 Sep 2002
Posts: 386
Location: Shake & Bake

PostPosted: Thu Apr 25, 2013 4:15 pm    Post subject: Wont Fix - Don't want framebuffer during boot Reply with quote

I want a straight console while booting (nofb mode) then the switch to X once kdm is up.

Is this doable or am I barking at the wrong squirrel?

Problem was minor and related to kernel config for some reason. Now during boot, the switch to fbcon takes but a moment and the buffer shows a few lines before the switch so any error messages that come up are now shown - was a problem with the virtualbox video driver not starting/loading for some reason


Last edited by FastTurtle on Wed May 15, 2013 3:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3601
Location: USA

PostPosted: Thu Apr 25, 2013 5:58 pm    Post subject: Re: Don't want framebuffer during boot Reply with quote

Depends on the driver/board, some X11 drivers (like Intel) seems to require KMS and thus a type of FBcon well before X11 starts... This isn't quite the true "fbcon" but close enough...

The question remains is ... what do you want to accomplish with it, what's wrong with fbcon, why is regular text mode needed, all the way until kdm presents a login prompt? Is it doing something bad? That would more likely be a driver issue. What hardware are you using?

If it's a scrolling speed issue, that's a separate problem...

Most of my fbcon/kms machines work just fine, and not only that, switch to X11 graphical drawing without flickering from text mode...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
FastTurtle
Guru
Guru


Joined: 03 Sep 2002
Posts: 386
Location: Shake & Bake

PostPosted: Sat Apr 27, 2013 3:03 pm    Post subject: Reply with quote

during the boot, I'm seeing indications of some error just before the system switches to the fb, which takes 2-5 seconds - long enough that by the time it's back, the fb is at the log-in prompt.

What I'd like to do is either delay the fb from starting or entirely.

I'm currently using grub, so a nofb option like the install kernel would work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum