Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] why "fc-match Times" match Times to DejaVu Serif
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Kiwon Um
n00b
n00b


Joined: 15 Jul 2009
Posts: 49

PostPosted: Thu Apr 25, 2013 7:04 am    Post subject: [SOLVED] why "fc-match Times" match Times to DejaV Reply with quote

Hi,

I realized that my system does incorrectly match Times fonts:
Quote:
# fc-match Times
DejaVuSerif.ttf: "DejaVu Serif" "Book"

I have Times fonts certainly:
Quote:
# fc-list Times
Times:style=Bold Italic
Times:style=Bold
Times:style=Italic
Times:style=Regular

My fontconfig is as follows:
Quote:
#eselect fontconfig list | grep "*"
Available fontconfig .conf files (* is enabled):
[1] 09-texlive.conf *
[5] 10-sub-pixel-rgb.conf *
[9] 20-fix-globaladvance.conf *
[10] 20-fix-globaladvance-nanumgothiccoding.conf *
[11] 20-unhint-small-dejavu-sans.conf *
[12] 20-unhint-small-dejavu-sans-mono.conf *
[13] 20-unhint-small-dejavu-serif.conf *
[14] 20-unhint-small-vera.conf *
[26] 42-luxi-mono.conf *
[29] 49-sansserif.conf *
[30] 50-user.conf *
[31] 51-local.conf *
[32] 52-infinality.conf *
[33] 57-dejavu-sans.conf *
[34] 57-dejavu-sans-mono.conf *
[35] 57-dejavu-serif.conf *
[36] 59-google-droid-sans.conf *
[37] 59-google-droid-sans-mono.conf *
[38] 59-google-droid-serif.conf *
[46] 65-fonts-persian.conf *
[69] 69-unifont.conf *
[73] 80-delicious.conf *
[74] 80-ttf-nanum.conf *
[75] 90-synthetic.conf *

I didn't configure the Times fonts in my local conf. (~/.fonts.conf)

Does anybody have the same problem or catch the clue for this?


Last edited by Kiwon Um on Fri Apr 26, 2013 1:29 am; edited 1 time in total
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu Apr 25, 2013 11:13 am    Post subject: Reply with quote

What's in your 57-dejavu-serif.conf then?

Check what's in your fontconfig rules, in /etc/fonts/conf.d/
_________________
Improve your font rendering and ALSA sound
Back to top
View user's profile Send private message
Kiwon Um
n00b
n00b


Joined: 15 Jul 2009
Posts: 49

PostPosted: Thu Apr 25, 2013 11:28 am    Post subject: Reply with quote

Nothing special in 57-dejavu-serif.conf:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
<!-- /etc/fonts/conf.d/57-dejavu-serif.conf

     Define aliasing and other fontconfig settings for
     DejaVu Serif.

     © 2006-2008 Nicolas Mailhot <nicolas.mailhot at laposte.net>
-->
<fontconfig>
  <!-- Font substitution rules -->
  <alias binding="same">
    <family>Bitstream Prima Serif</family>
    <accept>
      <family>DejaVu Serif</family>
    </accept>
  </alias>
  <alias binding="same">
    <family>Bitstream Vera Serif</family>
    <accept>
      <family>DejaVu Serif</family>
    </accept>
  </alias>
  <alias binding="same">
    <family>DejaVu LGC Serif</family>
    <accept>
      <family>DejaVu Serif</family>
    </accept>
  </alias>
  <alias binding="same">
    <family>Hunky Serif</family>
    <accept>
      <family>DejaVu Serif</family>
    </accept>
  </alias>
  <alias binding="same">
    <family>Olwen Serif</family>
    <accept>
      <family>DejaVu Serif</family>
    </accept>
  </alias>
  <alias binding="same">
    <family>SUSE Serif</family>
    <accept>
      <family>DejaVu Serif</family>
    </accept>
  </alias>
  <!-- In case Verajja Serif stops declaring itself as DejaVu Serif -->
  <alias binding="same">
    <family>Verajja Serif</family>
    <accept>
      <family>DejaVu Serif</family>
    </accept>
  </alias>
  <!-- Generic name assignment -->
  <alias>
    <family>DejaVu Serif</family>
    <default>
      <family>serif</family>
    </default>
  </alias>
  <!-- Generic name aliasing -->
  <alias>
    <family>serif</family>
    <prefer>
      <family>DejaVu Serif</family>
    </prefer>
  </alias>
</fontconfig>

I didn't modify it. I tested with something disabled fontconfig as well:
Quote:
#eselect fontconfig list | grep "*"
Available fontconfig .conf files (* is enabled):
[1] 09-texlive.conf *
[5] 10-sub-pixel-rgb.conf *
[9] 20-fix-globaladvance.conf *
[10] 20-fix-globaladvance-nanumgothiccoding.conf *
[14] 20-unhint-small-vera.conf *
[26] 42-luxi-mono.conf *
[29] 49-sansserif.conf *
[30] 50-user.conf *
[31] 51-local.conf *
[32] 52-infinality.conf *
[46] 65-fonts-persian.conf *
[69] 69-unifont.conf *
[73] 80-delicious.conf *
[74] 80-ttf-nanum.conf *
[75] 90-synthetic.conf *

In these fontconfig files, there was no Times related configuration. 8O
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu Apr 25, 2013 12:00 pm    Post subject: Reply with quote

Not sure what the best command to use is, but check debugging - e.g.:
Code:
$ FC_DEBUG=1024 fc-match "Times"
FC_DEBUG=1024
   Loading config file /etc/fonts/fonts.conf
   Scanning config dir /etc/fonts/conf.d
   Loading config file /etc/fonts/conf.d/09-texlive-fonts.conf
   Loading config file /etc/fonts/conf.d/20-unhint-small-vera.conf
   Loading config file /etc/fonts/conf.d/30-metric-aliases.conf
   Loading config file /etc/fonts/conf.d/30-urw-aliases.conf
   Loading config file /etc/fonts/conf.d/40-nonlatin.conf
   Loading config file /etc/fonts/conf.d/42-luxi-mono.conf
   Loading config file /etc/fonts/conf.d/45-latin.conf
   Loading config file /etc/fonts/conf.d/49-sansserif.conf
   Loading config file /etc/fonts/conf.d/50-user.conf
   Loading config file /etc/fonts/conf.d/51-local.conf
   Loading config file /etc/fonts/local.conf
   Loading config file /etc/fonts/conf.d/60-latin.conf
   Loading config file /etc/fonts/conf.d/65-fonts-persian.conf
   Loading config file /etc/fonts/conf.d/65-nonlatin.conf
   Loading config file /etc/fonts/conf.d/69-unifont.conf
   Loading config file /etc/fonts/conf.d/80-delicious.conf
   Loading config file /etc/fonts/conf.d/90-synthetic.conf
Times Roman.pfb: "Times" "Roman"


I'm using fontconfig git, which is why I get the filename printed at the end, slightly different to your output.
Back to top
View user's profile Send private message
Kiwon Um
n00b
n00b


Joined: 15 Jul 2009
Posts: 49

PostPosted: Thu Apr 25, 2013 12:19 pm    Post subject: Reply with quote

OMG, there is such a great variable FC_DEBUG! :D

Finally, I found the clue, 52-infinality.conf
If I disable it, fc-match shows correct result. I need to investigate more about infinality.

Thank you very much! :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum