Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] nfs won't mount on boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
quasar
n00b
n00b


Joined: 11 Mar 2006
Posts: 31

PostPosted: Sat Apr 27, 2013 3:31 pm    Post subject: [Solved] nfs won't mount on boot Reply with quote

My /etc/fstab contains the following line:
Code:

192.168.1.138:/home/quasar/video /mnt/video  nfs        defaults        0 0


netmount is in runlevel default but when I boot this nfs mount is not mounted. Calling 'mount -a' will mount this nfs mount with out problems. It is unclear to me why /mnt/video isn't being mounted at boot


Last edited by quasar on Sun Apr 28, 2013 12:28 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42841
Location: 56N 3W

PostPosted: Sat Apr 27, 2013 7:29 pm    Post subject: Reply with quote

quasar,

Add bg to your mount options, so if things are not ready yet, the mount attempts continue in the background.
Read man mount
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
quasar
n00b
n00b


Joined: 11 Mar 2006
Posts: 31

PostPosted: Sun Apr 28, 2013 12:28 am    Post subject: Reply with quote

Adding bg to the options may have worked after a minute but I didn't want to wait a minute to find out. The real problem was that net.eth0 was not in any runlevel. Adding it to default fixed the problem. It is unclear to me how I was getting any networking without net.eth0 in a runlevel but it works now.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42841
Location: 56N 3W

PostPosted: Sun Apr 28, 2013 10:40 am    Post subject: Reply with quote

quasar,

I expect the nfs startup script needs/depends on net, so when nfs tries to start, it starts eth0 but by the time eth0 is up, nfs has given up waiting.
eth0 contines to come up and its waiting for you when you do the mount manually.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum