Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Problem with emerge blocking
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
hypeboyz
n00b
n00b


Joined: 26 Feb 2012
Posts: 24

PostPosted: Mon Apr 15, 2013 9:53 am    Post subject: [Solved]Problem with emerge blocking Reply with quote

My system was a little bit old which was installed last year without any updates. And currently I wanna update all packages and bring up a gui. But when I emerge --update world, I was told that sys-apps/man-pages and sys-libs/glibc is blocking the libiconv. Since I don't know any portage mechanics I unmerged libiconv and it is removed from my computer. But when I emerge --update again the blocking message still pop up. So what shall I do? Thanks beforehand.
The message goes like following
Code:

Calculating dependencies... done!
[ebuild   N      ] dev-libs/libiconv-1.14
[ebuild B        ] sys-apps/man-pages ("sys-apps/man-pages" is blocking dev-libs/libiconv-1.14)
[ebuild B        ] sys-libs/glibc ("sys-libs/glibc" is blocking dev-libs/libiconv-1.14)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system

 (dev-libs/libiconv-1.14::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libiconv required by @system

 (sys-apps/man-pages-3.47::gentoo, installed) pulled in by
    sys-apps/man-pages-3.47 required by @selected

 (sys-libs/glibc-2.13-r4::gentoo, installed) pulled in by
    sys-libs/glibc-2.13-r4 required by @selected
    >=sys-libs/glibc-2.7 required by (sys-libs/pam-1.1.5::gentoo, installed)
    sys-libs/glibc:2.2 required by (virtual/libc-0::gentoo, installed)

[/code]


Last edited by hypeboyz on Thu Apr 25, 2013 6:06 am; edited 1 time in total
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 5804

PostPosted: Mon Apr 15, 2013 10:51 am    Post subject: Re: Problem with emerge blocking Reply with quote

hypeboyz wrote:
But when I emerge --update again the blocking message still pop up. So what shall I do?

Because your glibc is just too old, it block that update.

It's easy to kept an old gentoo running, but it's than harder to update it.
If you think you can handle to update it, first step would stop asking portage to do everything for you, it just can't.

Reducing the causes of blocking will higher your chance of success. So first step is emerge -u system (yes no deep or anything, and yes certainly not world !)
If this fail you will have to go with even smaller steps (updating only the toolchain, portage... needed tools).

So it's not hard, but if your knowledge is limited to emerge world, it will take you times, but you will learn.
If you don't wish that, you better download a livecd and install a fresher system.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Mon Apr 15, 2013 12:19 pm    Post subject: Reply with quote

This looks like a bit more than a case of an old system - glibc setup shouldn't pull libiconv.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 5804

PostPosted: Mon Apr 15, 2013 12:32 pm    Post subject: Reply with quote

the virtual/glibc need a glibc-2.2, pam need glibc-2.7...
Maybe not libiconv, but the too old glibc will stuck him until fix (so toolchain need to be fix before going futher).
Back to top
View user's profile Send private message
imaginasys
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2009
Posts: 83
Location: Québec

PostPosted: Mon Apr 15, 2013 12:45 pm    Post subject: Reply with quote

the dev-libs/libiconv has the following depends:

Quote:
DEPEND="!sys-libs/glibc
!sys-apps/man-pages"



I don't really see why you would need dev-libs/libiconv ?
On my system I only have a virtual/libiconv and no dev-libs/libiconv.

So may be you should start by finding who is pulling dev-libs/libiconv.
Show output of : " equery d dev-libs/libiconv"

(nb you need app-portage/portage-utils for equery).

Regards,
BT :mrgreen:
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3211
Location: Germany

PostPosted: Mon Apr 15, 2013 1:25 pm    Post subject: Reply with quote

hypeboyz wrote:
emerge --update world

This is not a good idea without --deep and --newuse on old System,
better use
Code:
emerge --update --deep --newuse @world

or shortly
Code:
emerge -avuDN @world
Back to top
View user's profile Send private message
hypeboyz
n00b
n00b


Joined: 26 Feb 2012
Posts: 24

PostPosted: Thu Apr 25, 2013 6:05 am    Post subject: Reply with quote

Well Thanks for you all guys. The problem was caused by the eselect profile that was set to something like hardened linux. I don't know why cuz I didn't even see this option when I installed system. By the way can anyone explain what's the propose of these hardened linux profile? Thanks once more for your answers!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum