Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Perl packages skipped (solved?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Bigun
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 2073

PostPosted: Wed Aug 10, 2016 11:11 am    Post subject: Perl packages skipped (solved?) Reply with quote

Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-lang/perl:0

  (dev-lang/perl-5.22.1:0/5.22::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl:0/5.20= required by (dev-python/subunit-1.2.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.20* required by (virtual/perl-Test-Harness-3.330.0:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.20* required by (virtual/perl-MIME-Base64-3.140.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.20* required by (virtual/perl-Digest-SHA-5.880.0:0/0::gentoo, installed)
    ^              ^^^^^
    =dev-lang/perl-5.20* required by (virtual/perl-Digest-MD5-2.530.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.20=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.30.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-vcs/git-2.7.3-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.20=[-build(-)] required by (perl-core/libnet-1.270.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/Error-0.170.240:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.20= required by (dev-perl/Net-SSLeay-1.720.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.20= required by (net-fs/samba-4.2.11:0/0::gentoo, installed)
                 ^^^^^^^^
    =dev-lang/perl-5.20* required by (virtual/perl-Scalar-List-Utils-1.380.0:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.20=[-build(-)] required by (perl-core/Data-Dumper-2.154.0:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/IO-Socket-SSL-2.24.0:0/0::gentoo, installed)
                 ^^^^^^^^

_________________
"It's ok, they might have guns but we have flowers." - Perpetual Victim


Last edited by Bigun on Wed Aug 10, 2016 2:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
Bigun
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 2073

PostPosted: Wed Aug 10, 2016 11:46 am    Post subject: Reply with quote

I may have figured it out, I found this rogue line in my package.accept_keywords file:

Code:
=dev-lang/perl-5.22.1 ~x86


I've commented it out and now I have no need of emerging this package.
_________________
"It's ok, they might have guns but we have flowers." - Perpetual Victim
Back to top
View user's profile Send private message
krenshala
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jan 2006
Posts: 85
Location: Austin TX, NorAm, Sol III

PostPosted: Mon Oct 17, 2016 8:32 pm    Post subject: Reply with quote

I'm running into the same problem, but do not have perl listed in any of the package.* files.

I found what (so far) appears to be a helpful thread, however: https://forums.gentoo.org/viewtopic-t-1010432-postdays-0-postorder-asc-start-0.html

Based on that, I ran

Code:
perl-cleaner --all


And once that was completed ran

Code:
emerge --update --newuse --deep --with-bdeps=y @world -p


I'm currently waiting on the above (without the -p) to complete (62 packages to (re)merge) to see if that fixed things for me or not.

edit: Yup, the above appears to have fixed the perl 5.20 blocking 5.22 problem for me.
_________________
krenshala
:wq
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum