Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VirtualBox gentoo,安装xorg,X -configure 失败
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese)
View previous topic :: View next topic  
Author Message
limanxian
n00b
n00b


Joined: 01 Nov 2012
Posts: 1

PostPosted: Thu Nov 01, 2012 5:28 am    Post subject: VirtualBox gentoo,安装xorg,X -configure 失败 Reply with quote

我的机器是联想Y480n,Xorg.0.log内容为:
[ 1017.289]
X.Org X Server 1.12.2
Release Date: 2012-05-29
[ 1017.295] X Protocol Version 11, Revision 0
[ 1017.297] Build Operating System: Linux 3.5.7-gentoo x86_64 Gentoo
[ 1017.300] Current Operating System: Linux localhost 3.5.7-gentoo #1 SMP Wed Oct 31 00:41:39 CST 2012 x86_64
[ 1017.300] Kernel command line: root=/dev/sda3
[ 1017.302] Build Date: 01 November 2012 12:22:21PM
[ 1017.303]
[ 1017.304] Current version of pixman: 0.26.0
[ 1017.307] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 1017.307] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 1017.317] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 1 12:26:41 2012
[ 1017.317] (II) Loader magic: 0x7d6ae0
[ 1017.317] (II) Module ABI versions:
[ 1017.317] X.Org ANSI C Emulation: 0.4
[ 1017.317] X.Org Video Driver: 12.0
[ 1017.317] X.Org XInput driver : 16.0
[ 1017.317] X.Org Server Extension : 6.0
[ 1017.320] (--) PCI:*(0:0:2:0) 80ee:beef:0000:0000 rev 0, Mem @ 0xe0000000/67108864
[ 1017.322] List of video drivers:
[ 1017.324] intel
[ 1017.325] vboxvideo
[ 1017.326] vesa
[ 1017.326] (II) LoadModule: "intel"
[ 1017.326] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[ 1017.326] (EE) Failed to load /usr/lib64/xorg/modules/drivers/intel_drv.so: libdrm_intel.so.1: cannot open shared object file: No such file or directory
[ 1017.326] (II) UnloadModule: "intel"
[ 1017.326] (II) Unloading intel
[ 1017.326] (EE) Failed to load module "intel" (loader failed, 7)
[ 1017.326] (II) LoadModule: "vboxvideo"
[ 1017.326] (II) Loading /usr/lib64/xorg/modules/drivers/vboxvideo_drv.so
[ 1017.327] (II) Module vboxvideo: vendor="Oracle Corporation"
[ 1017.327] compiled for 1.5.99.901, module version = 1.0.1
[ 1017.327] Module class: X.Org Video Driver
[ 1017.327] ABI class: X.Org Video Driver, version 12.0
[ 1017.327] (**) Load address of symbol "VBOXVIDEO" is 0x7fc6d0a1c400
[ 1017.327] (II) LoadModule: "vesa"
[ 1017.327] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 1017.327] (II) Module vesa: vendor="X.Org Foundation"
[ 1017.327] compiled for 1.12.2, module version = 2.3.1
[ 1017.327] Module class: X.Org Video Driver
[ 1017.327] ABI class: X.Org Video Driver, version 12.0
[ 1017.327] (II) VBoxVideo: guest driver for VirtualBox: vbox
[ 1017.327] (II) VESA: driver for VESA chipsets: vesa
[ 1017.341] (++) Using config file: "/root/xorg.conf.new"
[ 1017.342] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 1017.342] (==) ServerLayout "X.org Configured"
[ 1017.342] (**) |-->Screen "Screen0" (0)
[ 1017.342] (**) | |-->Monitor "Monitor0"
[ 1017.342] (**) | |-->Device "Card0"
[ 1017.342] (**) |-->Screen "Screen1" (1)
[ 1017.342] (**) | |-->Monitor "Monitor1"
[ 1017.342] (**) | |-->Device "Card1"
[ 1017.342] (**) |-->Input Device "Mouse0"
[ 1017.342] (**) |-->Input Device "Keyboard0"
[ 1017.342] (==) Automatically adding devices
[ 1017.342] (==) Automatically enabling devices
[ 1017.342] (**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/,
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/
[ 1017.342] (**) ModulePath set to "/usr/lib64/xorg/modules"
[ 1017.342] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 1017.342] (WW) Disabling Mouse0
[ 1017.342] (WW) Disabling Keyboard0
[ 1017.342] (WW) Falling back to old probe method for vesa
[ 1017.344] Number of created screens does not match number of detected devices.
Configuration failed.


希望大牛们帮我看看是什么问题。
Back to top
View user's profile Send private message
prettya1
n00b
n00b


Joined: 17 Mar 2013
Posts: 3

PostPosted: Sun Mar 24, 2013 1:51 am    Post subject: Reply with quote

EE) Failed to load /usr/lib64/xorg/modules/drivers/intel_drv.so: libdrm_intel.so.1: cannot open shared object file: No such file or directory

提示要加载 /usr/lib64/xorg/modules/drivers/intel_drv.so文件,但这个文件要依赖 libdrm_intel.so.1谁的。

libdrm_intel.so.1文件没有在系统中找到,可能的原因大概有两种:
1. 包含此文件的软件包未安装
可用emerge -S libdrm_intel.so.1等,或google查查到这个文件是在哪个软件包中。

2. 软件包已经安装,需要设置 LD_LIBRARY_PATH 变量
将此文件放入到类似下面目录下。再执行下ldconfig
LD_LIBRARY_PATH='/lib:/data/local/lib:/usr/local/lib'
Back to top
View user's profile Send private message
beizhuchun
n00b
n00b


Joined: 11 Apr 2013
Posts: 21

PostPosted: Tue Apr 16, 2013 3:28 am    Post subject: Re: VirtualBox gentoo,安装xorg,X -configure 失败 Reply with quote

limanxian wrote:
我的机器是联想Y480n,Xorg.0.log内容为:
[ 1017.289]
[ 1017.322] List of video drivers:
[ 1017.324] intel
[ 1017.325] vboxvideo
[ 1017.326] vesa
[ 1017.326] (II) LoadModule: "intel"
[ 1017.326] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[ 1017.326] (EE) Failed to load /usr/lib64/xorg/modules/drivers/intel_drv.so: libdrm_intel.so.1: cannot open shared object file: No such file or directory
[ 1017.326] (II) UnloadModule: "intel"
[ 1017.326] (II) Unloading intel
[ 1017.326] (EE) Failed to load module "intel" (loader failed, 7)
[ 1017.326] (II) LoadModule: "vboxvideo"[ 1017.326] (II) Loading /usr/lib64/xorg/modules/drivers/vboxvideo_drv.so
[ 1017.327] (II) Module vboxvideo: vendor="Oracle Corporation"
[ 1017.327] compiled for 1.5.99.901, module version = 1.0.1
[ 1017.327] Module class: X.Org Video Driver
[ 1017.327] ABI class: X.Org Video Driver, version 12.0
[ 1017.327] (**) Load address of symbol "VBOXVIDEO" is 0x7fc6d0a1c400
[ 1017.327] (II) LoadModule: "vesa"[ 1017.327] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 1017.327] (II) Module vesa: vendor="X.Org Foundation"
[ 1017.327] compiled for 1.12.2, module version = 2.3.1
[ 1017.327] Module class: X.Org Video Driver
[ 1017.327] ABI class: X.Org Video Driver, version 12.0
[ 1017.327] (II) VBoxVideo: guest driver for VirtualBox: vbox
[ 1017.327] (II) VESA: driver for VESA chipsets: vesa
[ 1017.341] (++) Using config file: "/root/xorg.conf.new"
[ 1017.342] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 1017.342] (==) ServerLayout "X.org Configured"
[ 1017.342] (**) |-->Screen "Screen0" (0)
[ 1017.342] (**) | |-->Monitor "Monitor0"
[ 1017.342] (**) | |-->Device "Card0"
[ 1017.342] (**) |-->Screen "Screen1" (1)
[ 1017.342] (**) | |-->Monitor "Monitor1"
[ 1017.342] (**) | |-->Device "Card1"
[ 1017.342] (**) |-->Input Device "Mouse0"
[ 1017.342] (WW) Falling back to old probe method for vesa
[ 1017.344] Number of created screens does not match number of detected devices.
Configuration failed.

希望大牛们帮我看看是什么问题。

你安装了3个显卡驱动,成功加载2个。xorg.conf使用系统默认,设置两个显卡分别输出到不同屏幕,但实际你只有一个显示器,所以配置失败。
虚拟机不用装两个显卡驱动吧。
在/etc/portage/make.conf

INPUT_DEVICES="evdev"
VIDEO_CARDS="virtualbox"
emerge --update --deep --newuse world
安装virtualbox-guest-additons 以支持鼠标,
emerge virtualbox-guest-additions
rc-update add virtualbox-guest-additions default
/etc/init.d/virtualbox-guest-additions start
移除无用的xorg.conf
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
把自己加入vboxguest组
gpasswd -a <user> vboxguest
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum