Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Windows in The GIMP behaving badly. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Sat Apr 13, 2013 11:55 pm    Post subject: Windows in The GIMP behaving badly. [SOLVED] Reply with quote

I've just started using The GIMP in my new Gentoo/LXDE installation, and in spite of my admiration for the program generally, it now has a most annoying new "feature". I use the standard GIMP layout - Tool Panel on the left, Layer Panel on the right, working windows in the middle.

The problem is this: the Tool and Layer panels are locked onto the top layer, and working windows "slide beneath" them. I've tried using the Window menu to lower them in the stack, the Preferences dialogue which has no such setting, and the Window menu of working windows to raise them to the top, all to no avail. There is no sensible reason that I can see for the utility windows always to be on top, and this "feature" is a confounded nuisance.

This is probably a GIMP-specific issue, although it could be due to an interaction of some sort between it and LXDE; but I thought I'd raise the issue here first before heading to other venues. In early versions of The GIMP, its windows behaved normally; then a version or few ago, the Tool and Layer windows removed themselves from the <Alt-Tab> switching cycle, an inconvenience I learned to live with since I didn't use it much. I'm now faced with several months intensive use and want to fix it.

Has anyone else had a similar problem; and, more importantly, found a way to fix it?


Last edited by 52midnight on Sun Apr 14, 2013 10:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Sun Apr 14, 2013 2:41 am    Post subject: Reply with quote

What does xprop report on these windows?

I don't have a clue where to start to assist you, so defining the problem seems like a good place.

One of the options in xprop is window state... I don't know if it will tell you anything or not, but if it's locked on top, there may be something that jumps out at you.
_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1639

PostPosted: Sun Apr 14, 2013 2:55 am    Post subject: Reply with quote

I don't know how to directly fix the problem, but:

You can enable single window mode (Windows -> Single Window Mode)

You can also toggle the tool windows by just pressing Tab
_________________
“And even in authoritarian countries, information networks are helping people discover new facts and making governments more accountable.”– Hillary Clinton, Jan. 21, 2010
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Sun Apr 14, 2013 3:23 am    Post subject: Reply with quote

> What does xprop report on these windows?

Good suggestion! Knew there was something like this I needed to do ... X properties, coming back ... There's heap of it, so I've posted it here:

http://52midnight.com/gimp.html

Nothing obvious at first glance. Here's something interesting, tho'. Windows from other apps slide over the top of GIMP windows as normal; the layering appears to be specific to GIMP.

Still looking ...

> You can enable single window mode (Windows -> Single Window Mode) You can also toggle the tool windows by just pressing Tab

Interesting workaround, but I still want the thing fixed proper-like ...
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Sun Apr 14, 2013 3:30 am    Post subject: Reply with quote

... and when I activate a GIMP working window behind a window from another app, it doesn't 'raise' - i.e. it remains 'behind' the inactive app window.

Also, If you open a file in a new window, the new window is NOT raised; if it's small, it remains 'behind' the active window, and therefore invisible. Someone in the GIMP team has been playing sillyb***ers with layering, pretty obviously.
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Sun Apr 14, 2013 4:06 am    Post subject: Reply with quote

Might be on the track of it. The following from /etc/gimp/2.0/gimprc suggests that the problem CAN be fixed, though I've had no luck yet:
Code:

# The window type hint that is set on the toolbox. This may affect how your
# window manager decorates and handles the toolbox window.  Possible values
# are normal, utility and keep-above.
#
# (toolbox-window-hint utility)

# The window type hint that is set on dock windows. This may affect the way
# your window manager decorates and handles dock windows.  Possible values
# are normal, utility and keep-above.
#
# (dock-window-hint utility)

# When enabled, dock windows (the toolbox and palettes) are set to be
# transient to the active image window. Most window managers will keep the
# dock windows above the image window then, but it may also have other
# effects.  Possible values are yes and no.
#
# (transient-docks no)


I'm experimenting with putting these params in ~/.gimp-2.6/gimprc with various values ...
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Sun Apr 14, 2013 4:35 am    Post subject: Reply with quote

I tried using 'normal' and 'utility' modes for 'toolbox-window-hint' and 'dock-window-hint' without any change or success, so I switched to twm and the windows behaved normally.

At this stage it looks like either LXDE (Openbox) isn't interpreting the window hints correctly, or the GIMP isn't parsing them correctly.

Might try the Openbox forum if there is one ... almost certainly not a Gentoo problem.


Last edited by 52midnight on Sun Apr 14, 2013 7:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Sun Apr 14, 2013 5:36 pm    Post subject: Reply with quote

This was a good start.

Now, the other piece of information that is needed is the xprops for a window that behaves normally.

That way, we can see what working options are as opposed to those in question.

Does that make sense?
_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Sun Apr 14, 2013 7:31 pm    Post subject: Reply with quote

Commendably methodical, and thanks for your ongoing interest. I've updated the link with xprops from the GIMP working window and an Nedit window that behaves normally for comparison:

http://52midnight.com/gimp.html

I joined the Openbox mailing list and have this so far:

"I'm running gimp 2.8 and it does the same thing. I assumed this was gimp
trying to be clever rather than anything openbox was doing. Does it behave
differently with other window managers?"

I've replied and referred him to this thread. Might try looking for the "hints list" that Openbox follows if there is such a thing.
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Sun Apr 14, 2013 8:45 pm    Post subject: Reply with quote

What I see when I look at that output is that the windows that are misbehaving are set to
Code:
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_UTILITY

while the windows that are behaving are set to
Code:
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_NORMAL


I didn't see that your NEdit window had that notation, howver I did notice that openbox did register the types in all 4 windows.

Misbehaving
Code:
_OB_APP_TYPE(UTF8_STRING) = "utility"


Working
Code:
_OB_APP_TYPE(UTF8_STRING) = "normal"


Now, I'm taking it that the _OB notation refers to openbox, so odds are it's something with openbox. That's just my opinion, and I could be wrong, but that's where I'ld start.

It's been a number of years since I've used openbox, so unfortunately I can't be of much help there.

Anyway, good luck in tracking this down.
_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Sun Apr 14, 2013 8:52 pm    Post subject: Reply with quote

Many thanks, Knute. I hadn't noticed that. Yes, I think it's an Ob/Gimp issue, so I'll pass along your comments and come back here when I've resolved it.
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2179
Location: Netherlands

PostPosted: Sun Apr 14, 2013 9:10 pm    Post subject: Reply with quote

I'm using KDE.
I had the same problem with Gimp-2.7.x
Now I'm running 2.8.4.
If my memory serves me right I solved it in the following way:
Start Gimp,uncheck single window mode.
Make sure your toolbox is visible,if it's not the check your panel.
If you see it then close Gimp.
Restart Gimp,the center or drawing window will be small.
Move and drag it to fill the space between the toolbox and the layers windows.
Now check single window mode and close Gimp.
When you close Gimp it will save the last setup.
When you restart Gimp it should behave and the toolbox should remain visible.
Mind you I did this quite a while ago and my memory is not the best.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has midori to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Sun Apr 14, 2013 10:11 pm    Post subject: Reply with quote

Solved it - learned something.

I'd never come across a "single window mode" switch, but when I went looking, I found the following in Edit > Preferences > Window Management:

Window Manager Hints:
Hint for the toolbox:
Hint for other docks:

Setting both to 'Normal' fixed things. Thanks to all who contributed. Will check options more thoroughly next time.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum