Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] atheros ar9485 wireless network
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
umka69
n00b
n00b


Joined: 31 Mar 2013
Posts: 61

PostPosted: Sat Apr 13, 2013 8:38 pm    Post subject: [SOLVED] atheros ar9485 wireless network Reply with quote

Hi, guys!
I have atheros ar9485 wireless adapter and i can't get wireless connection.
Kernel version is 3.7.10-gentoo.
The adapter is plant on wlp3s0 interface.
I already tried wpa_supplicant and wireless-tools but I didn't get any seccess.
Is it kernel problem? How to solve it?
Code:
Den ~ # cat /usr/src/linux/.config | grep ATH9K
CONFIG_ATH9K_HW=m
CONFIG_ATH9K_COMMON=m
CONFIG_ATH9K_BTCOEX_SUPPORT=y
CONFIG_ATH9K=m
CONFIG_ATH9K_PCI=y
CONFIG_ATH9K_AHB=y
CONFIG_ATH9K_DEBUGFS=y
CONFIG_ATH9K_MAC_DEBUG=y
CONFIG_ATH9K_RATE_CONTROL=y

Code:
Den ~ # lsmod
Module                  Size  Used by
ath9k                 146160  0
ath9k_common            1881  1 ath9k
ath9k_hw              392440  2 ath9k_common,ath9k
ath                    15479  3 ath9k_common,ath9k,ath9k_hw

Code:
Den ~ # ifconfig wlp3s0
wlp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 9c:b7:0d:41:63:b1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Code:
Den ~ # iwconfig
wlp3s0    no wireless extensions.
lo        no wireless extensions.
enp4s0    no wireless extensions.
sit0      no wireless extensions.


Last edited by umka69 on Tue Apr 16, 2013 8:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6251
Location: Goose Creek SC

PostPosted: Sun Apr 14, 2013 4:35 pm    Post subject: Reply with quote

boot minimal install cd or sysresccd, mount gentoo partitions,
Code:
 wgetpaste /mnt/gentoo/etc/conf.d/net
wgetpaste /mnt/gentoo/usr/src/linux/.config
ls -l /mnt/gentoo/etc/init.d/net* | wgetpaste
wgetpaste /mnt/gentoo/etc/wpa_supplicant/wpa_supplicant.conf
wgetpaste /mnt/gentoo/etc/rc.conf

_________________
Defund the FCC.


Last edited by DONAHUE on Tue Apr 16, 2013 5:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
umka69
n00b
n00b


Joined: 31 Mar 2013
Posts: 61

PostPosted: Mon Apr 15, 2013 8:30 pm    Post subject: Reply with quote

DONAHUE wrote:
boot minimal install cd or sysresccd, mount gentoo partitions,
Code:
 wgetpaste /mnt/gentoo/etc/conf.d/net
wgetpaste /mnt/gentoo/usr/src/linux/.config
ls -l /etc/init.d/net* | wgetpaste
wgetpaste /mnt/gentoo/etc/wpa_supplicant/wpa_supplicant.conf
wgetpaste /mnt/gentoo/etc/rc.conf


ok... my configs...

Code:
Den ~ # cat /etc/conf.d/net
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc*/net.example* and save your configuration
# in /etc/conf.d/net (this file :]!).
config_enp4s0="dhcp"
modules="wpa_sapplicant"
wpa_supplicant_wlp3s0="-Dwext"


Code:
Den ~ # cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=1

network={
        #auth_alg=OPEN
        #mode=1
        #key_mgmt=WPA-PSK
        ssid="**********"
        psk="***********"
        priority=999
}


Code:
Den ~ # /etc/init.d/net.wlp3s0 start
 * Bringing up interface wlp3s0
 *   Starting wpa_supplicant on wlp3s0 ...
ioctl[SIOCSIWPMKSA]: Invalid argument
ioctl[SIOCSIWMODE]: Invalid argument
ioctl[SIOCGIWRANGE]: Invalid argument
ioctl[SIOCGIWMODE]: Invalid argument
ioctl[SIOCSIWAP]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWPMKSA]: Invalid argument                                              [ ok ]
 *   Starting wpa_cli on wlp3s0 ...                                                [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlp3s0 has started, but is inactive
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Mon Apr 15, 2013 8:33 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-p-7218540.html#7218540
Back to top
View user's profile Send private message
umka69
n00b
n00b


Joined: 31 Mar 2013
Posts: 61

PostPosted: Tue Apr 16, 2013 8:54 am    Post subject: Reply with quote

ok. I enabled wext in the kernel. It seams that we are on the right way. :) Thank you, guys!
But it still doesn't work... a got these outputs:
Code:
Den ~ # iwconfig
wlp3s0    IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
lo        no wireless extensions.
enp4s0    no wireless extensions.
sit0      no wireless extensions.

Code:
Den ~ # ifconfig
...
wlp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 9c:b7:0d:41:63:b1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Code:
Den ~ # /etc/init.d/net.wlp3s0 start
 * Bringing up interface wlp3s0
 *   Starting wpa_supplicant on wlp3s0 ...                                       [ ok ]
 *   Starting wpa_cli on wlp3s0 ...                                              [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlp3s0 has started, but is inactive

I tried to ping but there was no result.
if it is impotent i emerged rfkill and tried it.
Code:
Den ~ # cat /usr/src/linux/.config | grep RFKILL
CONFIG_RFKILL=y
CONFIG_RFKILL_LEDS=y
CONFIG_RFKILL_INPUT=y
# CONFIG_AMILO_RFKILL is not set
# CONFIG_TOSHIBA_BT_RFKILL is not set

Code:
Den ~ # rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6251
Location: Goose Creek SC

PostPosted: Tue Apr 16, 2013 6:08 pm    Post subject: Reply with quote

suggest /etc/conf.d/net:
Quote:
config_enp4s0="dhcp"
dhcpcd_enp4s0="-t 10"

modules_wlp3s0="wpa_supplicant"
wpa_supplicant_wlp3s0="-Dwext"
#wpa_supplicant_wlp3s0="-Dnl80211"
wpa_timeout_wlp3s0=15
iwconfig_wlp3s0_mode="Managed"
config_wlp3s0="dhcp"
dhcpcd_wlp3s0="-t 10"


/etc/wpa_supplicant/wpa_supplicant.conf:
Quote:
DIR=/var/run/wpa_supplicant GROUP=wheel
ap_scan=1
update_config=1


then
Code:
 /etc/init.d/net.wlp3s0 restart
then use wpa_gui to configure and save the network(s)
you should have wpa_gui if you have a gui and if wpa_supplicant was emerged with the qt4 USE flag
_________________
Defund the FCC.
Back to top
View user's profile Send private message
umka69
n00b
n00b


Joined: 31 Mar 2013
Posts: 61

PostPosted: Tue Apr 16, 2013 8:51 pm    Post subject: Reply with quote

I make these configs. It works! :D
Thank you your help guys!))
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum