Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Everything in English, keyboard layout in Polish
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kbzium
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2012
Posts: 146

PostPosted: Sat Apr 13, 2013 11:00 am    Post subject: Everything in English, keyboard layout in Polish Reply with quote

Hello!

How to set my keyboard layout to Polish keeping system language as English?

Code:
LANG=en_US.UTF-8                                                                                                                                 
LC_CTYPE="en_US.UTF-8"                                                                                                                           
LC_NUMERIC="en_US.UTF-8"                                                                                                                         
LC_TIME="en_US.UTF-8"                                                                                                                           
LC_COLLATE=C                                                                                                                                     
LC_MONETARY="en_US.UTF-8"                                                                                                                       
LC_MESSAGES="en_US.UTF-8"                                                                                                                       
LC_PAPER="en_US.UTF-8"                                                                                                                           
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
kboom-wst init.d # locale-gen
 * Generating 4 locales (this might take a while) with 1 jobs
 *  (1/4) Generating en_US.ISO-8859-1 ... [ ok ]
 *  (2/4) Generating en_US.UTF-8 ... [ ok ]
 *  (3/4) Generating pl_PL.ISO-8859-2 ... [ ok ]
 *  (4/4) Generating pl_PL.UTF-8 ... [ ok ]
 * Generation complete


xorg.conf
Code:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "evdev"
        Option  "XkbRules" "xorg"
        Option  "XkbLayout" "pl2"
        Option  "XkbModel" "pc105"
EndSection


Help me out please! I've looked for it for an hour without and nothing works as expected.

Thank you!
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4813

PostPosted: Sat Apr 13, 2013 11:17 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-p-6760516.html#6760516
This should solve your issue.
Back to top
View user's profile Send private message
kbzium
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2012
Posts: 146

PostPosted: Sat Apr 13, 2013 2:49 pm    Post subject: Reply with quote

Thank you! It worked like a charm. Sadly there was no info about this in neither guides.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1264

PostPosted: Sat Apr 13, 2013 3:49 pm    Post subject: Reply with quote

Is this valide?
Code:
LANG=en_US.UTF-8

isn't it
Code:
LANG=en_US.utf8

Or does there exist an alias?
I ever was disturbed by this different naming than with the other variables ...
_________________
fun2gen2
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4813

PostPosted: Sat Apr 13, 2013 9:49 pm    Post subject: Reply with quote

ulenrich wrote:
Is this valide?
Code:
LANG=en_US.UTF-8


As per UTF8 guide, it's correct, while your other proposal fail, as you can see there : https://forums.gentoo.org/viewtopic-t-956644-highlight-.html
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5981

PostPosted: Sun Apr 14, 2013 2:58 am    Post subject: Reply with quote

krinn wrote:
ulenrich wrote:
Is this valide?
Code:
LANG=en_US.UTF-8


As per UTF8 guide, it's correct, while your other proposal fail, as you can see there : https://forums.gentoo.org/viewtopic-t-956644-highlight-.html


Not sure about that thread, but in standard setup, '.utf8' and '.UTF-8' suffixes for locale values are equivalent.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum