Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(SOLVED!!)wlan0 not detected
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Wed Apr 10, 2013 4:39 pm    Post subject: (SOLVED!!)wlan0 not detected Reply with quote

Good day all,

I have been battling this problem for the last 24 hours with configuring my wifi. First When I recompiled my kernel my udev/rules.d/70-* was deleted and I had to go to my Live CD to load my firmware and cp the Live CD udev/rules.d/ for my network ethernet to work "again". I have wpa_supplicant installed here is my info:



Code:

Quasar checkmate # ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask 255.255.255.0  broadcast
        inet6 fe80::21d:72ff:feed:5680  prefixlen 64  scopeid 0x20<link>
        ether 00:1d:72:ed:56:80  txqueuelen 1000  (Ethernet)
        RX packets 587  bytes 186520 (182.1 KiB)
        RX errors 0  dropped 1  overruns 0  frame 0
        TX packets 516  bytes 111406 (108.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Quasar checkmate # ifconfig wlan0
wlan0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:21:6b:71:7d:36  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0



Code:

Quasar checkmate # dmesg| grep iwlwifi
[    6.534602] iwlwifi 0000:04:00.0: PCI->APIC IRQ transform: INT A -> IRQ 18
[    6.534627] iwlwifi 0000:04:00.0: pci_resource_len = 0x00002000
[    6.534630] iwlwifi 0000:04:00.0: pci_resource_base = ffffc9000006c000
[    6.534632] iwlwifi 0000:04:00.0: HW Revision ID = 0x0
[    6.534637] iwlwifi 0000:04:00.0: pci_enable_msi failed(0Xffffffff)
[    6.825901] iwlwifi 0000:04:00.0: loaded firmware version 8.83.5.1 build 33692
[    6.895268] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUG enabled
[    6.895271] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[    6.895273] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[    6.895276] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE disabled
[    6.895278] iwlwifi 0000:04:00.0: CONFIG_IWLWIFI_P2P enabled
[    6.895281] iwlwifi 0000:04:00.0: Detected Intel(R) WiFi Link 5100 AGN, REV=0x54
[    6.895314] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[    6.898250] iwlwifi 0000:04:00.0: RF_KILL bit toggled to enable radio.
[    6.916233] iwlwifi 0000:04:00.0: device EEPROM VER=0x11f, CALIB=0x4
[    6.916237] iwlwifi 0000:04:00.0: Device SKU: 0xF0
[    6.916240] iwlwifi 0000:04:00.0: Valid Tx ant: 0x2, Valid Rx ant: 0x3
[  162.160154] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[  162.163296] iwlwifi 0000:04:00.0: Radio type=0x1-0x2-0x0
[  162.359172] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[  162.362132] iwlwifi 0000:04:00.0: Radio type=0x1-0x2-0x0
Quasar checkmate # dmesg | grep wlan0
[  162.494286] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

conf.d/net
Code:


# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /usr/share/doc/openrc*/net.example* and save your configuration
# in /etc/conf.d/net (this file :]!).
config_wlan0="dhcp"
modules_wlan0="wpa_supplicant"
wpa_supplicant_wlan0="-Dwext /etc/wpa_supplicant/wpa_supplicant.conf"



wpa_supplicant.conf
Code:


update_config=1
ctrl_interface=/var/run/wpa_supplicant
ap_scan=1
ctrl_interface_group=0

.config
Code:


CONFIG_IWLWIFI=m
CONFIG_IWLDVM=m

CONFIG_IWLWIFI_DEBUG=y
CONFIG_IWLWIFI_DEBUG_EXPERIMENTAL_UCODE=y
CONFIG_IWLWIFI_DEVICE_TRACING=y
CONFIG_IWLWIFI_P2P=y
# CONFIG_IWLWIFI_EXPERIMENTAL_MFP is not set





I have my wifi drivers as modules and here is my /lib/firmware
Code:

Quasar linux # ls -l /lib/firmware/
-rw-r--r-- 1 root root 345008 Apr 10 05:07 iwlwifi-5000-1.ucode
-rw-r--r-- 1 root root 340688 Apr 10 05:18 iwlwifi-5000-5.ucode


I have ethernet but not wifi not even detected
Code:

 wpa_supplicant -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf -d
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
update_config=1
ctrl_interface='/var/run/wpa_supplicant'
ap_scan=1
ctrl_interface_group='0'
WEXT: cfg80211-based driver detected
ioctl[SIOCSIWPMKSA]: Invalid argument
ioctl[SIOCSIWMODE]: Invalid argument
Could not configure driver to use managed mode
ioctl[SIOCGIWRANGE]: Invalid argument
ioctl[SIOCGIWMODE]: Invalid argument
ioctl[SIOCSIWAP]: Invalid argument
WEXT: Failed to clear to disconnect
netlink: Operstate: linkmode=1, operstate=5
WEXT: SIOCSIWAUTH(param 7 value 0x1) failed: Invalid argument)
Own MAC address: 00:21:6b:71:7d:36
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
wpa_driver_wext_set_countermeasures
WEXT: SIOCSIWAUTH(param 4 value 0x0) failed: Invalid argument)
RSN: flushing PMKID list in the driver
ioctl[SIOCSIWPMKSA]: Invalid argument
State: DISCONNECTED -> INACTIVE
WPS: UUID based on MAC address - hexdump(len=16): 7c 78 99 60 2b 96 57 57 a2 89 83 49 00 48 4c 48
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
ctrl_interface_group=0
Added interface wlan0
EAPOL: disable timer tick
EAPOL: Supplicant port status: Unauthorized


Code:

Quasar linux # /etc/init.d/net.wlan0 restart
 * Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...
ioctl[SIOCSIWPMKSA]: Invalid argument
ioctl[SIOCSIWMODE]: Invalid argument
ioctl[SIOCGIWRANGE]: Invalid argument
ioctl[SIOCGIWMODE]: Invalid argument
ioctl[SIOCSIWAP]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWPMKSA]: Invalid argument                                                                                                                                                                                                    [ ok ]
 *   Starting wpa_cli on wlan0 ...                                                                                                                                                                                                       [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlan0 has started, but is inactive


my hardware
Code:

04:00.0 Network controller: Intel Corporation WiFi Link 5100


thanking in advance.


Last edited by chessmaster on Sat Apr 13, 2013 4:10 am; edited 4 times in total
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Wed Apr 10, 2013 4:56 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-p-7218540.html#7218540
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Wed Apr 10, 2013 7:51 pm    Post subject: Reply with quote

Gusar wrote:
https://forums.gentoo.org/viewtopic-p-7218540.html#7218540

I'll give this a try this is for to cfg80211. This is needed to be compile as a module? If so then I didn't have that. I will repost back.
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Wed Apr 10, 2013 9:13 pm    Post subject: Reply with quote

Code:

Quasar checkmate # /etc/init.d/net.wlan0 restart
 * Bringing down interface wlan0
 *   Removing addresses
 *     Stopping wpa_cli on wlan0 ...                                      [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...                               [ ok ]
 * Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...                                 [ ok ]
 *   Starting wpa_cli on wlan0 ...                                        [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlan0 has started, but is inactive


Code:

Quasar checkmate # iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

sit0      no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off


Code:

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:21:6b:71:7d:36  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


Still no luck
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Wed Apr 10, 2013 10:36 pm    Post subject: Reply with quote

Going to take a break been battling this all day yesterday and try again tomorrow. If anybody had this same problem please help. :oops:
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Wed Apr 10, 2013 11:02 pm    Post subject: Reply with quote

If that's your full wpa_supplicant, of course you won't get a connection. You need a network block containing a ssid and psk (no other settings necessary, wpa_supplicant can figure them out on it's own). The simplest way to create it is using wpa_passphrase
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Thu Apr 11, 2013 4:50 am    Post subject: Reply with quote

Code:

wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf

Just hangs and no response


Code:

wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Could not read SSID from driver.



Code:

Quasar linux # uname -a
Linux Quasar 3.7.10-gentoo #7 SMP Wed Apr 10 17:45:10 EDT 2013 x86_64 Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz GenuineIntel GNU/Linux


conf.d/net
Code:

modules="wpa_supplicant"
config_wlan0="dhcp"
wpa_cli_wlan0="-G3600"
wpa_supplicant_wlan0="-Dwext -c/etc/wpa_supplicant/wpa_supplicant.conf"
wpa_supplicant_wlan0="-Dwext"



Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=0
network={
        ssid="***"
        psk="**********"
        proto=RSN
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        priority=5
}


Code:

wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf




Same thing I'm trying but nothing good is coming from this but just repeated frustration. help!!!!!!! please :( I'm confused where I'm going wrong


Last edited by chessmaster on Thu Apr 11, 2013 2:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
Trovalds
n00b
n00b


Joined: 16 Jun 2011
Posts: 7
Location: Cuiaba/MT - Brazil

PostPosted: Thu Apr 11, 2013 9:13 am    Post subject: Reply with quote

Did you try this? http://wiki.gentoo.org/wiki/Udev/upgrade

I have problems with my box after a update too.
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Thu Apr 11, 2013 2:15 pm    Post subject: Reply with quote

Code:

 wpa_cli status
Selected interface 'wlp4s0'
wpa_state=ASSOCIATING


I have tried -Dwl80211 which could find my SSID
-Dwext found my SSID but goes no farther than trying to associate with my SSID

Code:

# Network testing
#
# CONFIG_NET_PKTGEN is not set
# CONFIG_NET_DROP_MONITOR is not set
# CONFIG_HAMRADIO is not set
# CONFIG_CAN is not set
# CONFIG_IRDA is not set
# CONFIG_BT is not set
# CONFIG_AF_RXRPC is not set
CONFIG_FIB_RULES=y
CONFIG_WIRELESS=y
CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
CONFIG_CFG80211=m
# CONFIG_NL80211_TESTMODE is not set
# CONFIG_CFG80211_DEVELOPER_WARNINGS is not set
# CONFIG_CFG80211_REG_DEBUG is not set
CONFIG_CFG80211_DEFAULT_PS=y
# CONFIG_CFG80211_DEBUGFS is not set
# CONFIG_CFG80211_INTERNAL_REGDB is not set
CONFIG_CFG80211_WEXT=y
CONFIG_LIB80211=m
# CONFIG_LIB80211_DEBUG is not set
CONFIG_MAC80211=m
CONFIG_MAC80211_HAS_RC=y
CONFIG_MAC80211_RC_MINSTREL=y
CONFIG_MAC80211_RC_MINSTREL_HT=y
CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
CONFIG_MAC80211_RC_DEFAULT="minstrel_ht"
# CONFIG_MAC80211_MESH is not set
CONFIG_MAC80211_LEDS=y
# CONFIG_MAC80211_DEBUGFS is not set
# CONFIG_MAC80211_MESSAGE_TRACING is not set
CONFIG_MAC80211_DEBUG_MENU=y
# CONFIG_MAC80211_NOINLINE is not set
# CONFIG_MAC80211_VERBOSE_DEBUG is not set
# CONFIG_MAC80211_MLME_DEBUG is not set
# CONFIG_MAC80211_STA_DEBUG is not set
# CONFIG_MAC80211_HT_DEBUG is not set
# CONFIG_MAC80211_IBSS_DEBUG is not set
# CONFIG_MAC80211_PS_DEBUG is not set
# CONFIG_MAC80211_TDLS_DEBUG is not set
# CONFIG_WIMAX is not set
CONFIG_RFKILL=m
CONFIG_RFKILL_LEDS=y
CONFIG_RFKILL_INPUT=y
# CONFIG_NET_9P is not set
# CONFIG_CAIF is not set
# CONFIG_CEPH_LIB is not set
# CONFIG_NFC is not set
CONFIG_HAVE_BPF_JIT=y
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1539

PostPosted: Thu Apr 11, 2013 2:50 pm    Post subject: Reply with quote

chessmaster wrote:
Code:
wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Could not read SSID from driver.

Code:
[...]
ap_scan=0
[...]

chessmaster ... by using 'ap_scan=0' your explicitly requesting wpa_supplicant not to scan for AP's, hence the above, and:

Code:
wpa_state=ASSOCIATING

ap_scan=0 is only used for wired networks/802.1X (see: man wpa_supplicant.conf) as obviously a scan is not required. The default value for ap_scan is "1" (if undefined in wpa_supplicant.conf) and there is no need to set unless really required.

Also, your wireless interface, 'wlp4s0', needs to be reflected in /etc/conf.d/net, so:

Code:
modules_wlp4s0="!plug wpa_supplicant"
wpa_supplicant_wlp4s0="-Dnl80211 -qq"
wpa_timeout_wlp4s0="15"
config_wlp4s0="dhcp"
enable_ipv6_wlp4s0="false"

This obviously wasn't effecting your manually calling wpa_supplicant from the commandline above, but it needs to be corrected for /etc/init.d/net.wlp4s0 to work as expected. Note I removed the wpa_cli_wlan0="-G3600" which I have no idea what your intention was as wpa_cli doesn't have a '-G' switch and wpa_cli need not be configured in /etc/conf.d/net.

One more point, with ctrl_interface_group=0 set wpa_cli/wpa_gui will not be accessable to your user, should you want/need that. You may wish to assign ctl_interface to the group 'wheel':

Code:
ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel


best ... khay
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Thu Apr 11, 2013 9:06 pm    Post subject: Reply with quote

khayyam wrote:
chessmaster wrote:
Code:
wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Could not read SSID from driver.

Code:
[...]
ap_scan=0
[...]

chessmaster ... by using 'ap_scan=0' your explicitly requesting wpa_supplicant not to scan for AP's, hence the above, and:

Code:
wpa_state=ASSOCIATING

ap_scan=0 is only used for wired networks/802.1X (see: man wpa_supplicant.conf) as obviously a scan is not required. The default value for ap_scan is "1" (if undefined in wpa_supplicant.conf) and there is no need to set unless really required.

Also, your wireless interface, 'wlp4s0', needs to be reflected in /etc/conf.d/net, so:

Code:
modules_wlp4s0="!plug wpa_supplicant"
wpa_supplicant_wlp4s0="-Dnl80211 -qq"
wpa_timeout_wlp4s0="15"
config_wlp4s0="dhcp"
enable_ipv6_wlp4s0="false"

This obviously wasn't effecting your manually calling wpa_supplicant from the commandline above, but it needs to be corrected for /etc/init.d/net.wlp4s0 to work as expected. Note I removed the wpa_cli_wlan0="-G3600" which I have no idea what your intention was as wpa_cli doesn't have a '-G' switch and wpa_cli need not be configured in /etc/conf.d/net.

One more point, with ctrl_interface_group=0 set wpa_cli/wpa_gui will not be accessable to your user, should you want/need that. You may wish to assign ctl_interface to the group 'wheel':

Code:
ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel


best ... khay


Thanks this fixed my problem
Code:

ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel

Note: For use with netcfg>=2.6.1-1, this should be /run/wpa_supplicant (note: not /var/run/wpa_supplicant). This will, however, break the default for wpa_cli (use the -p option to override). If this is not changed, one gets errors like "Failed to connect to wpa_supplicant - wpa_ctrl_open: no such file or directory".

I was recieving the "Failed to connect to wpa_supplicant-wpa_ctrl_open no such file or directory and I had to use -Dwext for my driver.
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Thu Apr 11, 2013 9:07 pm    Post subject: Reply with quote

Trovalds wrote:
Did you try this? http://wiki.gentoo.org/wiki/Udev/upgrade

I have problems with my box after a update too.


Appreciated this really got me in the right direction. and reading this:

Code:

/usr/portage/metadata/news/2013-03-29-udev-upgrade/2013-03-29-udev-upgrade.en.txt
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 12:35 am    Post subject: Reply with quote

Code:

awk '/(WEXT|(MAC|CFG)80211)/' /usr/src/linux/.config





Code:


CONFIG_WEXT_CORE=y
CONFIG_WEXT_PROC=y
CONFIG_CFG80211=m
# CONFIG_CFG80211_DEVELOPER_WARNINGS is not set
# CONFIG_CFG80211_REG_DEBUG is not set
CONFIG_CFG80211_DEFAULT_PS=y
# CONFIG_CFG80211_DEBUGFS is not set
# CONFIG_CFG80211_INTERNAL_REGDB is not set
CONFIG_CFG80211_WEXT=y
CONFIG_MAC80211=m
CONFIG_MAC80211_HAS_RC=y
CONFIG_MAC80211_RC_MINSTREL=y
CONFIG_MAC80211_RC_MINSTREL_HT=y
CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
CONFIG_MAC80211_RC_DEFAULT="minstrel_ht"
CONFIG_MAC80211_MESH=y
CONFIG_MAC80211_LEDS=y
# CONFIG_MAC80211_DEBUGFS is not set
# CONFIG_MAC80211_MESSAGE_TRACING is not set
CONFIG_MAC80211_DEBUG_MENU=y
# CONFIG_MAC80211_NOINLINE is not set
# CONFIG_MAC80211_VERBOSE_DEBUG is not set
# CONFIG_MAC80211_MLME_DEBUG is not set
# CONFIG_MAC80211_STA_DEBUG is not set
# CONFIG_MAC80211_HT_DEBUG is not set
# CONFIG_MAC80211_IBSS_DEBUG is not set
# CONFIG_MAC80211_PS_DEBUG is not set
# CONFIG_MAC80211_MPL_DEBUG is not set
# CONFIG_MAC80211_MPATH_DEBUG is not set
# CONFIG_MAC80211_MHWMP_DEBUG is not set
# CONFIG_MAC80211_MESH_SYNC_DEBUG is not set
# CONFIG_MAC80211_TDLS_DEBUG is not set
# CONFIG_MAC80211_HWSIM is not set



Code:

awk '{RS="Cell"}/dasilvam/' <(iwlist wlp4s0 scan) | less


Code:

wlp4s0 Interface doesn't support scanning Network is down


Code:


 wpa_supplicant -Dnl80211 -iwlp4s0 -c/etc/wpa_supplicant/wpa_supplicant.conf
SME: No scan result available for the network


Code:

modules_wlp4s0="wpa_supplicant"
wpa_supplicant_wlp4s0="-Dnl80211 -c/etc/wpa_supplicant/wpa_supplicant.conf"
config_wlp4s0="dhcp"


Code:

ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
ap_scan=2
update_config=1
eapol_version=1
fast_reauth=1

network={
        ssid="ssid"
        #psk="password"
        psk=hex
        proto=RSN WPA
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        pairwise=CCMP TKIP
        group=CCMP TKIP
        priority=5
}





Code:

Quasar conf.d # wpa_supplicant -Dwext -iwlp4s0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Trying to associate with SSID 'ssid'
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable



result
Code:

ioctl[SIOCGIWSCAN]: Resource temporarily unavailable



Code:

Quasar conf.d # lsmod
Module                  Size  Used by
nvidia               9104327  30
snd_hda_codec_hdmi     23441  1
iwldvm                142700  0
led_class               2540  1 iwldvm
mac80211              309224  1 iwldvm
snd_hda_codec_conexant    39754  1
snd_hda_intel          20997  0
snd_hda_codec          63234  3 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep               5079  1 snd_hda_codec
snd_pcm                57395  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
firewire_ohci          26148  0
firewire_core          42538  1 firewire_ohci
crc_itu_t               1260  1 firewire_core
iwlwifi               102191  1 iwldvm
cfg80211              145820  3 iwlwifi,mac80211,iwldvm
snd_page_alloc          5995  2 snd_pcm,snd_hda_intel
snd_timer              15296  1 snd_pcm
rfkill                 13080  1 cfg80211


Still no luck
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1539

PostPosted: Fri Apr 12, 2013 7:46 am    Post subject: Reply with quote

chessmaster wrote:
Thanks this fixed my problem

chessmaster ... you're welcome, but now I'm confused as the next post suggests its not fixed.

chessmaster wrote:
Quote:
Note: For use with netcfg>=2.6.1-1, this should be /run/wpa_supplicant (note: not /var/run/wpa_supplicant). This will, however, break the default for wpa_cli (use the -p option to override). If this is not changed, one gets errors like "Failed to connect to wpa_supplicant - wpa_ctrl_open: no such file or directory".

I was recieving the "Failed to connect to wpa_supplicant-wpa_ctrl_open no such file or directory and I had to use -Dwext for my driver.

The above "Note" should make no difference, on gentoo /var/run is a symlink to /run. As for the error, I don't understand how changing wpa_supplicant driver would make any difference WRT the ctrl_interface. The only reason I can think of is if you were trying to run wpa_supplicant as your user, and not as root.

chessmaster wrote:
Code:
# awk '/(WEXT|(MAC|CFG)80211)/' /usr/src/linux/.config
[...]
CONFIG_MAC80211_MESH=y
[...]

I generally don't include MAC80211_MESH as there have been reported issues with it and standard wireless networking. Unless you plan on using MESH networking I'd suggest disabling it. Otherwise, everything seems to be in order.

chessmaster wrote:
Code:
# awk '{RS="Cell"}/dasilvam/' <(iwlist wlp4s0 scan)

That is the name of your AP's ESSID right? I get the impression I've seen that ESSID before ... and the commands look distinctly like those I would have suggested, so I'm thinking you may have copied this verbatum from some other thread. Anyhow, the "Interface doesn't support scanning Network is down" error generally means .... ummm ... the interface is down :) ... please try with the following:

Code:
# ip link set dev wlp4s0 up
# awk '{RS="Cell"}/<ESSID_of_AP>/' <(iw dev wlp4s0 scan)

or if using the depreciated net-tools/wireless-tools:

Code:
# ifconfig wlp4s0 up
# awk '{RS="Cell"}/<ESSID_of_AP>/' <(iwlist wlp4s0 scan)

It may of course be that the driver/firmware is at issue, but its more likely the interface is simply down.

Note that it might help if you use the same ESSID naming convention when providing details, as I'm not sure if your ESSID is 'ssid', as in your wpa_supplicant.conf, or 'dasilvam', it doesn't matter which but small details can make all the difference.

chessmaster wrote:
Code:
ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
ap_scan=2
update_config=1
eapol_version=1
fast_reauth=1

network={
        ssid="ssid"
        #psk="password"
        psk=hex
        proto=RSN WPA
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        pairwise=CCMP TKIP
        group=CCMP TKIP
        priority=5
}

OK, why are you using 'ap_scan=2'? As I said above 'ap_san=1' is the default, and unless your AP has a number of (virtual) ESSID's or your card is known not to work without it just use the default. Also, as you seem to be cutting & pasting from elsewhere, and just to be sure, the 'psk=hex' is just a notation correct .... the psk is infact a hex string?

chessmaster wrote:
Code:
# wpa_supplicant -Dwext -iwlp4s0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Trying to associate with SSID 'ssid'
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable

From this I get the impression that your 'sid' is actually set to 'ssid', which of course will only work if the AP's ESSID is infact 'ssid', so some confusion here, as the ESSID is either 'ssid' or 'dasilvam' ... or perhaps something else entirely. Anyhow, the error means that something is currently using the interface, ie, that wpa_supplicant, or dhcpcd, or what-have-you is running. If you use wpa_supplicant from the commandline (ie, for testing purposes) then you must make sure nothing is currently active on wlp4s0. If dhcpcd is set to run in the default runlevel remove it, and if /etc/init.d/net.wlp4s0 is running then stop it prior to testing.

Its difficult to see exactly what the issue is, or whether there are just small misconfigurations that are holding you back. So, I'd suggest you focus on getting wpa_supplicant to work via /etc/init.d/net.wlp4s0 and not via the commandline, it might be easier to see what is infact happening.

best ... khay
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 2:30 pm    Post subject: Reply with quote

khayyam wrote:
chessmaster wrote:
Thanks this fixed my problem

chessmaster ... you're welcome, but now I'm confused as the next post suggests its not fixed.

chessmaster wrote:
Quote:
Note: For use with netcfg>=2.6.1-1, this should be /run/wpa_supplicant (note: not /var/run/wpa_supplicant). This will, however, break the default for wpa_cli (use the -p option to override). If this is not changed, one gets errors like "Failed to connect to wpa_supplicant - wpa_ctrl_open: no such file or directory".

I was recieving the "Failed to connect to wpa_supplicant-wpa_ctrl_open no such file or directory and I had to use -Dwext for my driver.

The above "Note" should make no difference, on gentoo /var/run is a symlink to /run. As for the error, I don't understand how changing wpa_supplicant driver would make any difference WRT the ctrl_interface. The only reason I can think of is if you were trying to run wpa_supplicant as your user, and not as root.

chessmaster wrote:
Code:
# awk '/(WEXT|(MAC|CFG)80211)/' /usr/src/linux/.config
[...]
CONFIG_MAC80211_MESH=y
[...]

I generally don't include MAC80211_MESH as there have been reported issues with it and standard wireless networking. Unless you plan on using MESH networking I'd suggest disabling it. Otherwise, everything seems to be in order.

chessmaster wrote:
Code:
# awk '{RS="Cell"}/dasilvam/' <(iwlist wlp4s0 scan)

That is the name of your AP's ESSID right? I get the impression I've seen that ESSID before ... and the commands look distinctly like those I would have suggested, so I'm thinking you may have copied this verbatum from some other thread. Anyhow, the "Interface doesn't support scanning Network is down" error generally means .... ummm ... the interface is down :) ... please try with the following:

Code:
# ip link set dev wlp4s0 up
# awk '{RS="Cell"}/<ESSID_of_AP>/' <(iw dev wlp4s0 scan)

or if using the depreciated net-tools/wireless-tools:

Code:
# ifconfig wlp4s0 up
# awk '{RS="Cell"}/<ESSID_of_AP>/' <(iwlist wlp4s0 scan)

It may of course be that the driver/firmware is at issue, but its more likely the interface is simply down.

Note that it might help if you use the same ESSID naming convention when providing details, as I'm not sure if your ESSID is 'ssid', as in your wpa_supplicant.conf, or 'dasilvam', it doesn't matter which but small details can make all the difference.

chessmaster wrote:
Code:
ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
ap_scan=2
update_config=1
eapol_version=1
fast_reauth=1

network={
        ssid="ssid"
        #psk="password"
        psk=hex
        proto=RSN WPA
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        pairwise=CCMP TKIP
        group=CCMP TKIP
        priority=5
}

OK, why are you using 'ap_scan=2'? As I said above 'ap_san=1' is the default, and unless your AP has a number of (virtual) ESSID's or your card is known not to work without it just use the default. Also, as you seem to be cutting & pasting from elsewhere, and just to be sure, the 'psk=hex' is just a notation correct .... the psk is infact a hex string?

chessmaster wrote:
Code:
# wpa_supplicant -Dwext -iwlp4s0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Trying to associate with SSID 'ssid'
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable

From this I get the impression that your 'sid' is actually set to 'ssid', which of course will only work if the AP's ESSID is infact 'ssid', so some confusion here, as the ESSID is either 'ssid' or 'dasilvam' ... or perhaps something else entirely. Anyhow, the error means that something is currently using the interface, ie, that wpa_supplicant, or dhcpcd, or what-have-you is running. If you use wpa_supplicant from the commandline (ie, for testing purposes) then you must make sure nothing is currently active on wlp4s0. If dhcpcd is set to run in the default runlevel remove it, and if /etc/init.d/net.wlp4s0 is running then stop it prior to testing.

Its difficult to see exactly what the issue is, or whether there are just small misconfigurations that are holding you back. So, I'd suggest you focus on getting wpa_supplicant to work via /etc/init.d/net.wlp4s0 and not via the commandline, it might be easier to see what is infact happening.

best ... khay















First of all thanks for the help
Code:

Quasar checkmate # rc-status
Runlevel: default
 net.wlp4s0                                                        [  stopped  ]
 net.enp2s0                                                        [  stopped  ]
 netmount                                                          [  stopped  ]
 syslog-ng                                                         [  started  ]
 local                                                             [  started  ]


Code:

Quasar checkmate # dmesg |tail
[  668.554092] iwlwifi 0000:04:00.0: Radio type=0x1-0x2-0x0
[  668.697837] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[  850.069570] sky2 0000:02:00.0 enp2s0: enabling interface
[  850.069886] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[  851.753286] sky2 0000:02:00.0 enp2s0: Link is up at 100 Mbps, full duplex, flow control both
[  851.753305] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s0: link becomes ready
[ 1032.125027] sky2 0000:02:00.0 enp2s0: disabling interface
[ 1050.784901] iwlwifi 0000:04:00.0: L1 Disabled; Enabling L0S
[ 1050.787883] iwlwifi 0000:04:00.0: Radio type=0x1-0x2-0x0
[ 1050.918201] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready


Code:

modules_wlp4s0="!plug wpa_supplicant"
wpa_supplicant_wlp4s0="-Dwext -qq"
config_wlp4s0="dhcp"
enable_ipv6_wlp4s0="false"


Code:

ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel

network={
        ssid="Linux_Server"
        #psk="placeholder"
        psk=9f00cd1db413b9f5106370e331d7eec1734a54a71ddac2c59ecd2c002e3060f6
}


Code:

Quasar checkmate # wpa_supplicant -Dwext -iwlp4s0 -c/etc/wpa_supplicant/wpa_supplicant.conf
ioctl[SIOCSIWSCAN]: Device or resource busy
Failed to initiate AP scan.
ioctl[SIOCSIWSCAN]: Device or resource busy
Failed to initiate AP scan.
ioctl[SIOCSIWSCAN]: Device or resource busy
Failed to initiate AP scan.
ioctl[SIOCSIWSCAN]: Device or resource busy
Failed to initiate AP scan.
^CCTRL-EVENT-TERMINATING - signal 2 received


Now when I take away the space in between the two words in my ssid making it Linux Server this is what I get
Code:

Quasar checkmate # wpa_supplicant -Dwext -iwlp4s0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
ioctl[SIOCSIWFREQ]: Device or resource busy
Association request to the driver failed
Associated with 00:00:00:00:00:00
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=0
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
ioctl[SIOCSIWFREQ]: Device or resource busy
Association request to the driver failed
Associated with e0:91:f5:c0:65:d7
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=0
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
ioctl[SIOCSIWFREQ]: Device or resource busy
Association request to the driver failed
Associated with 00:00:00:00:00:00
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=0
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
ioctl[SIOCSIWFREQ]: Device or resource busy
Association request to the driver failed
Associated with e0:91:f5:c0:65:d7
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=0
^CCTRL-EVENT-TERMINATING - signal 2 received


Code:

Quasar checkmate # ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 00:1d:72:ed:56:80 brd ff:ff:ff:ff:ff:ff
3: wlp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 00:21:6b:71:7d:36 brd ff:ff:ff:ff:ff:ff
Quasar checkmate # ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 48  bytes 4368 (4.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 48  bytes 4368 (4.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp4s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:21:6b:71:7d:36  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1539

PostPosted: Fri Apr 12, 2013 3:34 pm    Post subject: Reply with quote

chessmaster wrote:
First of all thanks for the help

chessmaster ... again, your welcome ...

A couple of things:

What card, kernel, and firmware version is involved here? When the modules load is there anything in dmesg? To me the above looks like a driver issue.

Also, iwlwifi is NL80211, not WEXT, I'm not sure this has any baring on the matter, but really you should be using '-Dnl80211' as the wpa_supplicant driver.

Can you emerge net-wireless/rfkill and see if the card is hard/soft blocked (you may also need to enable CONFIG_RFKILL in the kernel ... a module should be fine).

Code:
# rfkill list 0

I know there are some issues with iwlwifi specificly related to 'N' though these are more stability issues than 'resource busy' ... but anyhow, N can be disabled like so.

/etc/modprobe.d/iwlwifi.conf
Code:
options iwlwifi 11n_disable=1

This probably has nothing to do with it, but thought it worth mentioning anyhow.

Also, please, please edit your quotes ...

Thats about all I can think of currently ... best ... khay

EDIT: An afterthought: if you booted with net.previously_known_as_wlan0 in the runlevel, then stopped it because the network connection wasn't establsihed (for whatever reason), it may be the card is soft blocked subsequently (the same happens here with ath5k). Just to be sure, please check the status and unblock if need be:

Code:
# rfkill unblock all
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 4:07 pm    Post subject: Reply with quote

khayyam wrote:
chessmaster wrote:
First of all thanks for the help

chessmaster ... again, your welcome ...

A couple of things:

What card, kernel, and firmware version is involved here? When the modules load is there anything in dmesg? To me the above looks like a driver issue.

Also, iwlwifi is NL80211, not WEXT, I'm not sure this has any baring on the matter, but really you should be using '-Dnl80211' as the wpa_supplicant driver.

Can you emerge net-wireless/rfkill and see if the card is hard/soft blocked (you may also need to enable CONFIG_RFKILL in the kernel ... a module should be fine).

Code:
# rfkill list 0

I know there are some issues with iwlwifi specificly related to 'N' though these are more stability issues than 'resource busy' ... but anyhow, N can be disabled like so.

/etc/modprobe.d/iwlwifi.conf
Code:
options iwlwifi 11n_disable=1

This probably has nothing to do with it, but thought it worth mentioning anyhow.

Thats about all I can think of currently ... best ... khay

hi khayyam,

Code:

Quasar checkmate # uname -a
Linux Quasar 3.7.10-gentoo #10 SMP Fri Apr 12 08:28:20 EDT 2013 x86_64 Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz GenuineIntel GNU/Linux


Code:

/lib/modules/3.7.10-gentoo/video/nvidia.ko
/lib/modules/3.7.10-gentoo/kernel/net/netfilter/nf_nat_sip.ko
/lib/modules/3.7.10-gentoo/kernel/net/netfilter/xt_TCPMSS.ko
/lib/modules/3.7.10-gentoo/kernel/net/netfilter/xt_mark.ko
/lib/modules/3.7.10-gentoo/kernel/net/netfilter/xt_LOG.ko
/lib/modules/3.7.10-gentoo/kernel/net/netfilter/nf_nat.ko
/lib/modules/3.7.10-gentoo/kernel/net/netfilter/xt_nat.ko
/lib/modules/3.7.10-gentoo/kernel/net/netfilter/nf_nat_ftp.ko
/lib/modules/3.7.10-gentoo/kernel/net/netfilter/nf_nat_irc.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv4/netfilter/iptable_nat.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv4/netfilter/ipt_MASQUERADE.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv4/netfilter/nf_nat_ipv4.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv4/tunnel4.ko
/lib/modules/3.7.10-gentoo/kernel/net/wireless/cfg80211.ko
/lib/modules/3.7.10-gentoo/kernel/net/wireless/lib80211.ko
/lib/modules/3.7.10-gentoo/kernel/net/rfkill/rfkill.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/netfilter/nf_conntrack_ipv6.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/netfilter/ip6t_ipv6header.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/netfilter/ip6_tables.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/netfilter/ip6t_REJECT.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/netfilter/ip6table_filter.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/netfilter/nf_defrag_ipv6.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/netfilter/ip6table_mangle.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/ipv6.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/sit.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/xfrm6_mode_beet.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/xfrm6_mode_transport.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/ah6.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/esp6.ko
/lib/modules/3.7.10-gentoo/kernel/net/ipv6/xfrm6_mode_tunnel.ko
/lib/modules/3.7.10-gentoo/kernel/net/mac80211/mac80211.ko
/lib/modules/3.7.10-gentoo/kernel/sound/pci/hda/snd-hda-codec-conexant.ko
/lib/modules/3.7.10-gentoo/kernel/sound/pci/hda/snd-hda-codec.ko
/lib/modules/3.7.10-gentoo/kernel/sound/pci/hda/snd-hda-codec-hdmi.ko
/lib/modules/3.7.10-gentoo/kernel/sound/pci/hda/snd-hda-intel.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/oss/snd-pcm-oss.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/oss/snd-mixer-oss.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/snd-pcm.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/snd-page-alloc.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/snd-hwdep.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/seq/snd-seq-dummy.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/seq/oss/snd-seq-oss.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/seq/snd-seq-midi-event.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/seq/snd-seq-device.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/seq/snd-seq.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/snd-hrtimer.ko
/lib/modules/3.7.10-gentoo/kernel/sound/core/snd-timer.ko
/lib/modules/3.7.10-gentoo/kernel/fs/ntfs/ntfs.ko
/lib/modules/3.7.10-gentoo/kernel/fs/isofs/isofs.ko
/lib/modules/3.7.10-gentoo/kernel/fs/fat/msdos.ko
/lib/modules/3.7.10-gentoo/kernel/fs/fat/vfat.ko
/lib/modules/3.7.10-gentoo/kernel/fs/fat/fat.ko
/lib/modules/3.7.10-gentoo/kernel/drivers/leds/led-class.ko
/lib/modules/3.7.10-gentoo/kernel/drivers/net/wireless/iwlwifi/dvm/iwldvm.ko
/lib/modules/3.7.10-gentoo/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
/lib/modules/3.7.10-gentoo/kernel/drivers/firewire/firewire-ohci.ko
/lib/modules/3.7.10-gentoo/kernel/drivers/firewire/firewire-core.ko
/lib/modules/3.7.10-gentoo/kernel/drivers/char/kcopy/kcopy.ko
/lib/modules/3.7.10-gentoo/kernel/lib/crc-itu-t.ko


Code:

Quasar[/quote] checkmate # ls -l /lib/firmware/
total 336
-rw-r--r-- 1 root root 340688 Apr 11 00:32 iwlwifi-5000-5.ucode


After changing the driver -Dnl80211 and in conf.d/net
Code:

Quasar checkmate # wpa_supplicant -Dnl80211 -iwlp4s0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=2
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=2
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=2
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=2
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
^CCTRL-EVENT-TERMINATING - signal 2 received


Code:

Quasar rules.d # dmesg | tail
[ 6855.471455] wlp4s0: RX AssocResp from e0:91:f5:c0:65:d7 (capab=0x431 status=0 aid=3)
[ 6855.476363] wlp4s0: associated
[ 6858.474332] wlp4s0: deauthenticated from e0:91:f5:c0:65:d7 (Reason: 2)
[ 6858.484431] cfg80211: Calling CRDA to update world regulatory domain
[ 6861.798334] wlp4s0: authenticate with e0:91:f5:c0:65:d7
[ 6861.800134] wlp4s0: send auth to e0:91:f5:c0:65:d7 (try 1/3)
[ 6861.801813] wlp4s0: authenticated
[ 6861.802035] wlp4s0: associate with e0:91:f5:c0:65:d7 (try 1/3)
[ 6861.806849] wlp4s0: RX AssocResp from e0:91:f5:c0:65:d7 (capab=0x431 status=0 aid=3)
[ 6861.809783] wlp4s0: associated


Code:

Quasar rules.d # lsmod
Module                  Size  Used by
ipv6                  220550  10
tunnel4                 1926  0
nvidia               9104327  40
snd_hda_codec_hdmi     23441  1
snd_hda_codec_conexant    39754  1
snd_hda_intel          20997  0
snd_hda_codec          63234  3 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep               5079  1 snd_hda_codec
snd_pcm                57395  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          5995  2 snd_pcm,snd_hda_intel
snd_timer              15296  1 snd_pcm
iwldvm                145816  0
led_class               2540  1 iwldvm
mac80211              309431  1 iwldvm
firewire_ohci          26148  0
firewire_core          42538  1 firewire_ohci
crc_itu_t               1260  1 firewire_core
iwlwifi               108059  1 iwldvm
cfg80211              147936  3 iwlwifi,mac80211,iwldvm
rfkill                 13080  1 cfg80211


Code:

Quasar rules.d # rfkill list 0
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no


Code:

# You should consult your kernel documentation and configuration
# for a list of modules and their options.
modules="nvidia"
modules="snd-hda-codec-conexant"
modules="snd-hda-intel"
modules="snd-pcm-oss"
modules="snd-mixer-oss"
modules="snd-pcm"
modules="snd-hda-codec"
modules="iwlwifi"
modules="cfg80211"
modules="lib80211"
modules="iwldvm"
modules="rfkill"
modules="nf_nat_ipv4"
modules="nf_nat_sip"
modules="xt_TCPMSS"
modules="xt_mark"
modules="nf_nat"
modules="xt_nat"
modules="nf_nat_ftp"
modules="nf_nat_irc"
modules="tunnel4"



Code:

Quasar modprobe.d # cat iwlwifi.conf
options iwlwifi 11n_disabled=1
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 4:20 pm    Post subject: Reply with quote

This was my wpa_supplicant.conf before I change it with the errors

Code:

ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel

network={
        ssid="Linux_Server"
        #psk="placeholder"
        psk=9f00cd1db413b9f5106370e331d7eec1734a54a71ddac2c59ecd2c002e3060f6
}


reported errors
Code:

Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=2
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=2
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=2
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: 4-Way Handshake failed - pre-shared key may be incorrect
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=2
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
^CCTRL-EVENT-TERMINATING - signal 2 received


now my wpa_supplicant.conf
Code:

ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
ap_scan=1
network={
        ssid="Linux Server"
        psk="placeholder"
        proto=RSN
}


error
Code:

Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Association request to the driver failed
Associated with e0:91:f5:c0:65:d7
WPA: Key negotiation completed with e0:91:f5:c0:65:d7 [PTK=CCMP GTK=CCMP]
CTRL-EVENT-CONNECTED - Connection to e0:91:f5:c0:65:d7 completed (reauth) [id=0 id_str=]
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=3
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
Failed to initiate AP scan.
Failed to initiate AP scan.
Failed to initiate AP scan.
Failed to initiate AP scan.
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 4:55 pm    Post subject: Reply with quote

Code:

Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)                                                                                aid=3)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7                                               reason=3)
WPA: Invalid EAPOL-Key MIC when using TPTK - ignoring TPTK
WPA: Could not verify EAPOL-Key MIC - dropping packet
Authentication with e0:91:f5:c0:65:d7 timed out.
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz aid=3))
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)  reason=3)
Associated with e0:91:f5:c0:65:d7
WPA: Key negotiation completed with e0:91:f5:c0:65:d7 [PTK=CCMP GTK=CCMP]
CTRL-EVENT-CONNECTED - Connection to e0:91:f5:c0:65:d7 completed (reauth) [id=0 id_str=]                                                                        ow control both
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=3
Failed to initiate AP scan.
Failed to initiate AP scan.
Failed to initiate AP scan.
Failed to initiate AP scan.
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: Key negotiation completed with e0:91:f5:c0:65:d7 [PTK=CCMP GTK=CCMP]
CTRL-EVENT-CONNECTED - Connection to e0:91:f5:c0:65:d7 completed (reauth) [id=0 id_str=]
CTRL-EVENT-DISCONNECTED bssid=e0:91:f5:c0:65:d7 reason=3
Failed to initiate AP scan.
Failed to initiate AP scan.
Failed to initiate AP scan.
Failed to initiate AP scan.



Code:

modules_wlp4s0="!plug wpa_supplicant dhcp"
wpa_supplicant_wlp4s0="-Dnl80211 -qq"
config_wlp4s0="dhcp"
enable_ipv6_wlp4s0="false"

Code:

ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
ap_scan=1
network={
        ssid="Linux Server"
        #psk="placeholder"
        psk=3024c58f6b756e78554d01790c637b51adb0f59d6aa57ea31a6772addf289ff8
        key_mgmt=WPA-PSK
        proto=RSN
        auth_alg=OPEN
        scan_ssid=1
        group=CCMP
        pairwise=CCMP
}
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 5:26 pm    Post subject: Reply with quote

I have WPA2-PSK AES on my router maybe I will try changing it to both TKIP and AES settings to see if this works
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1539

PostPosted: Fri Apr 12, 2013 6:15 pm    Post subject: Reply with quote

chessmaster ... there is such a thing as *too much* information, if you just try to provide the necessary information and edited, or omited, your quotes, it would make it a lot easier for me to parse the signal from the noise.

chessmaster wrote:
Code:
WPA: Could not verify EAPOL-Key MIC - dropping packet
Authentication with e0:91:f5:c0:65:d7 timed out.
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3

Ok, so its not a driver issue at all, its authentication.

Firstly, check the psk .... secondly try with just the basic requirements in wpa_supplicant.conf

Code:
ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
update_config=1

network={
    ssid="Linux Server"
    psk=3024c58f6b756e78554d01790c637b51adb0f59d6aa57ea31a6772addf289ff8
    key_mgmt=WPA-PSK
}

If that fails, try adding 'eapol_version=2' (not within the 'network' block).

best ... khay
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 6:31 pm    Post subject: Reply with quote

Code:

[Quasar rules.d # wpa_cli status
Selected interface 'wlp4s0'
bssid=e0:91:f5:c0:65:d7
ssid=Linux Server
id=0
mode=station
pairwise_cipher=TKIP
group_cipher=TKIP
key_mgmt=WPA2-PSK
wpa_state=COMPLETED
ip_address=192.168.1.2
Quasar rules.d # ping -c 3 google.com
ping: unknown host google.com


Code:

ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
update_config=1
eapol_version=2
network={
        ssid="Linux Server"
        #psk="placeholder"
        psk=3024c58f6b756e78554d01790c637b51adb0f59d6aa57ea31a6772addf289ff8
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
}


ifconfig keeps showing that my wlp4s0 is dropping which doesn't even stay when I active net.wlp4s0
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 6:41 pm    Post subject: Reply with quote

khayyam wrote:
chessmaster wrote:
Thanks this fixed my problem

chessmaster ... you're welcome, but now I'm confused as the next post suggests its not fixed.

chessmaster wrote:
Quote:
Note: For use with netcfg>=2.6.1-1, this should be /run/wpa_supplicant (note: not /var/run/wpa_supplicant). This will, however, break the default for wpa_cli (use the -p option to override). If this is not changed, one gets errors like "Failed to connect to wpa_supplicant - wpa_ctrl_open: no such file or directory".

I was recieving the "Failed to connect to wpa_supplicant-wpa_ctrl_open no such file or directory and I had to use -Dwext for my driver.

The above "Note" should make no difference, on gentoo /var/run is a symlink to /run. As for the error, I don't understand how changing wpa_supplicant driver would make any difference WRT the ctrl_interface. The only reason I can think of is if you were trying to run wpa_supplicant as your user, and not as root.

chessmaster wrote:
Code:
# awk '/(WEXT|(MAC|CFG)80211)/' /usr/src/linux/.config
[...]
CONFIG_MAC80211_MESH=y
[...]

I generally don't include MAC80211_MESH as there have been reported issues with it and standard wireless networking. Unless you plan on using MESH networking I'd suggest disabling it. Otherwise, everything seems to be in order.

chessmaster wrote:
Code:
# awk '{RS="Cell"}/dasilvam/' <(iwlist wlp4s0 scan)

That is the name of your AP's ESSID right? I get the impression I've seen that ESSID before ... and the commands look distinctly like those I would have suggested, so I'm thinking you may have copied this verbatum from some other thread. Anyhow, the "Interface doesn't support scanning Network is down" error generally means .... ummm ... the interface is down :) ... please try with the following:

Code:
# ip link set dev wlp4s0 up
# awk '{RS="Cell"}/<ESSID_of_AP>/' <(iw dev wlp4s0 scan)

or if using the depreciated net-tools/wireless-tools:

Code:
# ifconfig wlp4s0 up
# awk '{RS="Cell"}/<ESSID_of_AP>/' <(iwlist wlp4s0 scan)

It may of course be that the driver/firmware is at issue, but its more likely the interface is simply down.

Note that it might help if you use the same ESSID naming convention when providing details, as I'm not sure if your ESSID is 'ssid', as in your wpa_supplicant.conf, or 'dasilvam', it doesn't matter which but small details can make all the difference.

chessmaster wrote:
Code:
ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
ap_scan=2
update_config=1
eapol_version=1
fast_reauth=1

network={
        ssid="ssid"
        #psk="password"
        psk=hex
        proto=RSN WPA
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        pairwise=CCMP TKIP
        group=CCMP TKIP
        priority=5
}

OK, why are you using 'ap_scan=2'? As I said above 'ap_san=1' is the default, and unless your AP has a number of (virtual) ESSID's or your card is known not to work without it just use the default. Also, as you seem to be cutting & pasting from elsewhere, and just to be sure, the 'psk=hex' is just a notation correct .... the psk is infact a hex string?

chessmaster wrote:
Code:
# wpa_supplicant -Dwext -iwlp4s0 -c/etc/wpa_supplicant/wpa_supplicant.conf
Trying to associate with SSID 'ssid'
ioctl[SIOCGIWSCAN]: Resource temporarily unavailable

From this I get the impression that your 'sid' is actually set to 'ssid', which of course will only work if the AP's ESSID is infact 'ssid', so some confusion here, as the ESSID is either 'ssid' or 'dasilvam' ... or perhaps something else entirely. Anyhow, the error means that something is currently using the interface, ie, that wpa_supplicant, or dhcpcd, or what-have-you is running. If you use wpa_supplicant from the commandline (ie, for testing purposes) then you must make sure nothing is currently active on wlp4s0. If dhcpcd is set to run in the default runlevel remove it, and if /etc/init.d/net.wlp4s0 is running then stop it prior to testing.

Its difficult to see exactly what the issue is, or whether there are just small misconfigurations that are holding you back. So, I'd suggest you focus on getting wpa_supplicant to work via /etc/init.d/net.wlp4s0 and not via the commandline, it might be easier to see what is infact happening.

best ... khay



The problem is my device does not stay connected. It will scan and connect and disconnect


Code:

Quasar rules.d # ping -c 3 google.com
PING google.com (74.125.228.0) 56(84) bytes of data.
64 bytes from iad23s05-in-f0.1e100.net (74.125.228.0): icmp_seq=1 ttl=55 time=16.4 ms
64 bytes from iad23s05-in-f0.1e100.net (74.125.228.0): icmp_seq=2 ttl=55 time=16.0 ms
64 bytes from iad23s05-in-f0.1e100.net (74.125.228.0): icmp_seq=3 ttl=54 time=15.0 ms

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 15.044/15.829/16.430/0.598 ms
Quasar rules.d # ping -c 3 google.com
ping: unknown host google.com
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ping -c 3 google.com
ping: unknown host google.com
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ip link set wlp4s0 up
Quasar rules.d # ping -c 3 google.com
ping: unknown host google.com
Quasar rules.d # ping -c 3 google.com
PING google.com (74.125.228.41) 56(84) bytes of data.
64 bytes from iad23s06-in-f9.1e100.net (74.125.228.41): icmp_seq=1 ttl=55 time=17.6 ms
64 bytes from iad23s06-in-f9.1e100.net (74.125.228.41): icmp_seq=2 ttl=55 time=15.1 ms
64 bytes from iad23s06-in-f9.1e100.net (74.125.228.41): icmp_seq=3 ttl=55 time=15.2 ms

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 15.161/16.026/17.632/1.141 ms



Code:

ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
eapol_version=1
network={
        ssid="Linux Server"
        #psk="placeholder"
        psk=3024c58f6b756e78554d01790c637b51adb0f59d6aa57ea31a6772addf289ff8
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
}

Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 6:47 pm    Post subject: Reply with quote

Code:

WPA: Invalid EAPOL-Key MIC when using TPTK - ignoring TPTK
WPA: Could not verify EAPOL-Key MIC - dropping packet
Authentication with e0:91:f5:c0:65:d7 timed out.
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
Trying to authenticate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Trying to associate with e0:91:f5:c0:65:d7 (SSID='Linux Server' freq=2432 MHz)
Associated with e0:91:f5:c0:65:d7
WPA: Key negotiation completed with e0:91:f5:c0:65:d7 [PTK=TKIP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to e0:91:f5:c0:65:d7 completed (auth) [id=0 id_str=]
Back to top
View user's profile Send private message
chessmaster
n00b
n00b


Joined: 05 Apr 2013
Posts: 68

PostPosted: Fri Apr 12, 2013 7:34 pm    Post subject: Reply with quote

On network now but it keeps disconnecting This is my logs
Code:

Apr 12 15:28:08 Quasar wpa_cli: interface wlp4s0 CONNECTED
Apr 12 15:28:08 Quasar wpa_cli: executing '/etc/init.d/net.wlp4s0 --quiet start' failed
Apr 12 15:28:18 Quasar kernel: [20032.360525] wlp4s0: deauthenticating from e0:91:f5:c0:65:d7 by local choice (reason=3)
Apr 12 15:28:18 Quasar kernel: [20032.381575] cfg80211: Calling CRDA to update world regulatory domain
Apr 12 15:28:18 Quasar wpa_cli: interface wlp4s0 DISCONNECTED
Apr 12 15:28:18 Quasar wpa_cli: executing 'false /etc/init.d/net.wlp4s0 --quiet stop' failed
Apr 12 15:28:22 Quasar kernel: [20035.659267] wlp4s0: authenticate with e0:91:f5:c0:65:d7
Apr 12 15:28:22 Quasar kernel: [20035.660627] wlp4s0: send auth to e0:91:f5:c0:65:d7 (try 1/3)
Apr 12 15:28:22 Quasar kernel: [20035.661986] wlp4s0: authenticated
Apr 12 15:28:22 Quasar kernel: [20035.663024] wlp4s0: associate with e0:91:f5:c0:65:d7 (try 1/3)
Apr 12 15:28:22 Quasar kernel: [20035.671071] wlp4s0: RX AssocResp from e0:91:f5:c0:65:d7 (capab=0x431 status=0 aid=1)
Apr 12 15:28:22 Quasar kernel: [20035.673065] wlp4s0: associated
Apr 12 15:28:22 Quasar wpa_cli: interface wlp4s0 CONNECTED


Anyone know what I can do to keep this connected?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum