Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rtorrent crashes randomly
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 09 Jan 2004
Posts: 70

PostPosted: Wed Apr 10, 2013 3:13 am    Post subject: rtorrent crashes randomly Reply with quote

Okay so I have had this problem sens January probably and I cant find a solution.
What happens is that rtorrent crashes with this message "rtorrent: Handshake::fill_read_buffer(...) Buffer overflow." and it happens randomly, usually 4-5 days in-between.
Now I cant remember upgrading the filserver or rtorrent etc at the time it started. I suspect a torrent file is triggering it but still I cant see how rtorrent should not be able to handle that?
Google only gives me bug reports of an older bug in 0.8.2 and I run rtorrent 0.8.9 with libtorrent 0.12.9.

This filserver has 0 problems otherwise and have been running fine for 2-3 years now sens I upgraded it with Athlon II X2 240E and 8Gb of DDR3 1600Mhz running at SPD profile 1333Mhz @ 1.5V @ 9-9-9-24 timings. Got a dedicated disk for torrents, 80+ corsair 650W PSU and a APC 1500VA UPS and it has not crashed or had other failures sens trorrent started to bug out and sens rtorrent is predictable with the same error I figure its isolated to rtorrent.

Sens it started out of the blue I suspect a torrent is causing it sens I add those daily but I cant figure out wish one and I have a few (200-300) and I cant understand why rtorrent in that case would be susceptible to crashing.

Filserver hardware spec is in the signature. Been running stable as a rock.
WS: i7 3930K @4Ghz, 32Gb ram, 128Gb SSD, GTX570, NICs: Intel 2x1Gbit
NAS: Athlon II X2 240E 2.8Ghz, 8Gb ram, 120Gb SSD, 28Tb HDD, NICs: Intel 2x1Gbit
ROUTER: Celeron J1900 2Ghz, 8Gb ram, 120Gb SSD, NICs: 2x1Gbit, WIFI: Intel AC 7260, Atheros AR5005G
Back to top
View user's profile Send private message

Joined: 12 Feb 2006
Posts: 35

PostPosted: Mon Apr 15, 2013 8:16 pm    Post subject: try to Reply with quote

Downgrade/upgrade. Could very well be bug in application.

Not sure if there is verbose mode for application. see if there is anything in you log in metalog or whatever you are using aound time of crash.

Make little script, loop to restart rtorrent when it crashes.
smth like: if rtorent down -> start rtorrent.
Just a user.
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 02 Mar 2005
Posts: 97
Location: Al otro lado de la pantalla

PostPosted: Wed Apr 09, 2014 8:21 pm    Post subject: Reply with quote

Same problem here. Any help?
# emerge -C world >> 9/8
A flower?!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum