Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with Glx
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kalosu
n00b
n00b


Joined: 05 Apr 2013
Posts: 3

PostPosted: Sun Apr 07, 2013 1:07 pm    Post subject: Problem with Glx Reply with quote

Hello everybody, I am new to this forum and today I would like to ask for your help with a problem that I have with gl. It seems that I have some troubles with it since evey time I do glxinfo this message appears:

name of display: :0
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig

This is the post for my Xorg.0.log file

http://bpaste.net/show/89588/

And this is my xorg.conf

http://bpaste.net/show/89594/

In advance, thank you all for your help :D
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6046

PostPosted: Sun Apr 07, 2013 6:30 pm    Post subject: Reply with quote

It looks like there's a conflict between intel and nvidia drivers.
What does 'emerge -1pv libdrm mesa' print ?
Any chance it's a muxless laptop ?
Back to top
View user's profile Send private message
kalosu
n00b
n00b


Joined: 05 Apr 2013
Posts: 3

PostPosted: Sun Apr 07, 2013 7:27 pm    Post subject: Reply with quote

Thanks for the reply.

This is the output of the emerge

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-libs/libdrm-2.4.40 USE="libkms -static-libs" VIDEO_CARDS="intel (-exynos) -nouveau (-omap) -radeon -vmware" 0 kB
[ebuild R ] media-libs/mesa-9.0.1 USE="classic egl gallium llvm nptl shared-glapi -bindist -debug -g3dvl -gbm -gles1 -gles2 -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau (-wayland) -xa -xorg -xvmc" VIDEO_CARDS="intel -i915 -i965 -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB

For the nvidia card I search the official driver on the Nvidia's web page and installed it. For the intel case I am using the driver provided by portage. I read that I cannot access to my card directly but just using bumblee since it is an Optimus card. Nevertheless until now I have not succeded in using it. I do not know if the glx support in my case is being provided by the nvidia card or the intel integrated one.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6046

PostPosted: Mon Apr 08, 2013 7:40 am    Post subject: Reply with quote

kalosu wrote:
For the nvidia card I search the official driver on the Nvidia's web page and installed it.

:roll:
Congratulations, you've broke it. 'eselect opengl' scheme was put in place for a reason.
Back to top
View user's profile Send private message
kalosu
n00b
n00b


Joined: 05 Apr 2013
Posts: 3

PostPosted: Mon Apr 08, 2013 8:53 am    Post subject: Reply with quote

What do you mean by I broke it? Should I use the driver provided by the portage tree? Because I used that one before, but the load was never loaded and the device was never recognized by udev.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6046

PostPosted: Mon Apr 08, 2013 2:22 pm    Post subject: Reply with quote

Perhaps my reaction is a bit strong, but manual installs of nvidia/ati binary blobs tend to mess up the environment.

As such, what you need now is a cleanup after chem spill, not simply an average "how to set up your muxless laptop (as that's what it likely is)" advice.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum