Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sys-fs/udev-200 and firmware-loader USE flag
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2384

PostPosted: Mon Apr 01, 2013 12:19 pm    Post subject: sys-fs/udev-200 and firmware-loader USE flag Reply with quote

Todays's update brings in sys-fs/udev-200, and I see the new USE flag "firmware-loader". Though in the ebuild it's specified as "+firmware-loader" for me it came up with a default value of "-firmware-loader". Checking the USE flag descriptions, it says that this controls the user-space firmware loader, and is deprecated in favor or the in-kernel firmware loader present on 3.8+ kernels. I tweaked it on in /etc/portage/package.use.

Since gentoo-sources-3.8.x is not yet marked stable, I don't think that having this default off is appropriate, yet. It should default to on while 3.7.x is the current stable kernel, and possibly for a while beyond that. Not everyone updates their kernel on release day.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Mon Apr 01, 2013 5:33 pm    Post subject: Reply with quote

That's why it's enabled by default in the ebuild. Only reason why it would show up as disabled is if you configured it to be, by using USE="-*" or USE="-firmware-loader" or /etc/portage/package.use entry.
We don't have any plans in disabling the userspace loader by default anytime soon. That's not likely to be this year.

As in, I agree, please fix your settings.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2384

PostPosted: Mon Apr 01, 2013 6:16 pm    Post subject: Reply with quote

How do I fix my settings, when neither "emerge --info" nor "grep -r firmware /etc/portage" nor "grep -r firmware /usr/portage/profiles" gets any significant hits, yet "emerge -ptv udev" consistently shows "-firmware-lader". I noticed the "+firmware-loader" in the ebuild, which I would have thought would mean "default on", but that's not what comes out, and I can't find anywhere where it's being overridden. Nor do I see "-*" floating around anywhere. By the way, this is occurring with both x86/desktop and amd64/desktop (Neither kde nor knome) profiles.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1561
Location: Berlin, Germany

PostPosted: Tue Apr 02, 2013 12:01 am    Post subject: Reply with quote

In the absence of a make.conf or package.use entry, the only way that a +firmware-loader flag can be disabled is through profile or by messing with portage's USE_ORDER.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2384

PostPosted: Tue Apr 02, 2013 12:20 am    Post subject: Reply with quote

Here...
user@localhost ~ $ grep USE_ORDER /etc/make.conf
USE_ORDER="env:pkg:conf:auto:defaults"
user@localhost ~ $ ls -l /etc/portage/make.profile
lrwxrwxrwx 1 root root 59 Feb 17 08:50 /etc/portage/make.profile -> ../../usr/portage/profiles/default/linux/amd64/13.0/desktop
Then I suspect that the problem is with my USE_ORDER, since I'm using a regular profile, and have done nothing else with the USE flags that would affect firmware-loader.

I seem to remember several years back that something changed on my system. If I remember correctly, software that I'd installed was no longer automagically picked up by subsequent software installations. Someone on the forums recommended fixing USE_ORDER this way. Presuming this is the problem, I've been running with it this way for years, and this is the first time I've been bit by it.

As an example of the behavior I wanted, if I were to install say, "xcb" and its associated packages, I'd like any new software to incorporate it as if I'd added USE="xcb", unless I specifically inhibited it. I'd also like it to rebuild packages as necessary on the next emerge --newuse. (I already set the xcb USE flag, and got it installed that way, by the way.)

Assuming USE_ORDER is the problem, why is it overriding the "+firmware-loader" in the ebuild? What should I have as USE_ORDER, and will it give me the auto-take-advantage-of operation?
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1561
Location: Berlin, Germany

PostPosted: Tue Apr 02, 2013 12:30 am    Post subject: Reply with quote

You don't have pkginternal in USE_ORDER which causes EAPI=1 IUSE defaults to be ignored.

Please carefully read the USE_ORDER description in "man make.conf".
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2384

PostPosted: Tue Apr 02, 2013 12:57 am    Post subject: Reply with quote

Looking at the man page, several things are obviously missing from my USE_ORDER. The simplest thing would be to simply comment mine out, but I think I'll do "emerge -ptuvDN world" before and after doing so, just to check for breakage.

Point of curiosity - I don't see "auto" anywhere in the man page segment on USE_ORDER. I made this change many, many years ago, haven't touched it since, and much may have changed since then. Is "auto" top-secret/hidden, deprecated, or obsolete?
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Tue Apr 02, 2013 7:18 am    Post subject: Reply with quote

chithanh wrote:
In the absence of a make.conf or package.use entry, the only way that a +firmware-loader flag can be disabled is through profile or by messing with portage's USE_ORDER.


Nice catch.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2384

PostPosted: Wed Apr 03, 2013 12:00 pm    Post subject: Reply with quote

Two systems fully rebuilt with the default USE_ORDER, one system still chugging, waiting to start the other 3 until I had my first successes.

I'm guessing that my changing of USE_ORDER goes back to June, 2006 with this forum entry: https://forums.gentoo.org/viewtopic-p-3347284.html?sid=96dce9cce91b617abceb186a26a218dc
So I'm still curious, when did "auto" go away, and when did its behavior come back? When checking the man pages I saw no "auto" option in the USE_ORDER section, yet portage wasn't complaining about its presence. After commenting out my USE_ORDER I was still getting the "auto" behavior, if anything even more thoroughly, because I had to fiddle with the curl_ssl_ flags in order to get myself down to one implementation. As an aside, I began using Gentoo right in between 1.2 and 1.4. I don't remember if I ever actually installed 1.2, but when I started following the forums the migration to 1.4 was being discussed.

Incidentally 95, 104, and 147 packages emerged with this change on the first 3 systems.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum