Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ERROR: app-arch/cpio-2.11 failed (configure phase)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Assassin_53
n00b
n00b


Joined: 22 Mar 2013
Posts: 4
Location: Olympia, WA

PostPosted: Fri Mar 22, 2013 3:13 am    Post subject: ERROR: app-arch/cpio-2.11 failed (configure phase) Reply with quote

I am currently trying to emerge genkernel but it came up with this: http://bpaste.net/show/85513/
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2379
Location: Wisconsin (USA)

PostPosted: Fri Mar 22, 2013 3:18 am    Post subject: Reply with quote

If you've updated gcc since you opened that shell, try opening a new one or do...

source /etc/profile

and see if that helps. Also check make.conf for errors, sometimes this manifests as inability for the compiler to create executables, especially cflags errors or things like that.
Back to top
View user's profile Send private message
Assassin_53
n00b
n00b


Joined: 22 Mar 2013
Posts: 4
Location: Olympia, WA

PostPosted: Fri Mar 22, 2013 10:24 pm    Post subject: Reply with quote

updated gcc: haven't
source /etc/profile: didn't work

How do you check make.conf for errors?
Back to top
View user's profile Send private message
Assassin_53
n00b
n00b


Joined: 22 Mar 2013
Posts: 4
Location: Olympia, WA

PostPosted: Fri Mar 22, 2013 10:36 pm    Post subject: Reply with quote

My make.conf:
http://bpaste.net/show/85737/
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8611

PostPosted: Fri Mar 22, 2013 10:40 pm    Post subject: Re: ERROR: app-arch/cpio-2.11 failed (configure phase) Reply with quote

http://bpaste.net/show/85513/:
configure: error: C compiler cannot create executables
See `config.log' for more details.


Using -march=i686 on x86_64 is not a good choice. For any recent gcc, using -march=native is a good default.
Back to top
View user's profile Send private message
Assassin_53
n00b
n00b


Joined: 22 Mar 2013
Posts: 4
Location: Olympia, WA

PostPosted: Fri Mar 22, 2013 11:05 pm    Post subject: Reply with quote

Thank you that fixed it!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum