Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WTF with Flash? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 455
Location: Cape Town, South Africa

PostPosted: Fri Jan 30, 2015 2:18 pm    Post subject: WTF with Flash? [SOLVED] Reply with quote

Hi

Can't find anything in the forums about this and find it hard to believe I'm the only one with the issues.

Firefox kept popping up a message asking permission to play flash videos ... insists that my flash is out of date and vulnerable.

However:

1. eix shows I had the latest version.
2. Firefox's own 'check plugins' service shows I had the latest version.

In desperation I uninstalled www-plugins/adobe-flash.

YouTube still works (presume it autoswitches to HTML5 videos). Likewise with AdSense ads.

However there are sites that still use Flash... like I wanted to watch a video someone posted on FaceBook.

So now what? Live without flash and miss things, or reinstall flash and get irritated with constant nagging and (wrong?) warnings?

Advice gratefully received :-)

Note: I have Chrome installed (and Konquerer) but prefer Firefox.

thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM


Last edited by iandoug on Fri Jan 30, 2015 4:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1084
Location: Fayetteville, NC, USA

PostPosted: Fri Jan 30, 2015 2:34 pm    Post subject: Reply with quote

Adobe killed Flash updates everywhere but Windows years back. Linux has version 11.2 and this gets security updates, but that is about it. I would update however, as I use Firefox (Aurora) in Gentoo AMD64 and have no warnings. Then again I update at least once a month.
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 455
Location: Cape Town, South Africa

PostPosted: Fri Jan 30, 2015 2:43 pm    Post subject: Reply with quote

The_Great_Sephiroth wrote:
Adobe killed Flash updates everywhere but Windows years back. Linux has version 11.2 and this gets security updates, but that is about it. I would update however, as I use Firefox (Aurora) in Gentoo AMD64 and have no warnings. Then again I update at least once a month.


Update to what? I was already on the latest version (also AMD64) and I update once or more times a week....

My Firefox is on latest stable - 31.3.0. Compiled, not -bin.

thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 402

PostPosted: Fri Jan 30, 2015 2:50 pm    Post subject: Reply with quote

Can you post a screenshot of the message? With www-client/firefox-31.4.0, www-plugins/adobe-flash-11.2.202.440 and a completely clean profile I do not get any warnings, at least not on https://www.adobe.com/software/flash/about/.
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 455
Location: Cape Town, South Africa

PostPosted: Fri Jan 30, 2015 4:24 pm    Post subject: Reply with quote

Apheus wrote:
Can you post a screenshot of the message? With www-client/firefox-31.4.0, www-plugins/adobe-flash-11.2.202.440 and a completely clean profile I do not get any warnings, at least not on https://www.adobe.com/software/flash/about/.


I reinstalled www-plugins/adobe-flash and now Firefox is no longer presenting the messages ... weird. Getting as bad as Windoze :-)

Thanks for trying to help :)

cheers, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5916

PostPosted: Sun Feb 01, 2015 11:31 pm    Post subject: Reply with quote

I've been getting that, too, but I just click on whatever button says "allow" or "allow and remember" and be done with it. It's flash. It's gonna get in your face, because FLASH. :P
_________________
Gentoo Studio
Gentoo Studio in open beta. Feedback wanted.
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2338

PostPosted: Sun Feb 01, 2015 11:48 pm    Post subject: Reply with quote

Flash for Firefox et al. is basically dead. You could install chromium with www-plugins/chrome-binary-plugins if you need flash as it is actively being developed.

Any solution for Flash using adobe-flash is a stopgap measure at best.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2142
Location: Berlin, Germany

PostPosted: Mon Feb 02, 2015 1:01 am    Post subject: Reply with quote

You can find out with
Code:
# qlop -lu www-plugins/adobe-flash
the exact version that you uninstalled. Presumably you had the vulnerable version 11.2.202.438 installed when it didn't work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum