Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sys-libs/glibc" is blocking dev-libs/libiconv-1.14
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
andytheg
n00b
n00b


Joined: 23 Nov 2011
Posts: 71
Location: BASEL

PostPosted: Wed Mar 20, 2013 2:37 pm    Post subject: sys-libs/glibc" is blocking dev-libs/libiconv-1.14 Reply with quote

Code:
sys-libs/glibc" is blocking dev-libs/libiconv-1.14



how can i mask dev-libs/libiconv-1.14 ?
I dont need it.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7021
Location: Goose Creek SC

PostPosted: Wed Mar 20, 2013 5:44 pm    Post subject: Reply with quote

add it to /etc/portage/package.mask
but are you sure?
Code:
equery depends libiconv
found 13 packages need it here
_________________
Defund the FCC.
Back to top
View user's profile Send private message
andytheg
n00b
n00b


Joined: 23 Nov 2011
Posts: 71
Location: BASEL

PostPosted: Thu Mar 21, 2013 1:30 pm    Post subject: Reply with quote

yes it will be need, but glibc block it.
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 911
Location: Massachusetts USA

PostPosted: Thu Mar 21, 2013 5:06 pm    Post subject: Reply with quote

The packages that depend on libiconv should be depending on virtual/libiconv, which if glibc is being used will not depend on dev-libs/libiconv.

What profile are you using?
Execute the emerge --info command and look for ELIBC, it should be ELIBC="glibc".
Back to top
View user's profile Send private message
andytheg
n00b
n00b


Joined: 23 Nov 2011
Posts: 71
Location: BASEL

PostPosted: Fri Mar 22, 2013 1:31 pm    Post subject: Reply with quote

ok i see, but where can i change this?
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 911
Location: Massachusetts USA

PostPosted: Fri Mar 22, 2013 6:29 pm    Post subject: Reply with quote

Post the output of the emerge --info command.
Back to top
View user's profile Send private message
dsamersoff
n00b
n00b


Joined: 20 Feb 2007
Posts: 30
Location: St.Petersburg,Russia

PostPosted: Sat Oct 24, 2015 10:55 am    Post subject: Reply with quote

Unfortunately have to revive this old thread - I hit the same problem cross-compiling: glibc blocks libiconv and libintl and I find no good solution for this problem.


Calculating dependencies... done!
[ebuild N *] dev-libs/libiconv-1.14-r2::gentoo to /usr/aarch64-unknown-linux-gnu/ USE="-abi_ppc_32 -abi_ppc_64 -abi_s390_32 -abi_s390_64 -static-libs" 0 KiB
[ebuild R ] virtual/libiconv-0-r2::gentoo to /usr/aarch64-unknown-linux-gnu/ USE="-abi_ppc_32 -abi_ppc_64 -abi_s390_32 -abi_s390_64" 0 KiB
[blocks B ] sys-libs/glibc ("sys-libs/glibc" is blocking dev-libs/libiconv-1.14-r2)
_________________
*There will come soft rains ...
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7021
Location: Goose Creek SC

PostPosted: Sat Oct 24, 2015 1:28 pm    Post subject: Reply with quote

Suggest:
Code:
emerge --unmerge devlibs/libiconv virtual/libiconv
emerge -1 virtual/libiconv

While investigating, I ran:
emerge -s libiconv
and got:
[ Results for search key : libiconv ]
Searching...

* dev-libs/libiconv
Latest version available: 1.14-r1
Latest version installed: [ Not Installed ]
Size of files: 4,868 KiB
Homepage: https://www.gnu.org/software/libiconv/
Description: GNU charset conversion library for libc which doesn't implement it
License: GPL-3

* virtual/libiconv
Latest version available: 0-r2
Latest version installed: 0-r2
Size of files: 0 KiB
Homepage:
Description: Virtual for the GNU conversion library
License:

[ Applications found : 2 ]
Then:
emerge -av libiconv
And got:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] virtual/libiconv-0-r2::gentoo ABI_X86="32 (64) (-x32)" 0 KiB
Which emerged successfully.
Then:
merge --unmerge libiconv
* This action can remove important packages! In order to be safer, use
* `emerge -pv --depclean <atom>` to check for reverse dependencies before
* removing packages.

virtual/libiconv
selected: 0-r2
protected: none
omitted: none

All selected packages: =virtual/libiconv-0-r2
Which unmerged.
Then:
emerge -av libiconv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] dev-libs/libiconv-1.14-r1::gentoo USE="static-libs" ABI_X86="32 (64) (-x32)" 4,868 KiB
[blocks B ] sys-libs/glibc ("sys-libs/glibc" is blocking dev-libs/libiconv-1.14-r1)
Looks like your problem.
Then:
emerge -1 virtual/libiconv
Restored original situation which had no problem.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum