Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dbus-python
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
gulbuhar
n00b
n00b


Joined: 12 Apr 2015
Posts: 9

PostPosted: Sat Oct 24, 2015 11:00 am    Post subject: dbus-python Reply with quote

$sudo emerge --update --newuse --deep --ask --with-bdeps=y @world

* IMPORTANT: 16 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] dev-libs/elfutils-0.163 USE="static-libs*"

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/dbus-python:0

(dev-python/dbus-python-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
>=dev-python/dbus-python-0.80[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)

==========================

$ sudo PYTHON_TARGETS="python3_4" emerge --backtrack=30 -av dbus-python

* IMPORTANT: 16 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] dev-python/dbus-python-1.2.0-r1::gentoo USE="-doc -examples {-test}" PYTHON_TARGETS="python3_4* -python2_7* -python3_3* (-python3_5)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/dbus-python:0

(dev-python/dbus-python-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
dev-python/dbus-python (Argument)

(dev-python/dbus-python-1.2.0-r1:0/0::gentoo, installed) pulled in by
>=dev-python/dbus-python-0.80[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)

>=dev-python/dbus-python-1.1.1-r1[python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (net-print/hplip-3.14.10:0/0::gentoo, installed)

dev-python/dbus-python[python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (dev-util/meld-3.14.0:0/0::gentoo, installed)

dev-python/dbus-python[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] required by (media-radio/radiotray-0.7.3-r2:0/0::gentoo, installed)



It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Sat Oct 24, 2015 2:47 pm    Post subject: Reply with quote

Well, your test is obviously incorrect, as one of your packages needs dbus-python for python27, but try something more simple, like 'emerge -1pv dbus-python PyQt4'.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Oct 24, 2015 2:58 pm    Post subject: Reply with quote

when you change useflags,e specially for pyhton or ruby, it may be smart to emerge those packages by hand single by single.

portage is known to have issues with dependency resolution, especially when you change those ruby / python slots.

And i believe, python 27 is mandatory, and some higher profile also like python 3.4.

I was unable to get rid of python 27 on my box a few weeks

suggestion => python 27 and python 34. globally.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum