Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Poppler fails during world upgrade. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Mon Mar 18, 2013 2:40 pm    Post subject: Poppler fails during world upgrade. [SOLVED] Reply with quote

I'm building a new installation using stage3-i686-20121213.tar.bz2 After getting the partition bootable I executed the following:
Code:
># emerge --sync
>#   :
># emerge gentoolkit
>#   :
># emerge -avuND world

At package 98 of 130 the 'poppler' build failed with:
Code:
/usr/lib/gcc/i686-pc-linux-gnu/4.5.4/../../../../i686-pc-linux-gnu/bin/ld: warning: libudev.so.1, needed by /usr/lib/libEGL.so.1, not found (try using -rpath or -rpath-link)
/usr/lib/libEGL.so.1: undefined reference to `udev_unref@LIBUDEV_183'
/usr/lib/libEGL.so.1: undefined reference to `udev_new@LIBUDEV_183'
   :
 [31;01m*[0m ERROR: app-text/poppler-0.22.2-r1 failed (compile phase):
 [31;01m*[0m   emake failed

I tried rebooting and emerging 'poppler' on its own with the same result. Could someone please suggest how to resolve this? I've posted the build.log at:

http://52midnight.com/build.log.html


Last edited by 52midnight on Mon Mar 18, 2013 7:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1531

PostPosted: Mon Mar 18, 2013 3:06 pm    Post subject: Reply with quote

52midnight ...

looks like your --update brought in udev and so broke media-libs/mesa which is linked to the old udev ... you may be able to work arround the issue with 'emerge --oneshot mesa' ... thought you may also have other packages which are also linked to libudev.so.1 and so revdep-rebuild may be a better approach.

HTH & best ... khay
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Mon Mar 18, 2013 7:32 pm    Post subject: Reply with quote

> revdep-rebuild may be a better approach.

Yep, first time I've seen its inbuilt smarts. Fixed the broken deps and then invoked 'emerge' with the correct switches to emerge mesa.

I was wondering why a 3D graphics library would be needed by a basic non-GUI installation, but I guess my setting USE="gtk" brought in new dependencies; there are now a heap of x11 packages installed.

Thanks very much for a crucial tip.
Back to top
View user's profile Send private message
khayyam
Veteran
Veteran


Joined: 07 Jun 2012
Posts: 1531

PostPosted: Mon Mar 18, 2013 8:02 pm    Post subject: Reply with quote

52midnight ...

You're welcome ... as far as having mesa, gtk, and x11, pulled in, this sounds as though the profile is set to something other than 'default/linux/x86/13.0'. If your building a non-gui/x11 target then you should change the profile to reflect this.

best ... khay
Back to top
View user's profile Send private message
52midnight
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2012
Posts: 129
Location: Brisbane AU

PostPosted: Mon Mar 18, 2013 8:05 pm    Post subject: Reply with quote

No, am set to ../13.0/desktop but hadn't realized it would start affecting things so early in the process.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum