Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge world not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Thu Apr 25, 2002 11:51 am    Post subject: emerge world not working Reply with quote

I did a world update 2 days ago, I am now trying to run it again but it is blowing up in my face. I looked in the world file and don't see this entry in there, I searched the portage tree and it isn't there (which might be the problem), any suggestions???

root@Inspiron jason # emerge --update world --pretend

These are the packages that I would merge, in order.

Calculating world dependencies /
!!! Error: couldn't find match for >=x11-libs/gtk+-2.0.0 in gnome-base/libglade-1.99.10-r1



thanks,

jason
Back to top
View user's profile Send private message
Target
Apprentice
Apprentice


Joined: 25 Apr 2002
Posts: 199

PostPosted: Thu Apr 25, 2002 11:56 am    Post subject: Reply with quote

Did you remember to emerge rsync?
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Thu Apr 25, 2002 12:10 pm    Post subject: Reply with quote

yeah, did that first
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Thu Apr 25, 2002 1:12 pm    Post subject: Reply with quote

I checked the portage tree on my system and the packages it is looking for are right there. tried doing some trickery with soft links, but that didn't work either. I will have to read through the ebuild scripts and see if there is anything in there.
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Thu Apr 25, 2002 1:55 pm    Post subject: Reply with quote

yeah those are the same I have in my portage tree as well. I thought that >= blah blah, meant that it is looking for the package with version or greater. I will try to get a few minutes and look at the ebuild.
Back to top
View user's profile Send private message
jcmc2000
n00b
n00b


Joined: 19 Apr 2002
Posts: 25
Location: Reston, Virginia

PostPosted: Thu Apr 25, 2002 2:06 pm    Post subject: Reply with quote

ok, it looks like gtk+ 2.x.x is masked in the portage tree so I can't (shouldn't emerge that) libglade 1.99 is looking for gtk+ 2.x.x so it can't build. For now I went into /var/cache/db/world and commented out the libglade entry.

I can now run emerge --update world, which I am doing right now. I will just have to make a mental note to update gtk+ when 2.x.x is available and working.

thanks for all the help


jason
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum