Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
abi_x86_32 Multilib madness [Not as SOLVED as I thought]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2799

PostPosted: Thu Apr 30, 2015 3:34 pm    Post subject: Reply with quote

Havin_it wrote:
Currently gcc[multilib] still depends on emul-linux-x86-* packages.
Where can you see this, which gcc version?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Apr 30, 2015 5:22 pm    Post subject: Reply with quote

charles17 wrote:
Havin_it wrote:
Currently gcc[multilib] still depends on emul-linux-x86-* packages.
Where can you see this, which gcc version?


Just about every, one detail though: gcc[multilib,gcj].
As for a workaround...
Make an overlay with those two emul-linux-x86 depends on, change the version to 9999 and turn them into metas for [abi_x86_32] packages gcj wants - look at GCJ_GTK_DEPS in toolchain eclass for the list.
Back to top
View user's profile Send private message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1172
Location: Edinburgh, UK

PostPosted: Thu Apr 30, 2015 5:44 pm    Post subject: Reply with quote

VoidMage wrote:
charles17 wrote:
Havin_it wrote:
Currently gcc[multilib] still depends on emul-linux-x86-* packages.
Where can you see this, which gcc version?


Just about every, one detail though: gcc[multilib,gcj].
As for a workaround...
Make an overlay with those two emul-linux-x86 depends on, change the version to 9999 and turn them into metas for [abi_x86_32] packages gcj wants - look at GCJ_GTK_DEPS in toolchain eclass for the list.


Ummm, I don't have USE=gcj, never have that I know of. Currently installed gcc versions are 4.8.3 and 4.9.2 (the latter is the active system compiler).

These are the dependencies equery is showing me at the moment:
Code:
hazel ~ # equery d `qlist -IC emul-linux-x86-`
 * These packages depend on app-emulation/emul-linux-x86-baselibs:
app-emulation/emul-linux-x86-gtklibs-20140508-r6 (~app-emulation/emul-linux-x86-baselibs-20140508)
app-emulation/emul-linux-x86-xlibs-20140508 (!abi_x86_32 ? ~app-emulation/emul-linux-x86-baselibs-20140508)
dev-util/android-sdk-update-manager-23 (app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)])

 * These packages depend on app-emulation/emul-linux-x86-gtklibs:
sys-devel/gcc-4.8.3 (multilib ? app-emulation/emul-linux-x86-gtklibs)
sys-devel/gcc-4.9.2 (multilib ? app-emulation/emul-linux-x86-gtklibs)

 * These packages depend on app-emulation/emul-linux-x86-opengl:
app-emulation/emul-linux-x86-gtklibs-20140508-r6 (~app-emulation/emul-linux-x86-opengl-20140508)
app-emulation/emul-linux-x86-xlibs-20140508 (opengl ? app-emulation/emul-linux-x86-opengl)

 * These packages depend on app-emulation/emul-linux-x86-xlibs:
app-emulation/emul-linux-x86-gtklibs-20140508-r6 (~app-emulation/emul-linux-x86-xlibs-20140508)
app-emulation/emul-linux-x86-opengl-20140508-r1 (!abi_x86_32 ? >=app-emulation/emul-linux-x86-xlibs-20100611)
sys-devel/gcc-4.8.3 (multilib ? app-emulation/emul-linux-x86-xlibs)
sys-devel/gcc-4.9.2 (multilib ? app-emulation/emul-linux-x86-xlibs)


I haven't done a world update in probably a couple of months, which might not help matters. I've just done @system but the @world may have to be done piecemeal because I need a lot of access to that box (and for it to continue working!) atm.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Apr 30, 2015 6:59 pm    Post subject: Reply with quote

'equery d' output is flawed bot in regard of useflags and OR deps.
Check the ebuilds/eclasses.
Back to top
View user's profile Send private message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1172
Location: Edinburgh, UK

PostPosted: Tue May 05, 2015 2:30 pm    Post subject: Reply with quote

VoidMage wrote:
'equery d' output is flawed bot in regard of useflags and OR deps.
Check the ebuilds/eclasses.


OK I see now, --depclean hadn't worked so I thought that was the problem without checking. It was actually only android-sdk-update-manager that was requiring them, and I don't need that atm so I jst uninstalled that too. So far zlib is the only thing I've had to add abi_x86_32 for.

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum