Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge Nvidia Driver - Unable to determine the target kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 737

PostPosted: Mon Mar 11, 2013 10:58 pm    Post subject: Emerge Nvidia Driver - Unable to determine the target kernel Reply with quote

I am running a chroot enviroment making a new root partition. For some reason, when trying to compile the nvidia driver it doesn't recognize the kernel version I am using because I get "*** Unable to determine the target kernel version. ***:

Code:

>>> Emerging (1 of 1) x11-drivers/nvidia-drivers-304.64
 * NVIDIA-Linux-x86_64-304.64.run SHA256 SHA512 WHIRLPOOL size ;-) ...   [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.7.10-gentoo/build
 * Found sources for kernel version:
 *     3.7.10-gentoo
 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-3.7
 * <sys-kernel/vanilla-sources-3.7
 *
 * You are free to utilize epatch_user to provide whatever
 * support you feel is appropriate, but will not receive
 * support as a result of those changes.
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-304.64.run to /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work ...
 * Converting /kernel/Makefile.kbuild to use M= instead of SUBDIRS= ...  [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work ...
 * Preparing nvidia module
make -j6 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/3.7.10-gentoo/build CC=x86_64-pc-linux-gnu-gcc clean module
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1
 * ERROR: x11-drivers/nvidia-drivers-304.64 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-304.64'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-304.64'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work/'

>>> Failed to emerge x11-drivers/nvidia-drivers-304.64, Log file:

>>>  '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/temp/build.log'

 * Messages for package x11-drivers/nvidia-drivers-304.64:

 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-3.7
 * <sys-kernel/vanilla-sources-3.7
 *
 * You are free to utilize epatch_user to provide whatever
 * support you feel is appropriate, but will not receive
 * support as a result of those changes.
 * ERROR: x11-drivers/nvidia-drivers-304.64 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-304.64'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-304.64'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work/kernel'
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work/'
localhost linux #



Code:

Available kernel symlink targets:
  [1]   linux-3.7.10-gentoo *
  [2]   linux-3.8.2-gentoo
localhost linux # ls   
COPYING        Module.symvers  drivers   lib              security
CREDITS        README          firmware  mm               sound
Documentation  REPORTING-BUGS  fs        modules.builtin  tools
Kbuild         System.map      include   modules.order    usr
Kconfig        arch            init      net              virt
MAINTAINERS    block           ipc       samples          vmlinux
Makefile       crypto          kernel    scripts          vmlinux.o
localhost linux # ls ../
linux  linux-3.7.10-gentoo  linux-3.8.2-gentoo
localhost linux # ls -al ../
total 16
drwxr-xr-x  4 root root 4096 Mar 11 07:23 .
drwxr-xr-x 13 root root 4096 Mar 11 02:52 ..
-rw-r--r--  1 root root    0 Jan 29 22:43 .keep
lrwxrwxrwx  1 root root   19 Mar 11 07:23 linux -> linux-3.7.10-gentoo
drwxr-xr-x 24 root root 4096 Mar 11 17:48 linux-3.7.10-gentoo
drwxr-xr-x 21 root root 4096 Mar 11 07:21 linux-3.8.2-gentoo
localhost linux #

localhost linux # ls -al
total 69788
drwxr-xr-x  24 root root     4096 Mar 11 17:48 .
drwxr-xr-x   4 root root     4096 Mar 11 07:23 ..
-rw-r--r--   1 root root    81006 Mar 11 07:28 .config
-rw-r--r--   1 root root    81286 Mar 11 07:28 .config.old
-rw-r--r--   1 root root     1115 Dec 10 21:30 .gitignore
-rw-r--r--   1 root root     4465 Dec 10 21:30 .mailmap
-rw-r--r--   1 root root      591 Mar 11 07:28 .missing-syscalls.d
-rw-r--r--   1 root root  2433794 Mar 11 07:39 .tmp_System.map
-rw-r--r--   1 root root  2639720 Mar 11 07:39 .tmp_kallsyms1.o
-rw-r--r--   1 root root  2639720 Mar 11 07:39 .tmp_kallsyms2.o
drwxr-xr-x   2 root root     4096 Mar 11 07:35 .tmp_versions
-rwxr-xr-x   1 root root 18772907 Mar 11 07:39 .tmp_vmlinux1
-rwxr-xr-x   1 root root 20870059 Mar 11 07:39 .tmp_vmlinux2
-rw-r--r--   1 root root        2 Mar 11 07:39 .version
-rw-r--r--   1 root root       75 Mar 11 07:39 .vmlinux.cmd


 
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 3924

PostPosted: Mon Mar 11, 2013 11:04 pm    Post subject: Reply with quote

know issue, nvidia drivers have problem with 3.7+ kernel for now, some solves exists, check : https://forums.gentoo.org/viewtopic-t-951692.html
even it's for 3.8 series, in it you will find the posts for 3.7
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum