Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Slow OpenGL When Moving Mouse In X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
svxs
n00b
n00b


Joined: 08 Mar 2013
Posts: 6

PostPosted: Fri Mar 08, 2013 7:17 pm    Post subject: Slow OpenGL When Moving Mouse In X Reply with quote

Hallo,

I'm experiencing a weird problem after upgrading from nvidia-drivers-310.32 to any newer version of nvidia-drivers (unpatched from portage).

OpenGL applications such as glxgears slow to a crawl in X when moving the mouse. Only when moving the mouse (depending on the WM, only when moving it over -windows-). It is so noticeable! Also, X uses a -tremendous- amount of CPU when the mouse is moving over any window.

Code:

root@alchemy:/home/fb# lspci | grep 660
02:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 660 Ti] (rev a1)

root@alchemy:/home/fb# uname -a
Linux alchemy 3.8.2-gentoo #1 SMP PREEMPT Fri Mar 8 12:27:25 CST 2013 x86_64 Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz GenuineIntel GNU/Linux

root@alchemy:/home/fb# dmesg | grep NVRM
[    4.505110] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  313.26  Wed Feb 27 13:04:31 PST 2013


Is anyone else experiencing such an issue?

Downgrading to nvidia-drivers-310.32 seems to fix it for me. However, I would really like to use the new 313.26 nVidia drivers, so if anyone knows what could be wrong or how to fix it, please share your information! Thanks. :>

Edit:

Changed the post to reflect that my recent upgrade to a newer kernel has nothing to do with this, since it happens with older kernels as well when upgrading to newer nVidia drivers.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Fri Mar 08, 2013 9:48 pm    Post subject: Reply with quote

As a guess, try these kernel options:
Code:
CONFIG_COMPACTION=n
CONFIG_KSM=n
CONFIG_PCI_DIRECT=y  # Avoids MMCONFIG, unwanted in Nvidia's README
USB_EHCI_TT_NEWSCHED=y  # Better USB handling
Back to top
View user's profile Send private message
svxs
n00b
n00b


Joined: 08 Mar 2013
Posts: 6

PostPosted: Fri Mar 08, 2013 10:58 pm    Post subject: Reply with quote

PaulBredbury wrote:
As a guess, try these kernel options:
Code:
CONFIG_COMPACTION=n
CONFIG_KSM=n
CONFIG_PCI_DIRECT=y  # Avoids MMCONFIG, unwanted in Nvidia's README
USB_EHCI_TT_NEWSCHED=y  # Better USB handling


Thank you for the suggestion!

I am afraid it did not help, though... I enabled CONFIG_KSM (all of the others were already set), and made sure to set /sys/kernel/mm/ksm/run to 1. It did not make any difference. :<

glxgears while the mouse is moving:

Code:

30882 frames in 5.0 seconds = 6176.351 FPS
15660 frames in 5.0 seconds = 3107.116 FPS
18398 frames in 5.0 seconds = 3676.764 FPS
28944 frames in 5.1 seconds = 5719.027 FPS
32981 frames in 5.0 seconds = 6531.477 FPS


glxgears with the mouse sitting still:

Code:

85565 frames in 5.0 seconds = 17112.891 FPS
85591 frames in 5.0 seconds = 17118.021 FPS
85655 frames in 5.0 seconds = 17130.883 FPS
85636 frames in 5.0 seconds = 17127.184 FPS
85625 frames in 5.0 seconds = 17124.846 FPS


So, so weird.

Edit:

Some new information!

I have disabled compositing inside of my WM (I use KDE4) and now I get a framerate similar to what I get with older drivers, even when the mouse is moving:

Code:

94571 frames in 5.0 seconds = 18914.150 FPS
94634 frames in 5.0 seconds = 18926.680 FPS
94795 frames in 5.0 seconds = 18959.000 FPS
94833 frames in 5.0 seconds = 18966.568 FPS
95032 frames in 5.0 seconds = 19006.244 FPS


However, there is something VERY odd going on. If I hold a key down to rotate the gears inside of glxgears -while moving the mouse over the window-, the animation is noticeably skippy and jerky and even locks up, although the framerate remains unchanged.

If I hold a key down to rotate it -without- moving the mouse, the animation stays fluid as it should. In both cases, the framerate is the same with compositing turned off.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sat Mar 09, 2013 3:46 am    Post subject: Reply with quote

"n" means No, i.e. disable. So if you enabled KSM, you did the OPPOSITE of what I suggested ;)
Back to top
View user's profile Send private message
svxs
n00b
n00b


Joined: 08 Mar 2013
Posts: 6

PostPosted: Sun Mar 10, 2013 4:22 am    Post subject: Reply with quote

PaulBredbury wrote:
"n" means No, i.e. disable. So if you enabled KSM, you did the OPPOSITE of what I suggested ;)


Good catch!

I _carefully_ set the settings you gave this time, but the problem remains the same.

Can anyone verify if this problem does/doesn't affect them as well?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum