Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Issues installing e100.ko module
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
mgmacri
n00b
n00b


Joined: 07 Mar 2013
Posts: 2
Location: vancouver

PostPosted: Thu Mar 07, 2013 11:22 pm    Post subject: Issues installing e100.ko module Reply with quote

Code:
lspci

Returns:
Code:
Ethernet controller: Intel Corp. 82557/8/9/0/1 Ethernet Pro 100 (rev 08)

And
Code:
dmesg

Returns:
Code:
warning: process `hwsetup' used the deprecated sysctl system call with 1.23.
e100 0000:00:0d.0: eth0: Failed to load firmware "e100/d101m_ucode.bin": -2
e100 0000:00:0d.0: eth1: Failed to load firmware "e100/d101m_ucode.bin": -2
NET: Registered protocol family 10
e100: Intel(R) PRO/100 Network Driver, 3.5.240-k2-NAPI
e100: Copyright(c) 1999-2006 Intel Corp.
e100 0000:00:0d.0: eth0: addr 0xd6202000, irq 17, MAC addr 00:e0:81:xx:xx:xx
e100 0000:00:0d.0: eth0: Failed to load firmware "e100/d101m_ucode.bin"
e100 0000:00:0d.0: eth1: addr 0xd6202000, irq 17, MAC addr 00:e0:81:xx:xx:xx
e100 0000:00:0d.0: eth1: Failed to load firmware "e100/d101m_ucode.bin"
e100: `' invalid for parameter `/sbin/netconfig'


Am I loading the incorrect module somehow? Any suggestions would be greatly appreciated. If you know of documentation pertaining to this issue I can and will read it.

Things I've tried: not relying on `uname -r` as the install text suggests, removing the module and re-adding it, listening to Aphex Twin.
_________________
i can do whatever i want
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42576
Location: 56N 3W

PostPosted: Thu Mar 07, 2013 11:30 pm    Post subject: Reply with quote

mgmacri,

Welcome to Gentoo.

You are loading the right module but the module is two pieces.

You have the kernel driver but the device needs a firmware file too.

Code:
e100 0000:00:0d.0: eth0: Failed to load firmware "e100/d101m_ucode.bin": -2

The firmware is provided by the linux-firmware package.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mgmacri
n00b
n00b


Joined: 07 Mar 2013
Posts: 2
Location: vancouver

PostPosted: Fri Mar 08, 2013 12:28 am    Post subject: Reply with quote

NeddySeagoon wrote:
mgmacri,

Welcome to Gentoo.

You are loading the right module but the module is two pieces.

You have the kernel driver but the device needs a firmware file too.

Code:
e100 0000:00:0d.0: eth0: Failed to load firmware "e100/d101m_ucode.bin": -2

The firmware is provided by the linux-firmware package.


Any way to grab that package on one of my other boxes and copy it to an external drive?
Code:
livecd ~ # ls -ls /lib/firmware

Code:
total 0

_________________
i can do whatever i want
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42576
Location: 56N 3W

PostPosted: Fri Mar 08, 2013 8:14 pm    Post subject: Reply with quote

mgmacri,

On your Gentoo, do
Code:
emerge linux-firmware -fp

It will provide a file list for you to download.

If your mirror list has several mirrors in it, each file will be listed for each mirror. You only need each file once.

Download the file(s).
Put the file(s) into /usr/portage/distfiles

Use a USB memory stick, USB drive, CDROM ... whatever for the transfer.

Run
Code:
emerge linux-firmware

As you have the files in your distfiles already, portage will not try to download them.

Homework: Read up on Sneakernet :)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum