Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X10 remote stopped working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Bragor
n00b
n00b


Joined: 06 Mar 2013
Posts: 3

PostPosted: Wed Mar 06, 2013 9:38 pm    Post subject: X10 remote stopped working Reply with quote

A couple of days ago I upgraded from udev-171 to udev-197-r8 and hardened-sources-3.5.4 to hardened-sources-3.7.5. After that upgrade my X10 remote control stopped working. I spent several days now trying to get it working again - still not working. I see the remote with evtest and ir-keytable but I don't see any keypresses not even with cat /dev/input/event3.

dmesg:
Code:

[    8.168335] usb 1-1.6: new low-speed USB device number 4 using ehci-pci
[    8.258897] usb 1-1.6: New USB device found, idVendor=0bc7, idProduct=0006
[    8.258908] usb 1-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    8.258910] usb 1-1.6: Product: USB Receiver
[    8.258911] usb 1-1.6: Manufacturer: X10 Wireless Technology Inc
[    8.313327] Registered IR keymap rc-medion-x10-digitainer
[    8.313398] input: X10 Wireless Technology Inc USB Receiver as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/rc/rc0/input3
[    8.313446] rc0: X10 Wireless Technology Inc USB Receiver as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/rc/rc0
[    8.313475] input: X10 Wireless Technology Inc USB Receiver mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/input/input4
[    8.313527] usbcore: registered new interface driver ati_remote


ir-keytable:
Code:

Found /sys/class/rc/rc0/ (/dev/input/event3) with:
        Driver ati_remote, table rc-medion-x10-digitainer
        Supported protocols: other
        Enabled protocols: other
        Repeat delay = 500 ms, repeat period = 125 ms


cat /proc/bus/input/devices:
Code:

I: Bus=0003 Vendor=0bc7 Product=0006 Version=0100
N: Name="X10 Wireless Technology Inc USB Receiver"
P: Phys=usb-0000:00:1a.0-1.6/input0
S: Sysfs=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/rc/rc0/input3
U: Uniq=
H: Handlers=kbd event3
B: PROP=0
B: EV=100013
B: KEY=400000010afc332 200204300000000 0 108000 180c0000801 9e168000000000 ffc
B: MSC=10

I: Bus=0003 Vendor=0bc7 Product=0006 Version=0100
N: Name="X10 Wireless Technology Inc USB Receiver mouse"
P: Phys=usb-0000:00:1a.0-1.6/input1
S: Sysfs=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/input/input4
U: Uniq=
H: Handlers=mouse0 event4
B: PROP=0
B: EV=7
B: KEY=1b0000 0 0 0 0
B: REL=3


udevadm:
Code:

looking at device '/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/rc/rc0/input3/event3':
    KERNEL=="event3"
    SUBSYSTEM=="input"
    DRIVER==""

  looking at parent device '/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/rc/rc0/input3':
    KERNELS=="input3"
    SUBSYSTEMS=="input"
    DRIVERS==""
    ATTRS{name}=="X10 Wireless Technology Inc USB Receiver"
    ATTRS{phys}=="usb-0000:00:1a.0-1.6/input0"
    ATTRS{uniq}==""
    ATTRS{properties}=="0"

  looking at parent device '/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/rc/rc0':
    KERNELS=="rc0"
    SUBSYSTEMS=="rc"
    DRIVERS==""
    ATTRS{protocols}=="[other]"

  looking at parent device '/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0':
    KERNELS=="1-1.6:1.0"
    SUBSYSTEMS=="usb"
    DRIVERS=="ati_remote"
    ATTRS{bInterfaceClass}=="ff"
    ATTRS{bInterfaceSubClass}=="00"
    ATTRS{bInterfaceProtocol}=="00"
    ATTRS{bNumEndpoints}=="02"
    ATTRS{supports_autosuspend}=="0"
    ATTRS{bAlternateSetting}==" 0"
    ATTRS{bInterfaceNumber}=="00"

  looking at parent device '/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6':
    KERNELS=="1-1.6"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{bDeviceSubClass}=="00"
    ATTRS{bDeviceProtocol}=="00"
    ATTRS{devpath}=="1.6"
    ATTRS{idVendor}=="0bc7"
    ATTRS{speed}=="1.5"
    ATTRS{bNumInterfaces}==" 1"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bMaxPacketSize0}=="8"
    ATTRS{busnum}=="1"
    ATTRS{devnum}=="4"
    ATTRS{configuration}==""
    ATTRS{bMaxPower}=="  2mA"
    ATTRS{authorized}=="1"
    ATTRS{bmAttributes}=="a0"
    ATTRS{bNumConfigurations}=="1"
    ATTRS{maxchild}=="0"
    ATTRS{bcdDevice}=="0100"
    ATTRS{avoid_reset_quirk}=="0"
    ATTRS{quirks}=="0x0"
    ATTRS{version}==" 1.10"
    ATTRS{urbnum}=="13"
    ATTRS{ltm_capable}=="no"
    ATTRS{manufacturer}=="X10 Wireless Technology Inc"
    ATTRS{removable}=="removable"
    ATTRS{idProduct}=="0006"
    ATTRS{bDeviceClass}=="00"
    ATTRS{product}=="USB Receiver"

  looking at parent device '/devices/pci0000:00/0000:00:1a.0/usb1/1-1':
    KERNELS=="1-1"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{bDeviceSubClass}=="00"
    ATTRS{bDeviceProtocol}=="01"
    ATTRS{devpath}=="1"
    ATTRS{idVendor}=="8087"
    ATTRS{speed}=="480"
    ATTRS{bNumInterfaces}==" 1"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bMaxPacketSize0}=="64"
    ATTRS{busnum}=="1"
    ATTRS{devnum}=="2"
    ATTRS{configuration}==""
    ATTRS{bMaxPower}=="  0mA"
    ATTRS{authorized}=="1"
    ATTRS{bmAttributes}=="e0"
    ATTRS{bNumConfigurations}=="1"
    ATTRS{maxchild}=="6"
    ATTRS{bcdDevice}=="0000"
    ATTRS{avoid_reset_quirk}=="0"
    ATTRS{quirks}=="0x0"
    ATTRS{version}==" 2.00"
    ATTRS{urbnum}=="68"
    ATTRS{ltm_capable}=="no"
    ATTRS{removable}=="fixed"
    ATTRS{idProduct}=="0024"
    ATTRS{bDeviceClass}=="09"

  looking at parent device '/devices/pci0000:00/0000:00:1a.0/usb1':
    KERNELS=="usb1"
    SUBSYSTEMS=="usb"
    DRIVERS=="usb"
    ATTRS{bDeviceSubClass}=="00"
    ATTRS{bDeviceProtocol}=="00"
    ATTRS{devpath}=="0"
    ATTRS{idVendor}=="1d6b"
    ATTRS{speed}=="480"
    ATTRS{bNumInterfaces}==" 1"
    ATTRS{bConfigurationValue}=="1"
    ATTRS{bMaxPacketSize0}=="64"
    ATTRS{authorized_default}=="1"
    ATTRS{busnum}=="1"
    ATTRS{devnum}=="1"
    ATTRS{configuration}==""
    ATTRS{bMaxPower}=="  0mA"
    ATTRS{authorized}=="1"
    ATTRS{bmAttributes}=="e0"
    ATTRS{bNumConfigurations}=="1"
    ATTRS{maxchild}=="2"
    ATTRS{bcdDevice}=="0308"
    ATTRS{avoid_reset_quirk}=="0"
    ATTRS{quirks}=="0x0"
    ATTRS{serial}=="0000:00:1a.0"
    ATTRS{version}==" 2.00"
    ATTRS{urbnum}=="24"
    ATTRS{ltm_capable}=="no"
    ATTRS{manufacturer}=="Linux 3.8.0-hardened-r1 ehci_hcd"
    ATTRS{removable}=="unknown"
    ATTRS{idProduct}=="0002"
    ATTRS{bDeviceClass}=="09"
    ATTRS{product}=="EHCI Host Controller"

  looking at parent device '/devices/pci0000:00/0000:00:1a.0':
    KERNELS=="0000:00:1a.0"
    SUBSYSTEMS=="pci"
    DRIVERS=="ehci-pci"
    ATTRS{irq}=="16"
    ATTRS{subsystem_vendor}=="0x1462"
    ATTRS{broken_parity_status}=="0"
    ATTRS{class}=="0x0c0320"
    ATTRS{companion}==""
    ATTRS{consistent_dma_mask_bits}=="32"
    ATTRS{dma_mask_bits}=="32"
    ATTRS{local_cpus}=="f"
    ATTRS{device}=="0x1e2d"
    ATTRS{uframe_periodic_max}=="100"
    ATTRS{enable}=="1"
    ATTRS{msi_bus}==""
    ATTRS{local_cpulist}=="0-3"
    ATTRS{vendor}=="0x8086"
    ATTRS{subsystem_device}=="0x7758"
    ATTRS{d3cold_allowed}=="1"

  looking at parent device '/devices/pci0000:00':
    KERNELS=="pci0000:00"
    SUBSYSTEMS==""
    DRIVERS==""


Does anybody have any idea what I could try?
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8602

PostPosted: Thu Mar 07, 2013 3:12 am    Post subject: Reply with quote

Is the problem reproducible with sys-kernel/vanilla-sources?
Back to top
View user's profile Send private message
Bragor
n00b
n00b


Joined: 06 Mar 2013
Posts: 3

PostPosted: Fri Mar 08, 2013 9:56 am    Post subject: X10 remote stopped working Reply with quote

The problem was apparently in hardened-sources 3.7.5, 3.8.0 and 3.8.0-r1. After I upgraded to hardened-sources-3.8.2 I received input in ir-keytable again. Therefore I didn't test with vanilla-sources.

I have to correct myself.
It was just coincidence that I saw some input. When I press many keys at once or in short order, sometimes a signal seems to be generated.
Apart from that, neither with hardened-sources-3.8.2 nor with vanilla-sources-3.7.10 I receive a signal in ir-keytable, evtest or cat /dev/input/event3.

Does anybody know what else I could try?
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8602

PostPosted: Fri Mar 08, 2013 11:45 pm    Post subject: Reply with quote

If this fails in vanilla-sources, and an older version works, then file a bug report with the kernel maintainers. Be prepared to be asked to bisect this down to the specific commit that broke it.
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 402
Location: North~Sea~Coa~s~~t~~~

PostPosted: Sat Mar 09, 2013 8:17 pm    Post subject: Reply with quote

Hi,

There have been some changes in menuconfig of the kernel for Multimedia support, so you'll have to reenable the modules you need.

It should probably look like this:
Code:
Device Drivers  --->
Multimedia support  --->
[*]   Remote Controller support
<M>   Compile Remote Controller keymap modules
[*]   Remote Controller devices  --->
<M>   ATI / X10 based USB RF remote controls
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum