Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
webkit-gtk r200 vs r300 [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 415
Location: Nederland

PostPosted: Wed Mar 06, 2013 4:46 pm    Post subject: webkit-gtk r200 vs r300 [Solved] Reply with quote

hello all,

after doing an emerge auvD world and waiting for my laptop to finish emerging webkit-gtk r200 and r300 during 5 hours, I wander if it sould be possible to remove completly one of them

Code:
equery depends net-libs/webkit-gtk
 * These packages depend on net-libs/webkit-gtk:
app-pda/gtkpod-2.1.2 (>=net-libs/webkit-gtk-1.3:3)
dev-python/pywebkitgtk-1.1.8 (>=net-libs/webkit-gtk-1.1.15:2)
media-gfx/gimp-2.8.2 (webkit ? >=net-libs/webkit-gtk-1.6.1:2)
net-libs/libproxy-0.4.10-r1 (webkit ? >=net-libs/webkit-gtk-1.6:3)


here I can see that gtkpod (I use it for my ipod) use webkit-gtk r300 while gimp use r200

Is it possible to force the install of gimp with r300 ?
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"


Last edited by reup on Wed Mar 06, 2013 8:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2207
Location: UK

PostPosted: Wed Mar 06, 2013 5:13 pm    Post subject: Reply with quote

r300 is for GTK+3 only, so no.
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 415
Location: Nederland

PostPosted: Wed Mar 06, 2013 5:30 pm    Post subject: Reply with quote

GTK means Gimp toolkit no ? meaning that gimp use version 2 of gtk+ while the version 3 is used by other package ?

weird. so no way to force the use of one OR the other ?

thank you for the quick answer. I guess I have to plan my emerge for nights or weekend
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 221
Location: England, UK

PostPosted: Wed Mar 06, 2013 6:02 pm    Post subject: Reply with quote

Run

Code:
emerge -pv --depclean webkit-gtk:2

To see what requires webkit-gtk-r200
and
Code:
emerge -pv --depclean webkit-gtk:3

to see what requires webkit-gtk-r300.
You may be able to get rid of something you don't need, alter flags or whatever to try get rid of one.

The difference between the two is that webkit-gtk:2 is now 'old' and afiak may be being stopped sooner rather then later if not already because; 1) Gnome people are working gtk3 now and 2) Webkit2 is only being put across for gtk3 (in gentoo that translates to webkit-gtk:3) because of reason 1.

Webkit-gtk for gtk2 will never get the new/developing webkit2. At this point in time of "heavy development" though, support for flash and such is not in webkit2 without crappy wrappers like nsplugin or something (I didn't even bother testing it, I finally forced myself to get rid of flash entirely) but the benefits/features/improvements of webkit2 far outweigh loosing flash for some time after using webkit1, personally, which now I look back I would class as just buggy - anyway if you want to get rid of one, depending on your needs you may wish to try get rid of the webkit2/webkit-gtk:3 for now.

I hope that makes some sense, these version numbers inside each other become very confusing to explain.
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 415
Location: Nederland

PostPosted: Wed Mar 06, 2013 6:59 pm    Post subject: Reply with quote

Code:
ABC ~ # emerge -pv --depclean webkit-gtk:2

Calculating dependencies... done!
  net-libs/webkit-gtk-1.8.3-r200 pulled in by:
    dev-python/pywebkitgtk-1.1.8 requires >=net-libs/webkit-gtk-1.1.15:2
    media-gfx/gimp-2.8.4 requires >=net-libs/webkit-gtk-1.6.1:2


as you can see, gimp require webkit-gtk:2. this is what I cannot understand, almost every linux computer have Gimp installed. It is a choise, but a very important package for a home desktop. so how can I get webkit-gtk:2 out and keep THE GIMP ?
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2207
Location: UK

PostPosted: Wed Mar 06, 2013 7:15 pm    Post subject: Reply with quote

Simple: rewrite Gimp to use GTK+ version 3.x instead of version 2.x.
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 415
Location: Nederland

PostPosted: Wed Mar 06, 2013 7:19 pm    Post subject: Reply with quote

Quote:
Simple: rewrite Gimp to use GTK+ version 3.x instead of version 2.x.


he he, good one. I am taking my pen and start immediately. might be done in a century or so, with my understanding of programing. I hope nobody will wait for me ! :D
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 221
Location: England, UK

PostPosted: Wed Mar 06, 2013 7:26 pm    Post subject: Reply with quote

I'm not entirely sure what the programs you use here actually use webkit for entirely (do they browse the web in some way or something slightly more simple??) but do you actually need webkit support for gimp? If that is the only package bringing in webkit-gtk:2 I'd be inclined to -webkit on gimp.

Sorry if that is a stupid question but many people I speak to who use gimp for image editing don't even need gimp for what they do, let alone *advanced* things to do with the web.
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 415
Location: Nederland

PostPosted: Wed Mar 06, 2013 7:33 pm    Post subject: Reply with quote

I already have -webkit in my gimp settings : (last word of the following code)

Code:
[I] media-gfx/gimp
     Available versions:  (2) 2.6.12-r5 ~2.8.2 ~2.8.2-r1 ~2.8.4 **9999
        {{aalib alsa altivec bzip2 curl dbus debug doc exif gnome jpeg jpeg2k lcms linguas_am linguas_ar linguas_ast linguas_az linguas_be linguas_bg linguas_br linguas_ca linguas_ca@valencia linguas_cs linguas_csb linguas_da linguas_de linguas_dz linguas_el linguas_en_CA linguas_en_GB linguas_eo linguas_es linguas_et linguas_eu linguas_fa linguas_fi linguas_fr linguas_ga linguas_gl linguas_gu linguas_he linguas_hi linguas_hr linguas_hu linguas_id linguas_is linguas_it linguas_ja linguas_ka linguas_kk linguas_km linguas_kn linguas_ko linguas_lt linguas_lv linguas_mk linguas_ml linguas_mr linguas_ms linguas_my linguas_nb linguas_nds linguas_ne linguas_nl linguas_nn linguas_oc linguas_or linguas_pa linguas_pl linguas_pt linguas_pt_BR linguas_ro linguas_ru linguas_rw linguas_si linguas_sk linguas_sl linguas_sr linguas_sr@latin linguas_sv linguas_ta linguas_te linguas_th linguas_tr linguas_tt linguas_uk linguas_vi linguas_xh linguas_yi linguas_zh_CN linguas_zh_HK linguas_zh_TW mmx mng pdf png postscript python smp sse svg tiff udev webkit wmf xpm}}
     Installed versions:  2.6.12-r5(2)(12:43:10 AM 02/01/2013)(alsa curl dbus jpeg linguas_en_GB linguas_fr linguas_nl mmx mng pdf png python sse svg wmf -aalib -altivec -debug -doc -exif -gnome -lcms -linguas_am -linguas_ar -linguas_ast -linguas_az -linguas_be -linguas_bg -linguas_ca -linguas_ca@valencia -linguas_cs -linguas_da -linguas_de -linguas_dz -linguas_el -linguas_en_CA -linguas_eo -linguas_es -linguas_et -linguas_eu -linguas_fa -linguas_fi -linguas_ga -linguas_gl -linguas_gu -linguas_he -linguas_hi -linguas_hr -linguas_hu -linguas_id -linguas_is -linguas_it -linguas_ja -linguas_ka -linguas_kk -linguas_km -linguas_kn -linguas_ko -linguas_lt -linguas_lv -linguas_mk -linguas_ml -linguas_mr -linguas_ms -linguas_my -linguas_nb -linguas_nds -linguas_ne -linguas_nn -linguas_oc -linguas_or -linguas_pa -linguas_pl -linguas_pt -linguas_pt_BR -linguas_ro -linguas_ru -linguas_rw -linguas_si -linguas_sk -linguas_sl -linguas_sr -linguas_sr@latin -linguas_sv -linguas_ta -linguas_th -linguas_tr -linguas_tt -linguas_uk -linguas_vi -linguas_xh -linguas_yi -linguas_zh_CN -linguas_zh_HK -linguas_zh_TW -smp -tiff -webkit

_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 221
Location: England, UK

PostPosted: Wed Mar 06, 2013 7:40 pm    Post subject: Reply with quote

Strange, I have -webkit set for gimp also but it hasn't pulled in webkit-gtk - when I enable the use I get:

Code:
ray@gentoo ~ % USE=webkit emerge -pv gimp

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] net-libs/webkit-gtk-1.8.3-r200:2 [1.10.2-r300:3] USE="jit spell webgl (-aqua) -coverage -debug -geoloc -gstreamer -introspection {-test}" 7,631 kB
[ebuild   R    ] media-gfx/gimp-2.8.4:2  USE="alsa bzip2 curl dbus exif jpeg jpeg2k lcms mmx pdf png python smp sse svg tiff udev webkit* xpm -aalib (-altivec) -debug -doc -gnome -mng -postscript -wmf" 0 kB

Total: 2 packages (1 in new slot, 1 reinstall), Size of downloads: 7,631 kB



Have you rebuilt gimp with -webkit option yet?
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 415
Location: Nederland

PostPosted: Wed Mar 06, 2013 7:47 pm    Post subject: Reply with quote

gimp was build without webkit, but I am re-emerging the package just now. I will see after that if it is still required

I think I will just use depclean to locate all package that needs webkit and will find alternative programs for them. 5 hours just to upgrade webkit seems a bit excessive

by the way, dual-core laptop, not the last monster but still should be able to do it in better time. I have been upgrading system and world since 3 days now. still revdrebuild to run :?
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 221
Location: England, UK

PostPosted: Wed Mar 06, 2013 8:03 pm    Post subject: Reply with quote

You could always just globally -webkit - I don't think anything hard-depends on it you should be able to remove it and not have to find new software.

Lets take a look at what you have with the help of equery uses *package*:
Code:
app-pda/gtkpod-2.1.2 (>=net-libs/webkit-gtk-1.3:3)
 - - webkit    : Enable webkit support for finding coverart

dev-python/pywebkitgtk-1.1.8 (>=net-libs/webkit-gtk-1.1.15:2)
-- Nothing, dependency of webkit-gtk maybe?

media-gfx/gimp-2.8.2 (webkit ? >=net-libs/webkit-gtk-1.6.1:2)
 - - webkit              : Add support for the WebKit HTML rendering/layout engine

net-libs/libproxy-0.4.10-r1 (webkit ? >=net-libs/webkit-gtk-1.6:3)
 - - webkit         : Use libjavascriptcoregtk from net-libs/webkit-gtk for PAC parsing


It looks as though you have webkit enabled globally? Do you actually need any of those things? Disable it global and rebuild gimp and gtkpod - then try depcleaning webkit-gtk away again.

Heh, webkit is quite a large beast and takes some time with everything enabled in it - I disable most of it since I only need it to look at web pages, not play media or stream from the pages and it actually made to build time significantly shorter if I remember correctly, I haven't had to build it for some time :)
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 415
Location: Nederland

PostPosted: Wed Mar 06, 2013 8:11 pm    Post subject: Reply with quote

you are right, I have webkit declared globally, but following your steps, I am re-emerging all packages depending on webkit-gtk:2 without the use flag webkit, then I will remove this version of webkit-gtk. just gimp to rebuild then I can do it

below, the packages uses webkit. I will investigate if they need version 2 or 3

Code:
eix -c --installed-with-use webkit
[I] dev-python/PyQt4 (4.9.6-r2@02/27/2013): Python bindings for the Qt toolkit
[I] kde-base/kget (4.10.0(4)@03/02/2013): An advanced download manager for KDE
[I] net-irc/quassel (0.8.0@08/21/2012): Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity.
[I] net-libs/libproxy (0.4.10-r1@12/05/2012): Library for automatic proxy configuration management
[I] x11-libs/qt-declarative (4.8.4(4)@01/29/2013): The Declarative module for the Qt toolkit
Found 5 matches.

_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 415
Location: Nederland

PostPosted: Wed Mar 06, 2013 8:13 pm    Post subject: Reply with quote

actually, the packages I mention in previous post need webkit, but not webkit-gtk, so operation completed, only gimp to re-emerge then I can remove webkit-gtk:2
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 221
Location: England, UK

PostPosted: Wed Mar 06, 2013 8:49 pm    Post subject: Reply with quote

Alright, hopefully this should remove webkit-gtk:2.

If you are keeping webkit-gtk:3 I can only assume only gtkpod is pulling that in, if you want that coverart finding support we can assume you don't need the webkit-gtk's video streaming/playing (basically HTML5 video support). You should be able to build webkit-gtk:3 with -introspection -gstreamer - I'm sure that was what cut down the compile times on my webkit-gtk, since you need none of those for getting cover art it may be worth trying without those when you have some free time or whatever.

Edit: I just checked libproxy, if you do want to get rid of webkit-gtk:3 you will need to use -webkit on gtkpod and libproxy || for me libproxy will use my webkit-gtk:3.
Back to top
View user's profile Send private message
reup
Guru
Guru


Joined: 13 May 2005
Posts: 415
Location: Nederland

PostPosted: Wed Mar 06, 2013 8:57 pm    Post subject: Reply with quote

thanks rorgoroth

you are right, I need only gtkpod with webkit-gtk, I manage to remove the rest (some old note taking program....)

I have a quad-core that I can use for test as well, I will try to rebuild webkit-gtk with a minimum of flags (I have also geoloc enable, I don't know me why)

I will change this post to solved. thanks again for your support
_________________
reup

"Don't wiggle the tail of the frog in the oil of the frying peanuts"
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 221
Location: England, UK

PostPosted: Wed Mar 06, 2013 9:00 pm    Post subject: Reply with quote

You're most welcome :)

Also I look at my flags for webkit-gtk and I have -geoloc also, you should be able to disable geoloc and webgl too now I look at the use flags available.
No problem, have fun testing 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum