Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Stale NFS File Handles
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message

Joined: 22 Jun 2006
Posts: 360

PostPosted: Sun Nov 10, 2013 6:25 pm    Post subject: [Solved] Stale NFS File Handles Reply with quote

I went to log in to KDE today and got an error that .kde4/share/apps/kfileplaces/config.xml cannot be written, followed by an X crash. When I investigated, both the find command and ls reported stale NFS file handles. I find this troubling because I don't use NFS, and don't even have it emerged. As a check, I looked in /etc/init.d and confirmed there is not NFS or portmap init script. I rebooted from a LiveDVD and ran fsck on the file system and it quickly returned a response that the file system is clean. It is using JFS, which I used because I wanted to try something new... probably a mistake in this case. So reboots don't fix the problem, I can't restart NFS because it isn't on the system, and I can't delete the files for the same reason KDE cannot write to them. I was able to mv the home folder and create a new one, but I don't want to go through that every week. Can someone give me an idea as to how to remove the files that have "stale NFS file handles"?


Edit: I went back and tried fsck one last time with the option to scan even if the filesystem is clean- fixed it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum