Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
uxterm displaying special characters incorrectly? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tld
l33t
l33t


Joined: 09 Dec 2003
Posts: 773

PostPosted: Sun Mar 03, 2013 10:41 pm    Post subject: uxterm displaying special characters incorrectly? [SOLVED] Reply with quote

I have a string issue in uxterm on my MythTV frontend.

I run the frontend within fluxbox. I have hotkeys set up to open a uxterm window. My TERM is set to xterm and my locale is all en_US.UTF-8.

Special characters don't display correctly. Some examples are the "fancy" quote characters around file names in the confirmation prompt of "rm -i", or the characters used to make the level bars in an alsamixer screen.

What's especially odd is that, if I ssh to it remotely from a uxterm window and log in as the mythtv user, it looks fine, and the environment as far as I can see is essentially identical.

In case it makes a difference, the way things are run on that frontend are a little unusual...that is the way I auto start mythfrontend. I have it starting from inittab with this:

Code:
c6:2345:respawn:/usr/bin/openvt -fwc 2 -- /bin/su -l -c "/usr/bin/startx > /dev/null" mythtv


The fact that that uses su -l makes me assume the environment should be getting set up ok. Then, at the end of the mythtv users .fluxbox/startup, where it would usually do just "exec /usr/bin/fluxbox" I have this:

Code:
/usr/bin/fluxbox &
sleep 2
exec /usr/bin/mythfrontend -l /var/log/mythtv/mythfrontend.log -v important,general


Not sure if any of that would be an issue or not. Any ideas?

Tom


Last edited by tld on Sun Mar 03, 2013 11:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
tld
l33t
l33t


Joined: 09 Dec 2003
Posts: 773

PostPosted: Sun Mar 03, 2013 11:12 pm    Post subject: Reply with quote

OK...I figured out the issue mostly...I just don't know what to do about it. In order to have a readable font size on my 52" 16:9 screen, I have this in .Xdefaults:

Code:
xterm*font: -misc-fixed-*-*-*-*-26-*-*-*-*-*-*-*


That apparently does not want to display special characters correctly.

Now it's all coming back to me that, when I originally set that up, it took me forever to get a really big font size, and that was all that I could find that would work. I recall that essentially everything I read online about increasing that font size in uxterm simply did NOT work...just plain painful.

Any ideas on a setting that would render more nicely with a huge font size like that??

Tom
Back to top
View user's profile Send private message
tld
l33t
l33t


Joined: 09 Dec 2003
Posts: 773

PostPosted: Sun Mar 03, 2013 11:29 pm    Post subject: Reply with quote

Ah...got it. I just changed the .Xdefaults to just override the font size with this:

Code:
xterm*font: 10x20


Tom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum